w3hello.com logo
Home PHP C# C++ Android Java Javascript Python IOS SQL HTML videos Categories
is there software for jar file copy protection, or licensing software
Copy protection can't prevent your file to be copied but you can make it fail when it is run on unlicensed machines. Selection of a copy protection mechanism is a matter of budget and time. There are many companies with many products. You can go with not yet cracked technologies like iLok etc. This is applicable for very high revenue cases. But if your target audience is less than 1000 people then a simple in-house solution might work. Consequence of a complex method is typically many calls to support line and unhappy customers. Things got a lot easier after clients are all connected to internet. You can make some simple parts to run on server which a cracker would never dive into for a replacement. Or the app might download the contents from server after installation. Latter is what I d

Categories : Misc

ERROR: Error installing jquery-rails: activesupport requires Ruby version >= 1.9.3. in Ubuntu 10.04
sudo gem install jquery-rails is probably using your system's built-in Ruby (which is likely 1.8, or 1.9.2). This is because you're using sudo. With RVM, get rid of the sudo and it'll use RVM instead: gem install jquery-rails

Categories : Ruby On Rails

Get software's information in WiX from software
The WiX.chm documents all the standard binder variables at the bottom of the topic titled Linker (light). It does not appear the those pieces of information are available. However, it might be something you could work with the WiX toolset community with to get the code added.

Categories : Wix

Error using amazon EC2(ubuntu)
This means the SSH server is presenting a different RSA key than when you first connected to the server on this IP address. If you changed the instance running on this IP address/hostname, this should be expected. If this is a completely unexpected error message, this is for your own protection. There's a chance someone could be doing something malicious and monitoring the connection. If you want to override it, go to C:Users[your username].sshknown_hosts and remove the offending line that starts with the hostname and/or IP address of the SSH server. Then reconnect to the server.

Categories : Ubuntu

Ubuntu Installation Error
Did you include the init script into your bash_profile/bashrc? RVM installed by ruby not working?

Categories : Ruby On Rails

segmentation-error in ubuntu gcc
gets() is dereferencing an unitialized pointer, causing undefined behaviour. Allocate memory for ch and don't use gets() as there is no way to limit the number of characters read, meaning potentially writing beyond the bounds of the destination array. Example using fgets(): char ch[128]; if (fgets(ch, 128, stdin)) { }

Categories : C

403 error of phpmyadmin on ubuntu 12.04
First try to add Options FollowSymLinks before AllowOverride None Also here is a tip: If you created a symbolic link with a root user in example, then you might get that error because original resource is maybe somebody's else but link is owned by root. This usually happens on C-Panel hostings of course. I'm not sure it will happen under Ubuntu.

Categories : Ubuntu

PySide Import Error on Ubuntu 13.04
The output of ldd suggests that libshiboken-python2.7.so.1.2 can't be found. /usr/local/lib/python2.7/dist-packages/PySide, where it is found, is not typically a directory where the dynamic linker would look for it. There are several options in this case: add the directory to the directories checked by the dynamic linker. To do so, you can create a configuration file, e.g. /etc/ld.so.conf.d/pyside.conf with the content: /usr/local/lib/python2.7/dist-packages/PySide then as root run ldconfig copy or symlink the library to a directory that is already checked by the dynamic linker, like /usr/local/lib (and run ldconfig as root) set LD_LIBRARY_PATH=/usr/local/lib/python2.7/dist-packages/PySide (not reccomended)

Categories : Python

WKHTMLTOPDF Installation error on Ubuntu
In case anybody is having the similar issue, I got it fixed by following this article. All features are working perfectly now. Article contents: The wkhtmltopdf shell utility is used to generate PDF documents from HTML using WebKit. I’ve tried a few ruby gem wrappers that make use of wkhtmltopdf, but I’ve found that I like using the wicked_pdf gem the best. Regardless of what wrapper you use to call wkhtmltopdf, here are the steps to get wkhtmltopdf installed on Ubuntu (minor adjustments will be needed for non Debian based distributions). Remove wkhtmltopdf installed using apt-get previously (if previously installed). sudo apt-get remove --purge wkhtmltopdf Install dependencies. sudo apt-get install openssl build-essential xorg libssl-dev Download the static binary as pe

Categories : Linux

Yii create application error on ubuntu 13.04
You don't have PHP in your user path, that's the reason it doesn't know the command. You can just run it like: /opt/lampp/php yiic.php command name change the /opt/lampp/php path to match yours.

Categories : PHP

node-gyp install error on Ubuntu 12.04
I had the same problem. At the end of the NPM output, it says to see: /usr/share/doc/nodejs/README.Debian This file contains an explanation that the interpreter is run from the command line with "nodejs" not "node" due to namespace collision with some other (non node.js) package using the command "node" on the command line. I couldn't solve the problem, however bash scripts need to be changed to reflect this, and I'm not sure how to change scripts NPM uses. Paul

Categories : Python

error installing ruby-rvm in ubuntu 12.04
you should not install rvm this way, the package in ubuntu repositories is very old an contains multiple bugs, please check this instruction for a way to clean and install rvm properly: http://stackoverflow.com/a/9056395/497756

Categories : Ubuntu

Mysql Error 2003-Ubuntu
1). enable Remote Access 1.nano /etc/mysql/my.cnf 2.comment the quoted content bind-address = 127.0.0.1 use # symbol 3.restart MySQL server 2). create a database create database db_name; 3). Create user and grant PRIVILEGES This assume you put the web server and mysql at the same IP. CREATE USER 'user_name'@'10.9.247.140' IDENTIFIED BY 'pwd'; GRANT ALL ON db_name.* to 'user_name'@'10.9.247.140' IDENTIFIED BY 'pwd'; FLUSH PRIVILEGES; mysql --host=10.9.247.140 --user=user_name --password=pwd db_name If the web server is using another IP, replace the 'user_name'@'10.9.247.140' with the real one.

Categories : PHP

Error during linking using makefiles: Ubuntu
Try to add -I to include the .h file of the library: gcc -o $(LIB) $(SRC) -I/home/jagbirs/Downloads/sample/SampleExtLib1 -L/home/jagbirs/Downloads/sample/SampleExtLib1 -lext_lib1

Categories : C

Apache restart error on ubuntu 12.04
You have a nginx webserver running that listens to port 80, so Apache can't bind to that port. You have to shut nginx down first using something like sudo /etc/init.d/nginx stop

Categories : Ubuntu

Setting up artifactory on Ubuntu: ERROR: cannot find a JRE or JDK
JAVA_HOME should be set to the directory one level above the "bin" subdirectory containing the Java executable file, not the file itself. /usr/bin/java on Ubuntu is a symlink to the actual Java installation. Find the actual directory like this (I pasted the commands from my system): $ ls -l /usr/bin/java lrwxrwxrwx 1 root root 22 2012-06-14 17:33 /usr/bin/java -> /etc/alternatives/java* $ ls -l /etc/alternative/java lrwxrwxrwx 1 root root 35 2012-06-14 17:33 /etc/alternatives/java -> /usr/lib/jvm/java-7-oracle/bin/java* So in my case JAVA_HOME should be set to /usr/lib/jvm/java-7-oracle - your system may be different. You should also add the bin subdirectory to your PATH: export PATH=$PATH:$JAVA_HOME/bin Try typing java -version from the command line to test out your sett

Categories : Ubuntu

scala: Error occurred during initialization of VM on Ubuntu 12.04
First of all, The example folder name (and the folder name that you have installed sbt) cannot include "!". this probably applies to other special characters as well. Even, I recommend to install SBT in a folder that has no space on its path (and the same thing for examples folder). For example, if you have installed SBT (or examples folder) on a path like: /Users/dashti/My Programs/sbt-0.12.1 You can re-install it a path like: /Users/dashti/MyPrograms/sbt-0.12.1 By applying this naming change, if the error is gone, please ignore the rest of this post. Otherwise, to fix the mentioned error, first find sbt executable script, then edit it and correct any problem in it: If you are using a UNIX-based operating system, please follow these steps: 1- Find SBT: Open a terminal and type

Categories : Scala

PHP QR Code Class error in Linux Ubuntu
//give the full path if you have linux include('/var/www/phpqrcode/qrlib.php'); //or windows wamp or xampp include('c://wamp/phpqrcode/qrlib.php'); //check the class is exist or not if(class_exists('QRcode')) { QRcode::png('PHP QR Code :)'); }else{ echo 'class is not loaded properly'; }

Categories : PHP

Cherrypy json_out module error in Ubuntu
Do you use python-cherrypy from ubuntu package? It's version is 2.3.0 which does not have cherrypy.tools modules. Install newer version (sudo pip install -U cherrypy).

Categories : Python

Error concatenating two files with ffmpeg ubuntu
Your ffmpeg build is simply too old. Download a recent Linux build of ffmpeg, or follow a step-by-step guide to compile ffmpeg.

Categories : Ubuntu

libtool error building thrift 0.9.1 on Ubuntu 13.04
While this seems to be a defect in the 0.9.1 release tarball, it is not a problem in the top of tree pulled via git as of this afternoon. The solution if one encounters this problem is to use a newer version of thrift by getting the source tree directly via git instead of downloading the tarball. The only difference in build is you will need to run bootstrap.sh before configure. This is well documented. Note two additional helpful bits of data: 1. Configure to build --without-tests (Mike Johnson below - thanks) 2. This issue is fixed in 0.9.2 release (Luke below- thanks!)

Categories : C++

Installing glfw3 on ubuntu 13.04 - make error
check if /usr/lib/x86_64-linux-gnu/libGL.so exists. If no, use "apt-file search libGL.so" to find out in which package this file lies. Then install this package. You may also try to make a symlink, as this file should be a symlink to some other .so file like libGL.so.x.y, where x and y are version numbers.

Categories : Ubuntu

Eclipse plugin error for Hadoop on Ubuntu
You are facing this problem because the plugin is missing some necessary jars. In order to solve the problem you need to rebuild the plugin after including the necessary jars. I have seen this kind of questions a lot on SO, and they all point out to the same thing. Please see these links : Eclipse Hadoop plugin issue(Call to localhost/127.0.0.1:50070 )Can any body give me the solution for this? Hadoop eclipse mapreduce is not working? Installing Hadoop's Eclipse Plugin

Categories : Hadoop

Error compiling Libxml2 in codeblocks on ubuntu
You need to install sudo apt-get install libxml2 sudo apt-get install libxml2-dev sudo apt-get install libxslt-dev sudo apt-get install xml-core Then you need to set compliler option -I/usr/include/libxml2 and linker option -lxml2 -lm And use # include<libxml/parser.h> instead #include "libxml/parser.h" Also you need to clear all previous search path settings

Categories : Ubuntu

C++ runtime symbol lookup error, ubuntu
This error can occur when dependent library(where _ZNSaIcEC1Ev id defined) was compiled for other version of GLIBC (newer version or much older), that you currently have. Try to recompile that library with your current environment. Also you can add nice switch to LDFLAGS of your app: -Wl,--no-undefined. Then you can see any undefined symbols at compile time (not sure if it helps in your situation).

Categories : C++

JNetPcap in eclipse does not print error... Ubuntu 12.04
On Linux, a program will probably have to run as root, or with sufficient privileges granted in some other fashion, in order to be able to open any devices, and, currently, pcap_findalldevs(), which is presumably what the Pcap.findAllDevs method uses, tries to open each of the devices it finds, and only returns the devices it can open. So you'll have to run your Java program as root, or will somehow have to arrange that it have sufficient privileges (CAP_NET_RAW and CAP_NET_ADMIN) to get a list of network adapters and open those adapters.

Categories : Java

X11 Forwarding Error on Ubuntu, Though It Works On Windows
I solved it - it was an authentication issue. Executing the following line on Server resolved the issue: $ xauth add ${client_ip}:0 . ${hex_key} xauth: creating new authority file /homes/${username}/.Xauthority where ${client_ip} is the client with X server running, ${hex_key} is the 32-character hex string. Afterwards upon assinging the $DISPLAY env variable I can now connect successfully.

Categories : Ubuntu

Pharo on Ubuntu 13.04 : error with not finding module "vm-display-X11"
The following two steps solved the problem. sudo ln -s /usr/lib/i386-linux-gnu/mesa/libGL.so.1 /usr/lib32/libGL.so.1 sudo ldconfig Not pretty, but it worked!

Categories : Ubuntu

Ubuntu symfony error:Could not perform XLST transformation
If you are on Ubuntu, I think you just need to enable the php xsl module. Try: sudo apt-get install php5-xsl and restart your webserver after. If apache sudo service apache2 restart

Categories : PHP

Link error with `boost::log2_mt` only on Ubuntu 32/64bits
We also had the same issue and found that the symbol "sem_based_event" indeed does not exist in the library. Then the question is why, the header of this class "sem_based_event" is being included. The issue is caused because we try to use boost library built with gcc 4.1 on a platform with gcc 4.4 or greater. the class sem_based_event is enabled/included based on a flag "__GCC_HAVE_SYNC_COMPARE_AND_SWAP_4" which was introduced in gcc 4.3. So, when we build the boost library with version 4.1, this class is not included/enabled. However, this flag is for both definition as well as the declaration of the class "sem_based_event". On Platform with gcc 4.1 (CentOs5.7), the declaration is also disabled and we donot see any linker errors. However, on platforms with gcc 4.4 or greater (e.g. Ubun

Categories : Ubuntu

X Error of failed request: GLXBadFBConfig (opengl 4.3 - ubuntu)
glxinfo is your friend. It's a command line tool which will report the version numbers and extensions supported for server side GLX, client side GLX, and OpenGL itself. Do you have the NVIDIA binary (proprietary) driver installed? You'll need it if you want to take advantage of OpenGL versions 3 or 4. Like every software product there are occasional glitches, but over the years I think most 3D programmers / users would agree that the NVIDIA drivers for Linux have been very solid, much better than the alternatives.

Categories : C++

CakePhp application gives 500 Server Error on EC2 Ubuntu Instance
The error.log tells you what the problem is /var/www/app/tmp/cache/persistent/ is not writable Folder permissions have not been set up correctly. Run the following command on your shell chmod -R 777 /var/www/app/tmp/ This will allow writing to the tmp folder which is required for Cake to work

Categories : PHP

Error about nokogiri while capistrano deployment on ubuntu server
I faced the same issue with Nokogiri 1.6.0. The problem, as you can see from the logs, it's caused by a failed compilation of libxml2 that, together with libxslt, is now shipped embedded in the gem and compiled when you install it. To find out what exactly went wrong with the compilation, have a look at the suggested file compile.log that, in your case, you can find at: /home/deployer/.rvm/gems/ruby-2.0.0-p0/gems/nokogiri-1.6.0/ext/nokogiri/tmp/x86_64-linux-gnu/ports/libxml2/2.8.0/compile.log As a workaround (assuming you have libxml2-dev and libxslt-dev installed), you can do: NOKOGIRI_USE_SYSTEM_LIBRARIES=1 bundle install I hope it helps.

Categories : Ruby On Rails

Eclipse error in Ubuntu (Quick Post Mortem)
Though it appears to be a 64bit package, it actually still relies on 32bit libraries in its core. Your unbutu installation did not have these libraries present and that is why your eclipse died on startup while loading the ADT plugin. Installing these libraries, which is what the statement is for, solved the issue.

Categories : Android

error while building opencv 2.4.5 application with eclipse and ubuntu 13.04
Your linking step is specifying the libraries incorrectly. If the library is libfoo.so, then you need to say -lfoo. Replace g++ -L/usr/local/lib/ -o "Test_OpenCV01" ./src/main.o -llibopencv_calib3d -llibopencv_contrib -llibopencv_core -llibopencv_features2d -llibopencv_flann -llibopencv_gpu -llibopencv_highgui -llibopencv_imgproc -llibopencv_legacy -llibopencv_ml -llibopencv_nonfree -llibopencv_objdetect -llibopencv_photo -llibopencv_stitching -llibopencv_superres -llibopencv_ts -llibopencv_video -llibopencv_videostab with g++ -L/usr/local/lib/ -o "Test_OpenCV01" ./src/main.o -lopencv_calib3d -lopencv_contrib -lopencv_core -lopencv_features2d -lopencv_flann -lopencv_gpu -lopencv_highgui -lopencv_imgproc -lopencv_legacy -lopencv_ml -lopencv_nonfree -lopencv_objdetect -lopenc

Categories : C++

MySQL Syntax Error (Ubuntu LAMP Server)
It looks from your error like you're trying to execute SQL on the command line, something like: mysql -u mike -p CREATE DATABASE phpbb'; MySQL isn't going to like that, it separates the initiation of the tool from the SQL commands. What I'd normally do for CREATE DATABASE, as it's a one off, I'd do it manually. So start the tool with mysql -u mike -p This should prompt you for your password, and connect to the local database, giving you a shell prompt: mysql> You then issue your CREATE DATABASE phpbb; If you want to run scripts from the command line, put them in a file and redirect the input to mysql. Usually you'd redirect the output too - something like this: mysql -u mike -p < mysqlscript.sql > outputofscript.log

Categories : Mysql

Get Error File. when run Executable jar in Ubuntu terminal
It's difficult to tell what exactly your problem is, having a look at your stack trace I can see this: A NullPointerException is thrown in java.io.File, line 251. I had a look at the source code for this class, it seems that your application tries to create a File object with the constructor File(pathname), but with pathname being null, so I guess you need to specify a file name somewhere in your application (a properties file maybe?) that is not being specified when you execute your program in the console. The line at com.zinnaworks.iis.DBFileLoader.loadDBFile(DBFileLoader.java:17) suggests me that you're using a sort of database that is trying to find its database files; again, you need to find the place where you're specifying the files for your database. And that's it, sorry if the

Categories : Java

Error message by shell on running addr2line pragmatically on Ubuntu
This is a guess based on the error message. trace[i] is NULL, so the command generated is: addr2line (nil) -e xcep_app And so the shell that is invoked to execute the command complains about the parentheses. @WumpusQ.Wumbley reports that ash will reproduce this message: ash -c 'addr2line (nil) -e xcep_app'

Categories : C++

error on installing passenger nginx module on ubuntu with ruby 2.0.0 via rvm
You have to install development tools first. Most likely you're missing some libraries just like the error is indicating. I ran into the same thing a couple weeks back. Here is a nice tutorial similar to the one that helped me out. http://alexpearce.me/2012/06/setting-up-a-vps/ With a little bit of luck, I believe that this line will solve your current issues, but be sure to look over the whole document. sudo apt-get -y install curl git-core python-software-properties build-essential zlib1g-dev libssl-dev libreadline-gplv2-dev libcurl4-openssl-dev Also: I've also always had troubles when using rvm and have found that rbenv works with less hiccups, which is actually mentioned in this tutorial. For databases, if you aren't using postgres then you should be able to just swap out the

Categories : Ruby On Rails

Meteor ubuntu startup exception error "watch ENOSPC"
The error ENOSPC means that there isn't enough space on your disk for meteor to run. While i'm not absolutely certain it is the issue it might be something to do with space or permissions. Have a look with df to see what you have free, or delete some files if this is the issue.

Categories : Ubuntu



© Copyright 2017 w3hello.com Publishing Limited. All rights reserved.