w3hello.com logo
Home PHP C# C++ Android Java Javascript Python IOS SQL HTML videos Categories
Unable to install karma in Ubuntu
I had the same issue, fixed by downloading the source code for 0.10.15 version. ./configure && make && sudo make install then sudo npm install -g karma and it works!

Categories : Node Js

Unable to install ARToolkit in Ubuntu 13.04
I found the solution on these sites by luck. Instructions from both sites were necessary for successful installation. Install ARToolKit 2.72.1 in Ubuntu 10.10 Install ARToolKit 2.72.1 in Ubuntu 11.10 and 12.04

Categories : Ubuntu

Unable to install CBLAS on Ubuntu.
CBLAS is a wrapper of BLAS. CBLAS routines just call Fortran BLAS routines. First you need to compile BLAS. Then use BLLIB variable to point to .a file created after BLAS compilation.

Categories : C

Unable to install laravel 4 using composer on ubuntu
I had the same issue, this is what worked for me: Backup your composer.json Edit comooser.json and remove the whole "scripts" block Save composer install Restore original composer.json composer update Seems like we don't have all the dependencies needed to run artisan on a bare install, but once everything has been fetched by composer, it runs fine.

Categories : Laravel

How install ruby with rbenv install 1.9.3-p448 ubuntu 12.04 vagrant box?
Download the ruby using your browser from ftp://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.3-p448.tar.bz2 and place it in ~/.rbenv/caches/ruby-1.9.3-p448.tar.bz2, then run rbenv install 1.9.3-p448 Explanation here

Categories : Ruby On Rails

how to install php 5.4 install on ubuntu desktop 12.04?
Maybe this tutorial will help http://www.barryodonovan.com/index.php/2012/05/22/ubuntu-12-04-precise-pangolin-and-php-5-4-again

Categories : PHP

MySQL Won't Install on Ubuntu 11.04
this question was having the same issue it solved by uninstalling but before that he tried to set the password that is the question and then he tried to solve it in chat maybe when you try to set a password it will be solved , just try Update: Type the following commands in your terminal in order to make a complete remove for mysql. sudo apt-get remove --purge mysql-server mysql-client mysql-common sudo apt-get autoremove sudo apt-get autoclean Also you need to remove the /var/lib/mysql folder if exist by typing the following command sudo rm -rf /var/lib/mysql Then follow the official ubuntu documentation to install. and don't forget to set your mysql password during installation. Also see this question its similar to the error you have got during the installation process.

Categories : Mysql

How to install GIT Client in Ubuntu 10.10?
One option is to download and install it from the source code. This way you'll ge the latest upstream version with the latest features: $ wget https://git-core.googlecode.com/files/git-1.8.3.1.tar.gz $ tar xvfz git-1.8.3.1.tar.gz $ cd git-1.8.3.1 $ make $ make install This will install the git binaries on your ~/bin/ directory. For other installation options, see the INSTALL file on the source directory root.

Categories : GIT

Cannot install qrscanner gem on ubuntu
read the documentation of the gem at https://github.com/andys/qrscanner and install these dependencies before you install the gem. Dependencies ------------ * Python (for ZXing build script) * ImageMagick: libMagick++, libMagickWand, libMagickCore * gcc, g++, libstd++ * Operating system with a PREFIX of "/usr".

Categories : Ruby

trying to install something on an ubuntu ec2 instance
That repository is not responding to your update requests. I believe adding other repositories by modifying /etc/apt/sources.list should solve your problem. Look at this page for more details.

Categories : Linux

How to install ruby 1.8.7 on ubuntu 12.04 with rvm?
From the documentation: To install a specific tagged version of ruby from the repository we specify -t(tag name). It then goes on to talk about branches... Repository Branches (MRI) To install a specific branch version of ruby from the repository we specify --branch (branch name). Named rubies can help avoid clashes. $ rvm install ruby-head -n zombie --branch ruby_1_8 && rvm ruby-head-zombie $ ruby -v ruby 1.8.8dev (2012-05-21) [i386-darwin10.8.0] $ rvm install ruby-head -n newborn && rvm ruby-head-newborn $ ruby -v ruby 2.0.0dev (2012-06-03 trunk 35876) [x86_64-darwin10.8.0] You'll find a list of all valid branches in the ruby repository: http://svn.ruby-lang.org/repos/ruby/branches/ You have access to much more than what is shown. ruby_1_3/ ruby_1_4/ ruby_

Categories : Ruby

How to install OGRE SDK in Ubuntu 13.04?
Have a look at the Quick Start Guide. The source code download page is currently pointing at OGRE 1.8.1 Source for Linux / OSX. Don't forget to read through the Prerequisites!

Categories : Ubuntu

how to install viber in Ubuntu?
You have to use wine to get the Viber working with wizard on ubuntu. sudo apt-get install wine wget http://download.cdn.viber.com/cdn/desktop/windows/ViberSetup.exe wine ViberSetup.exe You can see the steps with screenshots on: http://www.unixmen.com/install-viber-in-linux-using-wine/

Categories : Linux

How to install mssql in ubuntu 12.04
sudo apt-get install php5-odbc php5-sybase tdsodbc /etc/odbc.ini # Define a connection to the MSSQL server. # The Description can be whatever we want it to be. # The Driver value must match what we have defined in /etc/odbcinst.ini # The Database name must be the name of the database this connection will connect to. # The ServerName is the name we defined in /etc/freetds/freetds.conf # The TDS_Version should match what we defined in /etc/freetds/freetds.conf [mssql] Description = Microsoft SQL Server Driver = freetds Database = XXXXXXXXXX ServerName = mssql TDS_Version = 8.0 /etc/odbcinst.ini # Define where to find the driver for the Free TDS connections. [freetds] Description = MS SQL database access with Free T

Categories : Sql Server

Can't install Yesod on Ubuntu 12.04
It seems that the more recent version of vault on Hackage is broken. You can work around this by telling cabal to install an older version: cabal install yesod-platform --force-reinstalls --constraint 'vault < 0.3.0.1' I'll file a bug report against vault about this.

Categories : Haskell

How can I install Zephir on Ubuntu?
Please note Zephir is currently in Alpha stage and therefore bugs can be expected. You need to have certain packages installed: json-c re2c In the command line type: sudo apt-get install libjson0 libjson0-dev libjson0-dbg sudo apt-get install re2c Once you have the required packages installed, you can generate the parser as follows: ./generate Compile the extension (this is your code): ./zephir The code produced is placed in ext/, there you can perform the standard compilation: cd ext/ sudo ./install

Categories : Misc

Qt5 with Qt 4.7 on Ubuntu 13.04. How to install without conflicts?
Having qt4 and qt5 installed on one system is always problematic and very often the source of unexplainable crashes. Something I personally experienced: I changed audio in one of my programs from phonon to QMediaPlayer. After compilation the program crashed immediately. Even when I used the exact example in the Qt docs. Any program, which used QMediaPlayer crashed. After some research I discovered. That the qt5 multimedia class linked against a gstreamer lib, which linked against libproxy, which had a module, which linked against Qt4. So: My program -> Qt5 -> libgstreamer -> libproxy -> Qt4 = Crash. I asked on the Qt mailing ist. It is a known problem. No workaround available. Can always happen when two Qt versions with different major numbers are installed on the same system. So back

Categories : Qt

trying to install pymssql on ubuntu 12.04 using pip
You need to install the FreeTDS development package (freetds-dev) before trying to install pymssql with pip: $ sudo apt-get install freetds-dev and then, in your virtualenv or wherever you wish to install it: $ pip install pymssql

Categories : Python

Install Netbeans 7.3 with JDK 1.6 on Ubuntu
Just install Java 7, then install Netbeans 7.3. When running Netbeans you still chan choose version of JDK and set it to 1.6_24 for your projects. EDIT: You can install JDK 1.7 in an other folder, you don't have to overwrite your JDK 1.6 folder. For installation just choose the new installation, for programming take your older JDK 1.6_24.

Categories : Java

Can not install pyhdf on ubuntu 13.04
You probably need to install libhdf4-dev package. And instead of using sudo to install packages into your system, spend some time to read about virtualenv.

Categories : Python

install android sdk on ubuntu
Download Android SDK for Linux from Here Extract the folder. Now navigate to eclipse folder and run eclipse from there. android sdk is already integrated in this eclipse package and you will also get the latest SDK with this package. UPDATE: Directory path for QT Android SDK Location: /home/vipul/dev/android-sdk-linux Android SDK Location: /home/vipul/dev/android-ndk-r8e JDK Location: /usr/lib/jvm/java-6-openjdk-i386

Categories : Android

Can't install rmagick gem on Ubuntu 13.04
Try clearing your apt repository and removing any broken packages first: sudo apt-get update sudo apt-get autoclean sudo apt-get clean sudo apt-get autoremove If the system identifies any broken packages, forcefully remove them (replace package_name with your own): sudo dpkg --remove -force --force-remove-reinstreq package_name Then reinstall any missing packages again.

Categories : Ruby On Rails

cannot re-install firefox on Ubuntu 11.04
Your release has reached end of life (EOL), you need to modify /etc/apt/sources.list. Replace CODENAME with the codename of Ubuntu release that you are using. # Required deb http://old-releases.ubuntu.com/ubuntu/ CODENAME main restricted universe multiverse deb http://old-releases.ubuntu.com/ubuntu/ CODENAME-updates main restricted universe multiverse deb http://old-releases.ubuntu.com/ubuntu/ CODENAME-security main restricted universe multiverse # Optional deb http://old-releases.ubuntu.com/ubuntu/ CODENAME-backports main restricted universe multiverse

Categories : Firefox

How to install Ruby 2 on Ubuntu without RVM
sudo apt-get -y update sudo apt-get -y install build-essential zlib1g-dev libssl-dev libreadline6-dev libyaml-dev cd /tmp wget http://ftp.ruby-lang.org/pub/ruby/2.0/ruby-2.0.0-p451.tar.gz tar -xvzf ruby-2.0.0-p451.tar.gz cd ruby-2.0.0-p451/ ./configure --prefix=/usr/local make sudo make install from here How do I install ruby 2.0.0 correctly on Ubuntu 12.04? UPDATE for ruby 2.1.5 sudo apt-get -y update sudo apt-get -y install build-essential zlib1g-dev libssl-dev libreadline6-dev libyaml-dev cd /tmp wget http://ftp.ruby-lang.org/pub/ruby/2.1/ruby-2.1.5.tar.gz tar -xvzf ruby-2.1.5.tar.gz cd ruby-2.1.5/ ./configure --prefix=/usr/local make sudo make install if you are still seeing an older ruby check your symlink ls -la /usr/bin/ruby from hector

Categories : Ruby

how to install pthread in ubuntu 12.10
HOW TO INSTALL IN LINUX SYSTEM'S: The following instructions will result in an isolated installation of PHP that does not affect your current installation. 1) Checkout PHP sources into a new directory on your system cd /usr/src git clone https://github.com/php/php-src cd php-src 1a) Optionally checkout a specific version of PHP git checkout PHP-5.6 2) Download the pthreads sources to the build directory (/ext) cd ext git clone https://github.com/krakjoe/pthreads cd ../ 3) Configure new isolated PHP installation ./buildconf --force ./configure --prefix=/opt/php-zts --bindir=/opt/php-zts/bin --with-config-file-dir=/opt/php-zts --with-config-file-scan-dir=/opt/php-zts/modules.d/ --enable-pthreads=shared --with-curl=s

Categories : PHP

Install Ruby on Rails on Ubuntu 12.04 LTS 2
Make sure RVM is correctly installed and that your .bash_profile file has the correct line: [[ -s "/home/tim/.rvm/scripts/rvm" ]] && source "/home/tim/.rvm/scripts/rvm" # Load RVM into a shell session *as a function*

Categories : Ruby On Rails

Using Ubuntu, how do I install DBD::Sybase from CPAN?
To install modules for the system perl, you can install the packages from the Ubuntu repositories. While these may be out of date, library dependencies are resolved aoutomatically. In this case, a $ sudo apt-get install libdbd-sybase-perl should do the trick.

Categories : Sql Server

How to install graphics.py on Ubuntu 12.04 for Python3.2
You problem: usr/lib/python3/dist-packages/graphics.py line 153, in import Tkinter as tk In Python 3+, Tkinter is imported as tkinter. Simply edit the graphics.py file to import tkinter as tk. Note: As Bender stated, it will probably be easier to continue learning with python 2.*, as you may encounter further issues in the future.

Categories : Python

Install Ruby on Rails on Ubuntu 12.04 LTS
I suggest you to use rbenv, it is a little bit longer to install but it's way more flexible. Among other feature it allow you to install different versions of ruby on you system, and specify which version to use for each project (or conveniently to use a global version everywhere). I got a doc you can follow, it works very well and I installed several machine with it. If you already installed rbenv, rvm, gem, ruby or rails please remove them before starting Works perfectly with Ubuntu 12.04, minor adjustments could be required for other distro Some commands need super-user access, I prefixed them with sudo and it will ask for your password This will install rbenv and all the gems in /opt Here is the step by step, just copy and paste in your terminal: * update and install packages *

Categories : Ruby On Rails

node js can't install right on my Ubuntu computer
You have to make before you make install. The wiki has more information about building from source.

Categories : Node Js

Deploying with RVM on Linode Ubuntu 10.4 Does not install RVM
is ruby-2.0.0-p195@dinner installed / created on the server? you can ensure it is with adding: before 'deploy:setup', 'rvm:install_ruby' more details on using rvm-capistrano can be found here: https://github.com/wayneeseguin/rvm-capistrano#readme

Categories : Ruby On Rails

node-gyp install error on Ubuntu 12.04
I had the same problem. At the end of the NPM output, it says to see: /usr/share/doc/nodejs/README.Debian This file contains an explanation that the interpreter is run from the command line with "nodejs" not "node" due to namespace collision with some other (non node.js) package using the command "node" on the command line. I couldn't solve the problem, however bash scripts need to be changed to reflect this, and I'm not sure how to change scripts NPM uses. Paul

Categories : Python

How to install oracle XE on Ubuntu with Chef?
The chef-oracle-xe Chef recipe uses expect to configure Oracle. Instead one should use silent installation. The example response file is found from Oracle XE zip-package. The format is very simple: ORACLE_HTTP_PORT=8080 ORACLE_LISTENER_PORT=1521 ORACLE_PASSWORD=manager ORACLE_CONFIRM_PASSWORD=manager ORACLE_DBENABLE=y I use silent installation in my own TurnKey Linux based Oracle XE installation.

Categories : Oracle

ubuntu 12.04 libudev-dev won't install because of dependencies
Here's the solution. When you read the following: The following packages have unmet dependencies: libudev-dev : Depends: libudev0 (= 175-0ubuntu9) but 175-0ubuntu9.3 is to be installed E: Unable to correct problems, you have held broken packages. it means that the libudev-dev package I am trying to install depends on package: libudev0 version 175-0ubuntu9 (That's what the "(= 175-0ubuntu9)" is trying to say) But libudev0 version 175-0ubuntu9.3 has been already installed. (That's what the "but 175-0ubuntu9.3 is to be installed" is trying to say). So in other words: a newer version of libudev0 is already installed. the libudev-dev package I am trying to install depends on an older version of libudev0 older and it is already installed. which in turn means that the repository I a

Categories : Ubuntu

How to install and set up OpenCV 2.6.1 for Qt Creator in Ubuntu 12.04
Solution: To answer the question myself, i found this guide: https://code.google.com/p/qt-opencv-multithreaded/wiki/Documentation This guide is straight forward, and well explained. I cleaned my installation of OpenCV before trying it, with good results - it worked right away! Configuration: Ubuntu 12.04 64bit, Qt Creator 2.72 Based on Qt v5.1.0 64bit, OpenCV v2.6.1

Categories : C++

How to install OpenAL on Ubuntu with Netbeans? - C++
Its always informative to start off with a new library like openal by compiling manually at the command line. Here is a simple example : g++ -o play_openal play_openal.cpp -lopenal Notice the mention of -lopenal to pull in the openal library. In your IDE add : openal to list of Linker Libraries.

Categories : C++

Ubuntu: How do I install ruby 1.8.7 specifically?
The RVM Installation Guide covers a "Multi-User Install". It will walk you through installing RVM in /usr/local/rvm. But... you may not need RVM... If I recall correctly, Ubuntu's default Ruby is version 1.8.7. You can look in the Software Center or use Synaptic Package Manager for which Ruby version is available for install. If you want to see available Ruby packages from the command line then use sudo apt-cache search ruby. Once you determine the Ruby version is 1.8.7 then you can install it using your method of choice.

Categories : Ruby

How to install PyQt on Ubuntu 12.04 with python 2.7?
You did in fact properly install the python bindings for Qt4 when you used: sudo aptitude install python-qt4 You should usually use the Distribution-provided packages - the Ubuntu-provided packages are perfectly adequate for your needs. What's puzzling me is the error you got after installing the Ubuntu package. I just tried this on a Ubuntu 12.04 installation and it worked for me. That suggests to me that your current installation of Ubuntu on your system is broken in some way. You could try completely purging the python-qt4 package and reinstalling it again; sudo apt-get remove --purge python-qt4 If you also issue: sudo apt-get clean ... that will remove any downloaded package files from the system, so that apt will then download the package file again when you issue a sudo a

Categories : Python

How Install Hadoop and Hive in Ubuntu Linux in VM box?
i386: Compiled for a 32-bit architecture x86_64: Compiled for a 64-bit architecture .rpm: Red Hat Package Manager file .deb: Debian Package Manager file .tar.gz: GZipped archive of the source files bin.tar.gz: GZipped archive of the compiled source files .mds: Checksum file A Linux Package Manager is (sort of) like an installer in Windows. It automatically collects the necessary dependencies. If you download the source files you have to link (and/or compile) all the dependencies yourself. There you're on Ubuntu, which is a Debian Linux distribution, and you don't seem to have much experience in a Linux environment I would recommend you to download the .deb file for your architecture. Ubuntu will automatically launch

Categories : Linux

How to install clang pre-built binaries ubuntu 12.04
Instead of manually install it you can use the LLVM repo, add it to your apt sources and install it via apt-get or the Ubuntu packet manager. See LLVM apt repo on how to do it. Do the steps as written in the Install paragraph, in a terminal: sudo wget -O - http://llvm.org/apt/llvm-snapshot.gpg.key | sudo apt-key add - sudo apt-get install clang-3.4 lldb-3.4

Categories : Ubuntu



© Copyright 2017 w3hello.com Publishing Limited. All rights reserved.