w3hello.com logo
Home PHP C# C++ Android Java Javascript Python IOS SQL HTML videos Categories
VirtualBox: "A disk read error occurred" after migrating Win XP to Virtualbox
I solved this, and thought i would share my solution: By comparing sectors to a working VM, I found that the following change was needed: Sector 63 offset 0x1A was 0xF0, and this byte needed to be changed to 0xFF. To do this: Attach the non booting drive image as a second drive on a working VM Boot the working VM, and install a low level sector editor (Google!) Run this editor, and look at sector 63 on the non-working drive image. Note that depending on how you select the disk, this is either sector 0, or sector 63 It the same physical sector on the disk Confirm the byte 0xF0 is at offset 0x1A (26), and change it to 0xFF and write the sector Shutdown the VM, and then in settings, detach the drive image from step 1 The disk image was healed - to a degree. It can now boot in recovery co

Categories : Windows

Linux skip /root/.gvfs when executing df command with non-root user
I got the solution for my own question :) In df command you can pass the file system types which you would like to exclude, in this case it is 'fuse.gvfs-fuse-daemon'. So when I execute the below the command I no more get this message "df: `/root/.gvfs': Permission denied" df -x fuse.gvfs-fuse-daemon For more details one can look into df --help option.

Categories : Linux

Root immediate child nodes icons not visible when hiding root
JTree#setShowsRootHandles(boolean newValue) controls the state of the handles for root elements. Normally, this is false. Try changing to true

Categories : Java

Is sudo-ing tomcat's startup with a non-root user the same as running it as root?
Do be aware that the recommended solution to run tomcat on port 80 is to use mod-jk with the Apache web server, not to have tomcat listen on port 80 directly.

Categories : Unix

How to emulate SMS on Android-x86 on virtualbox?
Check out the following threads on the Android-x86 Google Group. I have never done SMS with Android-x86, but here is a synthesis of some things from the group. I am guessing that it cannot be done. Also, you should see this SO question. From Telnet connection to Android-x86: ...should be able to connect to "telnet 192.168.1.XXX 5555" and send "sms send 555123456 SMS_text_here" to simulare an SMS, but the telnet connection is not working.... No responses. From android x86 telnet connection: ... So I was wondering, are there in a plans to make it more as an emulator stuff for developing purposes ? I mean telnet connection simmulating sms'es... No responses.

Categories : Android

Bluetooth in Android x86 on Virtualbox
I had a similar problem a few months ago - found these steps were needed to make it work: # poweroff settings -> USB -> Alt+Ins, this popped up "Unknown Device 0A12:0001[0134]", I clicked on it, I could see the device selected under USB device Filters clicke on OK. Select the guest OS i.e., Ubuntu 10.04, click on start. fiddled with the USB dongle (insert - remove - insert bluetooth dongle). Now it threw a message box, "Failed to set bluetooth power, The error reported is: Connection timed out" # gedit /etc/bluetooth/main.conf Replace 'RememberPowered' parameter from "true" to "false" (ofcourse with out quotes ). Save and close. # reboot After the system is up ... 10. # hciconfig -a output this is showing me the device 11. # hictool scan can see the mobiles, which have activated

Categories : Android

USB does not detecting in oracle virtualbox on mac OS
If a USB Mass Storage device is still claimed by the host OS will not be available for your virtual operating system. I'd recommend right-clicking the drive and select Eject. Then, try to mount the drive on your virtual OS.

Categories : Windows

Reset MAMP Pro username and password to root/root
Assuming you still know the password, you can change the password back to root using /Applications/MAMP/Library/bin/mysqladmin -u root -p password root It'll prompt you to enter a password again, after which it'll be reset to root

Categories : Mysql

Read and Write root folder wihout root
You can use run-as on some devices to execute commands as a particular package. Google have fixed this on Jelly Bean so it no longer works: adb shell run-as app.package.name cp /data/data/package.name/file.txt /sdcard/ exit adb pull /sdcard/file.txt ~/ Here is a good article explaining file access in Android without root permissions, including a one-liner for the above script. It details how to use the new backup command: backup -f ~/data.ab -noapk app.package.name And how to extract the contents of the resulting .ab file: dd if=data.ab bs=1 skip=24 | openssl zlib -d | tar -xvf - You will most likely need the android.permission.BACKUP permission.

Categories : Android

Windows 7 image to Oracle VirtualBox
The Windows 7 backup image is not intended to be bootable by all accounts. You will need to restore the image. Acronis appears to be able to restore the image to a partition, if you dont want to write 50 Gb to DVDs. the backup VHDs are not bootable in the form they are created with Windows backup. Reference

Categories : Windows

VirtualBox - How to write Drivers/Plugins?
The network handling in a VMM ("Virtual Machine Monitor" or "Hypervisor") is typically done by a simple interface that "pretends" to be a network card towards the VM and that is a bridge or switch type interface towards the host's network connection. I suspect you will not be able to easily attach to that, and almost certain that there is no "SDK" interface to it - I haven't worked with VirtualBox, but I have worked on Xen Hypervisor (which is open source, but even then, there's no easy interface to intercept packets in a meaningful way). Your best bet is probably to implement this on the host's side of the bridge or switch interface that the VMM provides. Most OS's have ways to hook into a network flow on the native side for firewall purposes. (I'm still waiting for the SDK document

Categories : C++

unable to install android 4.3 x86 on virtualbox
I dont really have any experience with installing Android on Virtualbox but Genymotion has just release a emulator running on virtualbox which works without having to tweak anything. http://www.genymotion.com/ You should take a look at that!

Categories : Android

Send keys to FreeBSD in VirtualBox
It's possible that VirtualBox is filtering the keys, since it's stateful as to whether or not the keyboard and mouse are bound to the VM or to the host and VBox's UI. You might be able to hack this by generating a mouse click event in the middle of the console display to make sure VBox has bound the keyboard to the VM, and then start the send keys. Also, Vbox has a scripting system. If you can't get this to work, maybe you could use that to get done what you need.

Categories : C#

Debugging Windows Kernel with two VirtualBox hosts
Uncheck "Create Pipe" on one of the VMs (for best practice it should be a debugger target). For serial port redirection one VM acts as a server (the one that creates the pipe) and other acts as a client. Use some terminal application to check that you can pass the data between the VMs using com port. And only then setup kernel debugger.

Categories : Windows

VT-X on windows 7 cannot be recognized by Guest OS(Ubuntu 12.04) with virtualbox
Thanks for answering, I finally installed Ubuntu 12.04 with windows7 on the same hard disk. As for my issue, virtualbox don't support full virtuallization, so I could not see any VMX feature in my Guest OS, but vmware do, which suits me well.

Categories : Linux

Why is Django so slow on VirtualBox VM created with Vagrant?
Apparently, this can be caused by a large number of files in the project directory -- some sort of issue with sharing between host and guest. In this case, I was running the Python virtual environment in the same directory as the project, and it includes about 10K files. Moving the virtual environment to another location on the VM has greatly improved performance.

Categories : Django

How to transfer some files when creating a VirtualBox with Veewee
You can use veewee build hooks like this: Veewee::Definition.declare({ :hooks => { :before_postinstall => Proc.new { definition.box.scp('/tmp/helper.sh', '/home/veewee/helper.sh') } } })

Categories : Ruby

Problems with PHP Request Taking 5+ Seconds in a VirtualBox VM
Try using NFS sharing rather than the default VirtualBox shared folders. Add something like the following to your Vagrantfile: # Set NFS sharing config.vm.share_folder("vagrant-root", "/vagrant", ".", :nfs => true) You will also need a host only network: config.vm.network :hostonly, "33.33.33.2" NFS sharing is not as convenient as the default as you have to enter a sudo password when you run vagrant up, but VirtualBox shared folders can get very slow.

Categories : PHP

Audio not working on Android running on Virtualbox?
Check for your sound cards detected using alsa_aplay -l and select the first card alsa_ctl init 1 Have you checked here of using this alsa_amixer set PCM 100 unmute or do as described here Read some crap to understand about Sound Architecture or Try using VMware Player or VMware Workstation its a better alternative, here you can find some good tutorials

Categories : Android

access mysql in host from guest virtualbox
Your external IP being static or not has no bearing to accessing a virtualized server on your LAN. Set VirtualBox to bridge mode. Simply determine your computer's DHCP-selected internal IP (usually 192.168.1.SOMETHING) and replace the last number with another that is less than 250. For example, if your computer was 192.168.1.6, 192.168.1.70 would work fine on the VM(pick a high number to void conflicts). Set it by using the control panel->adapter settings. Reboot the VM. Connect to MySQL at 192.168.1.70(or the address you picked earlier). Note: If your computer's address is in a different subnet (192.168.0.XXX, 10.XX.XX.XX, etc) change the last number and keep the first numbers the same as on the host.

Categories : Mysql

SVN (svnserve) virtual root --root= not recognized
svn+ssh handles the whole transaction including writing and reading the files so it ignores the --root parameter in svnserve. Here is how to fix it over at serverfault -- Basically you just make svnserve into a script that calls svnserve with the proper variables.

Categories : Svn

How to make a VirtualBox window go to fullscreen mode from python?
hey check this out ..may be it helps you.. This is pyVBOX, a shim layer above the VirtualBox Python API. Why? Becuase the VirtualBox Python API is somewhat complex and I got tried of trying to remember all the details of its use. Plus it changes from release to release and this gives me an abstraction layer to hide those changes. The software also includes a script, utils/pyVbox.py, that provides the ability to manipulate VMs (like VBoxMange). This code is written to the 4.1 version of VirtualBox (4.1.12 specifically). I have not tried it against any other version. This software is independently created from VirtualBox and Oracle. No endorsement by Oracle or the VirtualBox authors is implied. pyVbox

Categories : Python

Windows 7 on Virtualbox virtual machine: is it OpenGL 1.x compatible?
Yes, your guest VM will be able to run OpenGL 1.x and newer. Install the VirtualBox Guest Additions via the "Devices" menu in the virtual machine's menu bar VirtualBox has a handy menu item named "Install guest additions", which mounts the Guest Additions ISO file inside your virtual machine This will enable 3D hardware acceleration in your guest machine (OpenGL and Direct3D 8/9). VirtualBox states that because 3D support is still experimental at this time, it is disabled by default and must be manually enabled in the VM settings http://www.virtualbox.org/manual/ch04.html#guestadd-3d

Categories : Windows

Ubuntu in Virtualbox cannot connect to github, port closed?
In that case, it sounds like a firewall is blocking the git protocol — you may be able to solve the issue by ensuring that port 9418 is also open. The suggested solution from the linked article is to use HTTP or SSH instead; a recent SO answer notes that SSH and GIT are now very similar in terms of performance.

Categories : Ubuntu

Neo4j server in VirtualBox: Unable to create rrd store
While writing down the question, I figured out the fairly easy solution: There is not enough space to get the database (of several GB) into the virtual machine but it was enough to run the neo4j server itself and only access the data via the shared folder. So, now the server starts as expected when I run it from within Ubuntu: dustin@VirtualHAL:~/Software/neo4j-community-1.9$ bin/neo4j start WARNING! You are using an unsupported Java runtime. Please use Oracle(R) Java(TM) Runtime Environment 7. Starting Neo4j Server...WARNING: not changing user process [7676]... waiting for server to be ready............. OK. Go to http://localhost:7474/webadmin/ for administration interface. Nevertheless, this is maybe not the definite answer to the above question. Can somebody add information about

Categories : Neo4j

Vagrant has detected that you have a version of VirtualBox installed that is not supported
You have an old version of vagrant. Just uninstall the current one, and install the latest one. https://www.vagrantup.com/downloads-archive.html

Categories : Python

Volatility failed to scan memory dump of Virtualbox
Solved, virtualbox memory dump used ELF64 format, but volatility 2.2 didn't support it. The plugin here http://wiki.yobi.be/wiki/RAM_analysis could be used to support ELF64 format.

Categories : Misc

Virtualbox has a different byte code for backspace than an actual bare metal OS
You have just encountered the classic DEL vs. BKSP dilemma. There is no perfect solution, you have to acknowledge that some terminals are configured to output a BKSP (0x08) ASCII character when the user presses backspace, while others output DEL (0x7f). Most terminal emulators have an option for this sort of thing, I have not seen a lot of application software that actually works around this issue. It is usually left up to the terminal program, and the user decides whether to press DEL or BKSP or re-configure their terminal in order to ensure proper program operation.

Categories : C

Is it possible to address localhost from linux ubuntu to a virtualbox virtual machine
In the default network configuration (NAT) for VirtualBox you can accesss the host machine with the IP 10.0.2.2, so in the browser you would use that instead of localhost. (I can't find this in the official documentation though?)

Categories : Linux

running rails on guest linux virtualbox: a database.yml issue
What you are describing is pretty much the setup that Vagrant is offering, so yeah, you are doing fine, everyone else is also doing it but they didn't set it up themselves (and by that probably get some really nice addons as well, you should take a look at Vagrant). For your second question: no. Not on the fly. Rails loads the database.yml end then connects to the database with that. When you change it while your Rails server is running, the changes won't get noticed. What you can do however is setup a new environment for your two different machines. Then you can switch between the different environments and depending on the environment, one or the other database gets accessed.

Categories : Ruby On Rails

Cannot connect to VM VirtualBox Linux Nginx server after restarting my computer
First make sure that the service is working using sudo service nginx status If it's not running try starting it manually sudo service nginx start If it fails to start, you can check the error log in /var/log/nginx/error.log or any other error log defined in the server config.

Categories : Linux

Windows Batch - Wait Until VirtualBox Finished Loading To Execute Next Command?
As you have observed, the VirtualBox/VBoxManage process will return and exit once the VM has actually turned on. There isn't a good way to hook into the guest at start, though one thing you can do is instruct VirtualBox to run a command and check for the exit code. I would insert this code in your batch file script right after starting the guest VM but before you want to start sh.exe: :CheckVBox VBoxManage guestcontrol Win8 exec --image c:WindowsSystem32ipconfig.exe --wait-exit --username Goyuix --password VirtualBoxRox IF NOT ERRORLEVEL 0 ( REM Do something to sleep here, pinging localhost or timeout GOTO CheckVBox ) REM VM Ready, go ahead and fire up other apps that depend on it Note: you will need to have the path to the VBoxManage executable in your PATH environment variable. On

Categories : Shell

Opening port so that pgAdmin on Windows 7 can connect to PostgreSQL on Debian on VirtualBox
What about your pg_hba.conf file? Have you configured it to accept connections from hosts in the 192.168.56.0 network? Try to add this line and restart Postgres: # VitualBox Host-Only Adapter host all all 192.168.56.0/24 md5 If it's a testing environment you could even replace 192.168.56.0/24 with 0.0.0.0/0 and forget about it.

Categories : Postgresql

make: *** No targets specified and no makefile found. When trying to do dpkg-reconfigure virtualbox-dkms
if you do ls -l in /lib/modules/3.2.0-49-generic/ folder you will find that build is a symbolic link to the /usr/src/3.2.0-49-generic directory ex: sagar.sakre@sagar-vm /lib/modules/3.2.0-23-generic $ ls -l total 4412 lrwxrwxrwx 1 root root 39 Aug 6 2012 build -> /usr/src/linux-headers-3.2.0-23-generic So make sure that you have the built source code in /usr/src/ directory. If still problem persists upgrade the kernel.

Categories : Linux

Document root element "hibernate-configuration", must match DOCTYPE root "hibernate-mapping"
DOCTYPE for <hibernate-configuration> should be: <!DOCTYPE hibernate-configuration PUBLIC "-//Hibernate/Hibernate Configuration DTD//EN" "http://hibernate.sourceforge.net/hibernate-configuration-3.0.dtd">

Categories : Hibernate

is there any method to draw a tree with a root , the root's previous nodes and successor nodes?
Couple of ideas you might find useful: You can use the tree layout to place the nodes in the canvas, create link objects pointing back and forth, then bind the link objects to a diagonal. http://www.durablejs.org/examples/flowchart/1/admin.html You can also use place the nodes using a pack layout, create the link objects pointing back and forth, and bind the links to a Bezier curve. http://www.durablejs.org/examples/statechart/1/admin.html You can find the code for the graphs above: https://github.com/jruizgit/durable/tree/master/lib/durabjevisual.js

Categories : D3 Js

Including from child theme root or else include from parent theme root
To answer your question directly based on your sample, i would not check to see if the file has been placed in the child theme. If a child-theme developer has customized the file, they can simply declare the function and include their own file (wherever they place it). There is no risk of code duplication because your sample function is simple enough. Even if you simplified your code for the purposes of placing it here....you can always keep includes wrapped in a very simple function that can be declared by a child theme. This will keep PHP running efficient and not having to check for files all the time.

Categories : Wordpress

How can I remove the root node and make the first child the new root node with XSLT?
Add a rule to the identity transform that adds nothing to the result tree for your document element other than the processing of its children: <?xml version="1.0" encoding="US-ASCII"?> <xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1.0"> <xsl:template match="/*"> <xsl:apply-templates select="*[1]"/> </xsl:template> <xsl:template match="@*|node()"><!--identity for all other nodes--> <xsl:copy> <xsl:apply-templates select="@*|node()"/> </xsl:copy> </xsl:template> </xsl:stylesheet> (edited to be agnostic to the name of the document element) (edited again to only preserve the first child element of the document element)

Categories : Xml

Defining root of HTML in a folder within the site root folder
You need to set the base tag. If you add the tag in your page <head> like this: <base href="http://yoursite.tld/folder/"> it should display images and with sources relative to this base path.

Categories : HTML

I want to set authenticated users' root to a nested resource, their dashboard, instead of the home#index page non-authenticated users use as root
Option 1: In your dashboards controller, change to: @user = current_user @dashboard = current_user.dashboard This will also prevent users from seeing other user's dashboards. Option 2: Now, if users can see other user's dashboard fine, then change your route: root :to => "dashboards#find", as: :authenticated_root and in your dashboards controller: def find redirect_to user_dashboard_path(current_user, current_user.dashboard) end

Categories : Ruby On Rails



© Copyright 2017 w3hello.com Publishing Limited. All rights reserved.