w3hello.com logo
Home PHP C# C++ Android Java Javascript Python IOS SQL HTML videos Categories
Anaconda Spyder Qt library error on launch

I use anaconda 1.8 on kubuntu alpha. It uses qt 4.8.5. I can see it with

find $ANACONDA/lib -name '*.4.8.5'

My system qt libs is 4.8.6. I can see it with

find /usr/lib -name "*so.4.8.6"

If Your system qt version is 4.8.5, and anaconda is 4.8.1 -- maybe You can just update anaconda? Try to run

conda update conda
conda update anaconda

Edit

It seems that the problem is spyder picking up Your system libraries. I tried to sheild the libs using evnironment variables LD_LIBRARY_PATH and various qt-related. But nothing works. However simple copying system libs to $ANACONDA/lib solves the problem.

Go to $ANACONDA/lib and move all *.4.8* files to another dir. Then go to /usr/lib/x86_64-linux-gnu (are You using 64 bit?) and copy all *.4.8* to $ANACONDA/lib. That's it: run spyder!

enter image
description here

The qtlibs are usually stored as files and links: for example if there's a libQtGui.so.4.8.6 file then there's also a symbolic link libQtGui.so.4.8. You have to copy/move links too.

Edit 2:

There's a suggestion to

unset QT_PLUGIN_PATH

I tried to set it to nothing export QT_PLUGIN_PATH=, but didn't try to unset it.





© Copyright 2018 w3hello.com Publishing Limited. All rights reserved.