w3hello.com logo
Home PHP C# C++ Android Java Javascript Python IOS SQL HTML Categories
Eclipse WTP installation fails "Cannot complete the install because one or more required items could not be found"
For Eclipse 4.3 (Kepler), make sure you have the following two update sites: http://download.eclipse.org/releases/kepler/ http://download.eclipse.org/eclipse/updates/4.3

Categories : Java

Static .lib required for compiling library is also required for library users?
Looks like you want partial linking (see --relocatable flag in ld manual page). As I can see from the sources, cabal uses partial linking only libraries, compiled for ghci. From Distribution.Simple.GHC (buildLib function): whenVanillaLib False $ do (arProg, _) <- requireProgram verbosity arProgram (withPrograms lbi) Ar.createArLibArchive verbosity arProg vanillaLibFilePath staticObjectFiles whenProfLib $ do (arProg, _) <- requireProgram verbosity arProgram (withPrograms lbi) Ar.createArLibArchive verbosity arProg profileLibFilePath profObjectFiles whenGHCiLib $ do (ldProg, _) <- requireProgram verbosity ldProgram (withPrograms lbi) Ld.combineObjectFiles verbosity ldProg ghciLibFilePath ghciObjFiles whenSharedLib False $ runGhcProg ghcSharedLinkArgs

Categories : Haskell

How to install twistedweb python library on a web server
the easy_install/pip modes of installation are very likely to fail because of broken dependencies. You will have to download the tar and build it yourself. See the attached link for more info on installing the same on CENTOS. http://twistedmatrix.com/trac/wiki/FrequentlyAskedQuestions#CanIinstallTwistedusingeasy_installorpip

Categories : Python

Fails to build pinkimage library with python support under ubuntu 13.04 (32)
Here is a run through of the build, with its set of usual errors. I have not built it recently - but will get back once i have a linux machine!

Categories : Python

Python GDAL: pip install --no-install GDAL fails
A workaround to that problem is to Download GDAL Complete from this site Install GDAL Complete.pkg Go to /Library/Frameworks/GDAL.framework/Versions/1.10/ and copy all files in there Go to your virtual environment's sites-packages /venv/lib/python2.7/site-packages and paste the copied files in there

Categories : Python

install a python library, specifically pycurl, on my heroku box (Rails application)
add a requirements.txt file to your python deployment. Write your python dependencies in it (add any other dependencies you have not only pycurl). check this doc from heroku guys I use pycurl on my heroku app and have found no problem uploading to heroku.. Installing dependencies using Pip (1.3.1) Downloading/unpacking pycurl==7.19.0 (from -r requirements.txt (line 11)) Running setup.py egg_info for package pycurl Using curl-config (libcurl 7.19.7) Installing collected packages: pycurl Running setup.py install for pycurl Using curl-config (libcurl 7.19.7) building 'pycurl' extension gcc -pthread -fno-strict-aliasing -g -O2 -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -fPIC -DHAVE_CURL_OPENSSL=1 -DHAVE_CURL_OPENSSL=1 -DHAVE_CURL_SSL=1

Categories : Python

python pillow (better PIL) encoding check bug
Someone overlooked testing that method; the correct incantation is: if not isinstance(filename, str): # ... because the rest of the code proceeds to turn it into a str, for both Python 2 and Python 3. I've issued a pull request, after talking with the maintainer on IRC. Update: the patch has now been merged.

Categories : Python

Drawing Polygons of Varying Transparency Over the Top of Each Other in Python Pillow / PIL
According to the doc http://effbot.org/imagingbook/image.htm: im.show() Displays an image. This method is mainly intended for debugging purposes. On Unix platforms, this method saves the image to a temporary PPM file, and calls the xv utility. And as far as I know, the PPM file format does not support transparency ("alpha channel"). So... the transparency does not appears when you call im.show() -- but it will be applied if you save your file using a format that does support transparency: from PIL import Image,ImageDraw im = Image.new("RGBA", (800,600)) draw = ImageDraw.Draw(im,"RGBA") draw.polygon([(10,10),(200,10),(200,200),(10,200)],(20,30,50,125)) draw.polygon([(60,60),(250,60),(250,250),(60,250)],(255,30,50,120)) del draw im.save("out.png") #

Categories : Python

Brew Install Python Fails Due to Link gdbm link issue
I had the same issue., Try to change the ownership of the directory (recursively) sudo chown -R username:admin /usr/local/include In the above command., replace the username with your username. This should resolve the issue

Categories : Python

Go install always fails no install directory outside GOPATH
You are using go install on a directory outside the GOPATH folder. Set your GOBIN env variable, or move src folder inside GOPATH. GOPATH/ bin/ src/ go-statsd-client/ More info: GO BUILD Source code, line 296

Categories : Osx

Should I install jpeg library when I use Generic Image Library in BOOST
I think that your answer can be found here. It looks like you don't need to compile libjpeg before boost, but you do need to have it available when building code that uses the jpeg I/O functions.

Categories : C++

Allow bundler to continue if gem fails and isn't required
I've struggled with this also. I've resorted to creating another group, and putting those that fail into that group, then gem install --without group. There are ways to modify the gem install behavior based on platform if it's your own gem, but if you're not controlling the code, then this the only thing I was able to come up with. Hopefully, the platforms you are dealing with correspond to your groups for development, production, etc. I think this is really your issue: Make bundler use different gems for different platforms

Categories : Ruby

What is required and how to install zucchini framework on Mac OSX?
Requirements Zucchini framework has the following requirements: Ruby >= 1.9.2 Xcode >= 4.2 (for this installation process we require Xcode >= 4.6.2) Xcode command line tools Nodejs Coffee script (node module) How to install Install Homebrew $> ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)" Update Homebrew $> brew update Install imagemagick and nodejs $> brew install imagemagick node Install coffee script module for nodejs i. Install coffee script $> npm install coffee-script ii. Add coffee bin to your PATH environment variable $> cd ~ $> sudo vim .bash_profile Press i, to switch into insert mode then add following line PATH=$PATH:$HOME/node_modules/coffee-script/bin Press :w to save and Press :q to quit

Categories : IOS

Laravel Validator / Uploaded File Fails At Required
user2413500 found that the problem was using Input::except('_token') which did not include the file object. However, Input::all() does include the file object. This seems to be a bug which I'll report, but the definition of Input::except is "all" minus the items you don't want. But what seems to be happening is "all" minus the items you don't want, minus your file! Itrulia and Taylor say this is not a bug. However, these are confusingly not identical statements when you have a $_FILE posted... $params = Input::except('_token'); // Missing file inputs! $params = array_except(Input::all(), '_token'); // The current solution. Be on guard! :)

Categories : Validation

Max mobile app size before wifi is required to download/install
BlackBerry If you're referring to the legacy BlackBerry Java platform, the maximum size of an app is actually only about 14 MB. If you're referring to the new BlackBerry OS's, see this document: BlackBerry 10 and BlackBerry PlayBook OS version 1.0.6 and later supports applications (BAR files) up to 2 GB in size. BlackBerry PlayBook OS version 1.0.5 and earlier supports applications (BAR files) up to 300 MB in size. Android On Android, the size is for all intents and purposes unlimited (50MB + 2GB + 2GB), if you use expansion files. Of course, if you're on a 3G connection, it's going to be quite slow to download apps that are larger than the old 50MB hard maximum, and may incur significant costs for your users with data limited plans. iOS For completeness, here's the

Categories : Android

How to Install Matplotlib Basemap Module on Windows 7 with WinPython (or any Python stack install)?
I use windows. And my installation failed with official guidance, too. Finally I installed Basemap using the following method. Although I am not sure if it will go right for you, I just offer mine. First of all, you must have pip in your computer. (It is much easier to install, compared with Basemap and other things. And it can be used to install many useful packages.) Then go this great link: http://www.lfd.uci.edu/~gohlke/pythonlibs/ And download the file named "basemap‑1.0.8‑cp27‑none‑win_amd64.whl". Remove the .whl file to directory "C:Python27". (Maybe you installed your python in different disk, then change it accordingly.) Open terminal. (Use cmd or Git Bash or something else.) Use command: pip install basemap‑1.0.8‑cp27‑none‑win_amd64.whl

Categories : Python

Pip install python package into a specific directory other than the default install location
System: Ubuntu 12.04, Enthought Python Distribution (this is where I wanted to install a new python module) So the prefix_path environment variable didn't work for me and pip still kept installing it in the default location. But I used change default directory for pip install question as a guide. And one of the answers helped me achieve what I needed. pip install -d <path_to_my_directory> For the path I used: path_to_epd_directory/lib/python2.7/site-packages This puts the tar.gz file into the site-packages Then extract it using: tar -zxvf pymodule.tar.gz a directory named pymodule is created, cd into that module and type: python setup.py install and that should do the job.

Categories : Python

How to check and install required .net version while installing bootstrapper application
Depending on the version of .NET you need you can add something like this to your chain: <PackageGroupRef Id="NetFx40Redist" /> See here for other alternatives: http://wix.sourceforge.net/manual-wix3/wixnetfxextension.htm.

Categories : Wix

IIS fails to install on Windows 7
I've encountered the same error while I was installing the IIS on a windows 7 , 32 bit machine. I've tried almost all the solution that I found in many websites. In order to get rid of this error you can do a repair of the OS. it will solve the issue permanently.

Categories : Iis

Multiple reading from file fails (char array malloc required?)
According to opengroup The behavior of multiple concurrent reads on the same pipe, FIFO, or terminal device is unspecified.

Categories : C

Spring 3.2 bean with constructor fails to initialize because of an injected property using @Required
There is no way to make value injected via setter available in constructor. You can: Use constructor injection instead: @Autowired public SomeService(@Value("${someUrl}") String aURIString) throws Exception { ... } Use @PostConstruct instead of constructor for initialization code that depends on injected values: @PostConstruct public void init() throws Exception { ... } Convert injected value in a setter instead of doing it in constructor: @Required @Value("${someUrl}") public void setaURIString(String aURIString) throws Exception { try { oamURI = new URI(aURIString); } catch (URISyntaxException e) { throw new Exception("URISyntaxException created while creating a URI instance for url= "+aURIString); } }

Categories : Spring

Gosu/Ruby fails to install
I had a similar issue. After tinkering in my Path forever, I downloaded and ran Jewelrybox. Afterwards, I had it reinstall ruby-1.9.3 -p448, during which it ran diagnostics. Thankfully was able to install gosu after that. Try that out, hopefully it works for you too.

Categories : Ruby

I get some errors trying to install cpXstack. It fails at the end
You should check the initial stages of the error to understand what is really happening . I am one of the programmers of this plugin ;I can assist you better if you provide the exact reason why the install failed .

Categories : Nginx

PyDev fails to install on Eclipse for Mac
I think I just solved the problem. I tried to install PyDev, got a long way through to a dialog with a progress bar that seemed to be about the last step. A dialog box asking me to approve a certificate popped up behind the progress-bar dialog, when it was about half-way along. I clicked OK and both dialogs immediately disappeared. PyDev was not installed. I did it again, but this time looked at the certificate dialog. You have to tick the certificate, and then click OK. Installation continued. Now I have PyDev. YMMV, good luck.

Categories : Eclipse

npm fails trying to install node-inspector
This is a bug in some versions of NPM that was later fixed in this commit. A workaround is to call npm cache clear before installing modules, otherwise you should just update NPM.

Categories : Node Js

Configure errror -- Library 'crypto' is required for OpenSSL
For cryptography, PostgreSQL use Zlib, so, you need to install Zlib headers in your Mac, to be able to compile it with crypto support. You can see an example but is for Ubuntu. You need to figure out how to install zlib in Mac: To read more about the pgcrypto module, visit this link.

Categories : Osx

How to overwrite a file required by a javascript library hosted in a CDN (elsewhere)?
That's right. When you upload a js file or css file on a CDN and inside there is a relative path, then the browser tries to figure out the resource relative to the css or js file. That is why you get this error. If you upload everything in the CDN there shouldn't be any problem. If you want to keep some files on CDN and others locally you should specify absolute paths in your resources.

Categories : Javascript

Trying to install a Scitools Python pkg via 'pip install' but getting error
I had the same error but resolved it by manually installing all the Anaconda packages. NumPy SciPy Pandas PyTables h5py Matplotlib IPython Spyder Qt/PySide VTK Numexpr Astropy Cython LLVM LLVMpy Numba Scikit-learn Scikit-image NLTK NetworkX MayaVi

Categories : Python

iOS Ad-Hoc Install fails with proper provisions made
When I hit ad-hoc distribution errors, I have a couple troubleshooting steps to try to narrow it down. Can you install just the provisioning profile? You should have either a developer or a distribution profile (depending, often times I install both to be sure). Can you install the app via the iPhone Configuration Utility? Answering those two questions will point you in the right direction at least. Good luck!

Categories : IOS

gem install sqlite3-ruby fails on cygwin
Fixed by following 2 steps :- a) cd to /usr/lib (where the libcrypto.a and libcrypto.dll.a files are located) b) make a local copy of libcrypto.a and rename to libcrypt.a Run gem install sqlite3 Run rails new my_app1 Works so far ....

Categories : Sqlite

Prerequisite bootstrapper application fails to install .NET 4.5
There is a more simple way of installing .NET in Burn in stead of creating your own ExePackage. http://wix.sourceforge.net/manual-wix3/install_dotnet.htm Since you want to install .NET 4.5 you should use the WixNetfxExtension PackageGroup : NetFx45Redist Here is the complete PackageGroup list: http://wix.sourceforge.net/manual-wix3/wixnetfxextension.htm

Categories : Wix

pip install rauth fails : syntax error
Like many packages, rauth currently does not support Python 3. However, it looks like there is a branch where they are working on it. See here. In general, you may have more luck installing packages if you use Python 2.7.

Categories : Python

Custom-built iText version required by JasperReports library?
Since the iText license changed from MPL/LGPL Jasper Report couldn't upgrade. So according to the LGPL they supplied a jar file with their changes. You may ask what changes are: they added a pom.xml (not relevant in your case) they did a minor change to the ant.properties for their own version numbering (not relevant in your case) patched the PdfGraphics2D.java file (fixed a transparency bug) The change is about the currentFillGState, Lines 1089, 1490, 1616-1628. What this means for you is difficult to tell but you have the following possibilities: exchange the patched.jar with the default and run (extensive) tests add the patched.jar to your repository add the public jasper report repo to your repo (http://jasperreports.sourceforge.net/maven2) and as others pointed out ask jr folk

Categories : Maven

rvm install fails searching for binary rubies on a vagrant box
Nevermind. It happened that my Git was configured to convert line ending from Linux to Windows format automatically, so when I downloaded the vagrant files they turned useless when Linux tried to extract Ruby version (and other stuff like that) from them. So the solution in my case was to reinstall Git, setting "Configuring the line ending conversions" to "Checkout as-is, commit as-is":

Categories : Ruby

curl http://npmjs.org/install.sh | sh fails on cygwin
The error is because that URL responds with a 302 redirect. You'll need to use a different URL, which just has a different protocol -- https vs. http. curl https://npmjs.org/install.sh | sh Though, as I noted in a comment above, you can install Node 0.8 or later on Windows without cygwin.

Categories : Node Js

Cabal fails to install Idris language on OSX Lion
The first error indicates you should install the LLVM development packages of your distribution (not through cabal) and the second indicates you should install the development package for the GCC libffi library. What Linux distribution are you using? Or are you on Windows/Mac?

Categories : Haskell

AWS Elastic Beanstalk "composer install" fails to find packages
I found out what the problem was. The composer.lock file was in .gitignore and so composer on AWS didn't get it... See here for more details: http://www.michaelgallego.fr/blog/2013/08/19/solving-the-elastic-beanstalk-composer-deployment-problems/

Categories : Amazon

My Setup wizard disappears/Fails when i try to install new Sql server 2008 R2
I found this link when having the same problem: MSDN Blog

Categories : Sql Server

Maven aggregate build's install works but compile fails
You need to use mvn install. It is normal that mvn compile does not work. Module2 tries to load the needed classes from your local repository. If you do not do an install then the classes are not in your local repository and then Module2 cannot find the Module1 classes.

Categories : Maven

Using yeoman-maven-plugin fails to execute build with npm install error
Thanks for your interest in the yeoman-maven-plugin. I think that the problem is that npm is not on the PATH for GUI apps like IntelliJ. The solution is to create/edit the /etc/launchd.conf file and to add npm path (I installed npm with brew then I added /usr/local/bin for npm path and /usr/local/share/npm/bin for packages (yo, grunt, ...) setenv PATH /usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/local/share/npm/bin

Categories : Maven



© Copyright 2017 w3hello.com Publishing Limited. All rights reserved.