w3hello.com logo
Home PHP C# C++ Android Java Javascript Python IOS SQL HTML videos Categories
Installing JDK on OSX Lion for Scala
Scala is a popular enough of a language for there to be plenty of information on how to get started from scratch. For example, googling for "scala installation" gave me (amongst other stuff) http://www.tutorialspoint.com/scala/scala_environment_setup.htm —they talk about JVM versions, how to install Scala, etc; i.e. all you need. If that page won't do, I'm sure you'll find many more.

Categories : Scala

Installing jpype in Mountain Lion
This is on a system running OSX 10.8.5. I modified the setup.py for JPype-0.5.4.2 and added an element to the end of the self.includeDirs list which is created in the function setupInclusion. This function is declared at line 61 for this particular version of JPype. def setupInclusion(self): self.includeDirs = [ self.javaHome+"/include", self.javaHome+"/include/"+self.jdkInclude, "src/native/common/include", "src/native/python/include", #I added this line below. The folder contains a jni.h "/System/Library/Frameworks/JavaVM.framework/Versions/A/Headers/" ] Finally I ran pip install ~/Path/To/JPype-folder/ and the installation was successful.

Categories : Java

Installing Cloudera Hue on mac os x mountain lion
You need to delete desktop/core/ext-py/Twisted and retry. Also Hue 2.5 release (which contains this fix) is around the corner (this Monday/Tuesday).

Categories : Osx

Installing Pow 0.4.1 on OS X Mountain Lion: Illegal Instruction 4
I had the same problem on OS X Lion. I haven't figured out what is wrong, so I used Homebrew. First, install Homebrew if you didn't: $ ruby -e "$(curl -fsSL https://raw.github.com/mxcl/homebrew/go)" Than run: $ brew install pow And follow these instructions: $ sudo pow --install-system $ pow --install-local $ sudo launchctl load -w /Library/LaunchDaemons/cx.pow.firewall.plist $ launchctl load -w ~/Library/LaunchAgents/cx.pow.powd.plist Also, you always can install Pow from source.

Categories : Ruby On Rails

installing pycrypto on mountain lion with xcode 5
The solution was to reset my active Xcode to Xcode4. You were right, XCode5 has all kinds of problems and isn't ready for primetime. To switch back to your 'regular' XCode (Xcode 4.6 current release) sudo xcode-select -switch /Applications/Xcode.app credit to: http://stackoverflow.com/questions/11961032/xcrun-error-could-not-stat-active-xcode-path-volumes-xcode-xcode45-dp1-app-c Now pycrypto installs perfectly.

Categories : Python

Adding which song Im currently listening to inside Spotify, to a website, using the Spotify API?
Unfortunately there is no API to do that. You will need to use Last.fm's API to fetch the listened tracks if the user enabled that feature in her Spotify client. The other option would be to create a Spotify App that sends you that information, but the user would need to install it and keep it open while playing music, so your app subscribes to the event triggered every time there is a different track playing.

Categories : Javascript

Problems installing yeoman
You might try reading the error message: npm ERR! Perhaps not compatible with your version of node? Yeoman requires Node >=0.8, but you have Node 0.6: npm ERR! node -v v0.6.19 Upgrading to latest stable Node should do it. sudo apt-get install node -y

Categories : Javascript

Problems on installing cvxopt
The best way to get this running is by installing a pre-compiled binary. First, download the MLK build of numpy for windows. Then, download the installer for cvxopt and run it. It is very important you pick the build that corresponds to your version of Python. The builds I linked are for the standard Python for Windows. They should work with Enthought's distribution as well.

Categories : Python

problems in installing libxml2 on linux
You need python headers. Since you're on Ubuntu, you can probably avoid compiling python. Try $ sudo apt-get install python-dev and then compile libxml2. Alternatively, the LFS link that you've posted points to instructions for compiling python.

Categories : Ubuntu

Problems installing R on Linux CentOS 6.3
Hi You can install the missing packages by downloading rpm and install using rpm command libjpeg.so.62 and kernel-headers To install .rpm package use the following steps rpm -iv package.rpm Try yum install R After that. :)

Categories : R

Problems installing, adding and including
Do not mess with the system libraries directly. The better solution is to use a virtualenv for the project, and install requirements within it. Install virtualenvwrapper. sudo easy_install virtualenvwrapper Note this is the one place where you do install something system-wide Restart your terminal after this, it runs some setup from .bashrc mkvirtualenv -p python2 --no-site-packages --distribute project_name to make an environment for the project workon project_name activates the project's environment at any time pip install httplib2 installs httplib2 in the project's environment python, ipython, etc. within environment will only see packages/versions explicitly installed.

Categories : Python

Problems installing/importing Basemap
What you nees is to change your path first, by: $ export PATH=~/anaconda/bin:$PATH and then, $ conda install basemap ( I assumed you are in Linux) source:http://docs.continuum.io/anaconda/faq.html

Categories : Python

Problems in installing perl GD module
Install the gd package: yum install gd It can be found in the rhel-6-server-rpms repository. And please let us know what the perlmod installer is.

Categories : Perl

Problems Installing perl-DBD-MySQL
There's a conflict in the instaled modules on your system. Please make sure your system is up-to-date first. Use these commands: yum upgrade -y yum install perl-DBD-MySQL

Categories : Mysql

Having problems installing in android plugins
Try following below mentioned steps:- Go to Help, "Install New Software." Click on "Available Software Sites" Search http://download.eclipse.org/releases/indigo and enable it(If using juno then just replace indigo with juno) Come back to Help, "Install New Software." Check "Contact all update sites during install to find required software" Now follow the usual steps to install the ADT plugin, it should be able to automatically get the missing classes needed from the update site added above. Hope this helps...

Categories : Android

Problems installing pandas and numpy on Mac OSX
Start over the cleaner way. I'd recommend looking into tools like pyenv and virtualenv if you are going to do any amount of work with Python and especially when it comes to installing additional packages. Pyenv lets you easily manage and switch between multiple versions (including micro versions x.x.3, x.x.5, etc). Virtualenv lets you create isolated Python environments where you can pin down versions of site-packages specific to a particular project. It will go something like: Just using virtualenv: $ pip install virtualenv $ virtualenv foo $ source foo/bin/activate $ pip install pandas $ pip install numpy Or, using pyenv + virtualenv (for additional control over Python versions, e.g. specify 2.7.2), first install pyenv, then: $ pip install virtualenv $ pyenv install 2.7.2 $ pyenv s

Categories : Python

problems when installing kaazing websocket gateway
The first thing to do is get the Gateway running successfully first. So don't worry about running demo-services.start.bat yet. From the Windows Services application, start Kaazing WebSocket Gateway. Then go to C:Program FilesKaazing, locate your installation and look in the log directory. Open error.log using a text editor and verify there are no errors. If there are no errors, you should be able to open http://localhost:8001 from a browser. (Note, you had http://localhost/8000 in your example, but that last slash should be a colon.) You can use either port 8000 or 8001, but 8001 is where the samples are. If you are using a firewall or something else that is intercepting ports, then you'll need to make sure ports 8000 and 8001 are accessible. If you're not sure, start a different serve

Categories : Misc

problems while installing python-mysql package
You seem to have installed distribute and setuptools, your easy_install script tries to load the entry point from distribute, but setuptools is found first. You should remove distribute, as it has been merged back into setuptools and is now obsolete. Probably you'll need to reinstall setuptools after that to get everyting working again.

Categories : Python

Problems installing Google Protocol Buffers R Package
What version of the Protocol Buffers library do you have installed? On Ubuntu, with the default version of Google Protocol Buffers (currently: 2.4.1), it "just works". The package just checks for a minimal version of 2.2.0.

Categories : R

Problems with redmine installing step 5. rake generate_secret_token
Do you have installed the necessary native libraries for mysql2 adaptor ? You can check: mysql2 adapter issues in installing Redmine on Fedora 17

Categories : Mysql

Mac OSX Lion/X11/CImg Library
The header file Xlib.h is in /opt/X11/include, so add that path to the Header Search Paths in Xcode: You'll probably need to add libraries from /opt/X11/lib as well...

Categories : Xcode

R - OSX Mountain Lion and CPU Limit
Tried ulimit... Appears I do not have access, even via sudo. I get the same output from ulimit -a -H before and after giving ulimit -t 12000 # sets cputime limit to 12000 seconds from 600 seconds SOLVED via Debian Virtual Machine. If someone has a Mountain Lionic solution, please let us know.

Categories : R

Two versions of PHP - Mountain Lion
Your Apache is including libphp5.so of the wrong/the other installation. Option 1: See if you can find a libphp5.so file for your other PHP installation and point the Apache config to it (just put the whole path in the LoadModule line and restart Apache). If you cannot find such a file, the Apache module wasn't compiled for that PHP version. Compiling that may be a bit complicated, so in that case: Option 2: Figure out which PHP you're executing on the command line using which php and then just use the other one using the full path, e.g. instead of $ php ... use $ /usr/bin/php .... Note that you may still have different PHP configuration files for Apache and the CLI.

Categories : PHP

SublimeClang OSX Mountain Lion C++11
It may be too late, but I found how to do it. This matter is because clang uses headers for gcc-4.2, which is quite old and doesn't support C++11. To complete C++11 code, you have to get newer gcc and copy the include path it uses. If you have homebrew, open terminal and type brew tap homebrew/versions brew install gcc48 You can install gcc-4.8 and new libstdc++ with these two lines. Now, create some c++ file and try to use g++-4.8 with -v option. g++-4.8 -v example.cpp -v option tell gcc to show detailed log. In the output, there should be some lines like this. #include <...> search starts here: /usr/local/Cellar/gcc48/4.8.1/gcc/lib/gcc/x86_64-apple-darwin12.4.1/4.8.1/../../../../include/c++/4.8.1 /usr/local/Cellar/gcc48/4.8.1/gcc/lib/gcc/x86_64-apple-darwin12.4.1/4.8.1/

Categories : C++

Will it be possible to upload to App Store from Lion?
Your Lion will be just fine as stated here: https://developer.apple.com/support/ios/ios-dev-center.html "To develop with the iOS SDK and Xcode, you must have an Intel-based Mac running Mac OS X Snow Leopard or later and you must be registered as an Apple Developer." Update July 2015 https://developer.apple.com/support/enrollment/ You must have an Intel-based Mac running OS X Yosemite (v10.10) or later.

Categories : IOS

MAC OSX LION: gcc on mac not compiling wget
Honestly, even though it appears that gcc exists; but does it point to a valid install? It still sounds like it is not installed properly and with an upgrade to Mountain Lion, all your open source tools have been scrubbed away and pushed to Xcode and must be manually installed if necessary.

Categories : C++

TideSDK Notifications in OSX Lion 10.7.5
Harry, I'm not too familiar with CoffeeScript, but the following code works for me in 10.7.5 and 10.8.4 - it seems similar to what you have: function showNotify(title, message) { var notification = Ti.Notification.createNotification({ 'title': title || 'No Title', 'message': message || 'No Message', 'timeout': 10 }); notification.show(); } showNotify("The Title", "The Message"); Hope it helps.

Categories : Misc

Spotify changing C to VB.net
Try using: libspotify.sp_search_create(SessionPtr, "mc hammer", 0, 100, 0, 100, 0, 100, 0, 100, sp_search_type.SP_SEARCH_STANDARD, AddressOf MyCallback, CType(vbNull, IntPtr)) where MyCallback is a sub/function that handles search completion: Private Sub MyCallback ... End sub

Categories : C

Tesseract and dylib on OSX Mountain Lion
Done by cleaning my installation of both the softwares and re-installing them through brew. Mind that if there is some linking problem, you have to execute brew link --overwrite tesseract to solve them.

Categories : Misc

Which Python architecture provided on Mac (Lion)?
Use platform.architecture(): >>> import platform >>> platform.architecture() ('64bit', '') Run on my Mac OS X 10.8.4. Note that your Python executable may be a universal binary, in which case you could get the wrong architecture quoted: Note: On Mac OS X (and perhaps other platforms), executable files may be universal files containing multiple architectures. You can also test sys.maxsize: >>> sys.maxsize > 2**32 True The above would return False if you were running a 32-bit platform.

Categories : Python

Mac OS X Lion - mysql: command not found
In the past I've had problems installing the mysql2 gem, so I wrote a little shell script to make my life easier: #!/bin/sh -x env ARCHFLAGS="-arch x86_64" gem install mysql -- --with-mysql-config=/usr/local/mysql/bin/mysql_config Try updating that with the path to your mysql_config: /usr/local/Cellar/mysql/5.5.28/bin/mysql_config and change mysql to mysql2.

Categories : Mysql

How do I create a .conf file in Mac osx Lion?
Open TextEdit's Preferences, and switch to the Open and Save section. Under the When Saving a File panel, uncheck the Add '.txt' extension to plain text files option.

Categories : Osx

Does anybody know how to sniff in promiscuous mode on OS X Lion?
I recall having to setup a script on terminal to "tweak the permissions" of some files / drivers That's probably referring to the permissions on the /dev/bpf* devices. That's not something necessary to sniff in promiscuous mode, it's something necessary to sniff at all unless you're running as root. Recent versions of Wireshark, going back at least to Wireshark 1.8.0, install a script to do that automatically. Open up a Terminal window and do ls -l /dev/bpf*; it should report the /dev/bpf* devices, e.g. /dev/bpf0, /dev/bpf1, etc. as having permissions rw-rw---- and as being owned by root and group access_bpf. In addition, the id command should report you as being a member of group access_bpf. If that's all the case, Wireshark should show an en0 device and possibly an en1 device.

Categories : Osx

RabbitMQ not working on OS X Mountain Lion
I've managed to fix this issue by completely removing brew from my system and reinstalling it again. I've used the following instructions (adapted from the official brew documentation) to completely remove brew from my system: cd `brew --prefix` rm -rf Cellar brew prune rm -r Library/Homebrew rm -rf .git rm -rf ~/Library/Caches/Homebrew I simply reinstalled RabbitMQ afterwards: brew install rabbitmq .. and everything worked like a charm!

Categories : Osx

Mac Lion: Issue with opencv and python 2.7.5
This is how I configured it in the end for the official python 2.7.5 from http://www.python.org First we need to install opencv via brew: brew tap homebrew/science brew install opencv now add /usr/local/Cellar/opencv/2.4.5/lib/python2.7/site-packages to your PYTHONPATH . I did it by editing bash_profile: open ~/.bash_profile add this line in TextEditor: export PYTHONPATH=/usr/local/Cellar/opencv/2.4.5/lib/python2.7/site-packages:$PYTHONPATH #Check the version in your directory Save the file and do: source ~/.bash_profile Now everything should be ready.

Categories : Python

Mono Program Crashes on OSX Lion
This might be a problem of where you built it: try building it in Lion instead to see if that makes a difference. I've seen problems before when trying to execute a program on an older OS than where it was built.

Categories : C#

Where are the files generated with Xcode 4.5 in Lion?
This has nothing to do with Lion. Xcode puts generated files in: ~/Library/Developer/Xcode/DerivedData where ~ is your home directory. Keep in mind that the ~/Library directory is hidden by default in Lion (and later).

Categories : Xcode

How can I install pybrain on Mac OS X Mountain Lion?
Try using the Python package manager pip with the correct permissions: pip install pybrain or clone the repo and build the package git clone git://github.com/pybrain/pybrain.git python setup.py install

Categories : Python

Can't Uninstall Java 7 JDK on Mac OS X (Mountain Lion 10.8.4)
If you can't find the Java Home, open up terminal and enter: env look for or SOMETHING LIKE THIS Mine might not be the same as yours JAVA_HOME=/System/Library/Frameworks/JavaVM.framework/Versions/1.7/Home This is where your Java is installed If you want to see it in Finder then open up Finder and press Command + Shift + G and enter in the path to java home. to uninstall simply remove the java version from : /System/Library/Java/JavaVirtualMachines with cd /System/Library/Java/JavaVirtualMachines rm -r some.version.java.jdk Note: Sometimes Java is install in /System/Library but sometimes it's installed on /Library, so that's why you couldn't find Java in /Library which the Oracle document suggested.

Categories : Osx

Spotify content providers
It would be possible if you embed libspotify, and access the users playlists. libspotify playlist docs. This seems a little too heavyweight for what you're looking for, though.

Categories : Android



© Copyright 2017 w3hello.com Publishing Limited. All rights reserved.