w3hello.com logo
Home PHP C# C++ Android Java Javascript Python IOS SQL HTML videos Categories
Unable to access Samba folder from Windows (Using Raspberry Pi XMBC as a Samba Server)
That may depend on the directory and file rights. If the us who runs smb have no access rights, you can't read or write files. You can find out file permissions with ls -la you will also see owner and owner group. You can try to set read and write permissions for all (chmod 777 directory -R). If this was the problem, then you should give read and write permissions only to the user that runs smb. Set permissions for all back to 0 (770) because of security reasons. Here you find a tutorial on set up samba for Rasapberry Pi.

Categories : Windows

How Should I Debug Samba with GDB
Download samba source code from http://www.samba.org and compile it (without source code, it will be impossible to do symbolic debugging). Stop or kill any other samba instances. Start samba under gdb: gdb <path/to/compiled/smbd> Specify smbd parameters: set args -i -M single Parameters -i -M single force smbd to start as single process, do not daemonize and print all messages and errors to stdout/stderr. Now, you can set breakpoints and trace your source code as you normally would with any other program. Note: instead of using gdb, you might find more convenient to use gdb-tui (gdb text user interface), or use other debuggers like ddd.

Categories : Debugging

Automount samba folder on Mac
I followed https://discussions.apple.com/thread/3221944?start=15&tstart=0 The key is setting the mount point in your home directory is by following three steps. Add this line to the end of /etc/auto_master: /- auto_smb Created /etc/auto_smb with the following line: /Users/user/mount -fstype=smbfs,soft smb://domain;user:password@server/folder Run automount: automount -vc The troubleshooting points are: If you encounter "Too many users" you need to review your SMB path for syntax errors. Also be careful of incorrect username / passwords, or passwords with special symbols. e.g. @ would need to be replaced with %40.

Categories : Osx

samba shares seen in windows, but cannot connect
Add the following to your [global] section: guest account = nfsnobody map to guest = bad user And your public share could look something like: [Backups-Rhonda] path = /raid1/rhonda writable = yes guest ok = yes public = yes force user = root force group = root create mask = 666 directory mask = 666 security mask = 666 force create mode = 666 Make sure to restart the samba service.

Categories : Misc

authenticate against with Active Directory via samba
I recommend you this article http://technet.microsoft.com/en-us/magazine/2008.12.linux.aspx from Microsoft. The configure file seems OK.

Categories : Misc

FBSession.activeSession.permissions does not appear to accurately depict the valid granted permissions
If you were using iOS SDK 3.0, then this was due to a bug in the SDK. See the bug report for more details. Symptom summary: After authorizing user with openActiveSessionWithPermissions method, the sessions variable in callback method contains extended permissions that were not allowed by a user.

Categories : IOS

iOS file sharing with SAMBA / CIFS protocol
If I understood you correctly you want to connect with your app files via WiFi . Basically you need to open a local server within your app. CocoaHTTPServer may be help you with this issue.

Categories : Iphone

Android - Mount a Samba share in code
Probably smbfs/cifs are currently not supported by your kernel. As Delyan said, ensure your kernel can mount these filesystem : $ cat /proc/filesystems nodev sysfs nodev rootfs nodev bdev nodev proc nodev cgroup nodev tmpfs nodev debugfs nodev sockfs nodev usbfs .... If they are not listed, you should try to do a modprobing (sometimes the module you want just have to be activated), get root access then : # modprobe <modulename(without.ko)> e.g. : # modprobe cifs If it doesn't work you will have to change or recompile your kernel (including appropriate modules).

Categories : Android

qt transfer a file from local to a samba shared
You can not do that QFile just spports local files but you can mount it to a posix folder and access to that folder. You can find a guide about how to mount a samba shared folder here

Categories : C++

I'm trying to connect from windows to Samba Shared folder on linux using php
i found solution for connection using this code $sharename = '\\LinuxIPAddressShared_folder'; $username = 'username'; $password = 'password'; $letter = 'Z:'; if (!is_dir($letter . "/TMP")) { $WshNetwork = new COM("WScript.Network"); $WshNetwork->MapNetworkDrive($letter, $sharename, FALSE, $username, $password); } and is working perfect

Categories : PHP

Apache/php cannot access remote cifs/samba share
have you tried //ip/foleder/ /mnt/name cifs username=user,password=passwd,nounix,noserverino,defaults,users,auto,gid=33,uid=33 0 0 change gid and uid to the apache user u can find it out like this: cat /etc/passwd | grep www-data

Categories : Apache

Why would my samba connection fail after an upgrade to windows 2012?
Windows Server 2012 includes latest version of SMB protocol 3.0 and it full of really interesting updates and improvements (details and some relevant discussion here). As with any serious improvements there is a compromise in terms of legacy clients support. Probably there is no support for SMB 3.0 on your Samba client side or some backward compatibility should be enabled on Server 2012 side.

Categories : Java

Making a user in Samba - Debian 6 32bit - No commands working?
Solution: Setup Apt-get upgrade sudo apt-get install samba smbfs sudo mkdir –m 0777 /pathofdrive Editing the samba config sudo vi /etc/samba/smb.conf Copy this: # Global parameters [global] workgroup = HOME netbios name = SAMBA server string = Samba Server %v map to guest = Bad User log file = /var/log/samba/log.%m max log size = 50 socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192 preferred master = No local master = No dns proxy = No security = User # Share [Data] path = /disk2/data valid users = joel read only = No create mask = 0777 directory mask = 0777 Adding a user: # useradd -c "Joel Nahrgang" joel # smbpasswd -a joel New SMB password: secret Reenter SMB password: secret Added user joel Restarting Samba:

Categories : Linux

How to access a shared location in solaris from windows machine using samba with java?
"Connection refused" means that host is not listening on that port. You need to ensure the samba service is running on that host. I would check you can mount the file system as a drive letter first.

Categories : Java

How to set world permissions to be the same as group permissions?
From the chmod(1) man page (relevant parts extracted): -R Change the modes of the file hierarchies rooted in the files instead of just the files themselves. And: The symbolic mode is described by the following grammar: who ::= a | u | g | o op ::= + | - | = perm ::= r | s | t | w | x | X | u | g | o The who symbols "u", "g", and "o" specify the user, group, and other parts of the mode bits, respectively. The who symbol a is equivalent to ugo. The perm symbols represent the portions of the mode bits as follows: g The group permission bits in the original mode of the file. So for you: chmod -R o=g * Example: $ ls -l total 0 drwxr-x--- 2 carl staff 68 Jun 28 10:25 example.d -rw-r----- 1 carl staff 0 Jun 28 10

Categories : Bash

No permissions for notifications
The notifications permission does not propagate to the content script. Add an event page to your extension, and send a message to open the notification from the event page.

Categories : Google Chrome

Permissions in Excel
You can select the cells with vba or manually and set the locked property to false before locking the sheet. This will allow the user to edit those range/cells. You can use conditional formatting to identify these locked cells. Select your range (ctrl-A for all the cells). Conditional formatting formula is: =CELL("protect",A1)=0

Categories : Vba

ANT setting ACL permissions
Ok, got it: <exec executable="chmod" dir="webroot" failonerror="true"> <arg line="+a '_www allow delete,write,append,file_inherit,directory_inherit' app/cache app/logs" /> </exec>

Categories : Symfony2

Same permissions, different rights?
The Apache server is installed within a Linux distribution with SELinux enabled. SELinux by default denies Apache to read files in /home folders. By using ls -Z one can check SELinux labels of files. In my case, while usual (DAC) permissions were the same and there were no ACLs set, SELinux context was different: Next one is readable from Apache daemon and scripts: unconfined_u:object_r:httpd_sys_content_t: Next one is the file that SELinux denies access to Apache: unconfined_u:object_r:user_home_t

Categories : Python

Using GAC assemblies needs permissions
Can you be more specific about which assemblies and what your code is trying to do?... Giving admin privelidges is kind of a catchall... there's more likely a certain permission required that you have not provided... e.g. here's a little ditty about the same issue for SharePoint where the SSRSSvcAccount account did not have read permission for the GAC, which was solved using cacls.exe %windir%/assembly /e /t /p DOMAINSSRSSvcAccount:R

Categories : C#

App crashes after permissions are added?
This is the problem of strict mode which is introduce in android 4.0.Accroding to this network work done on background thread not on main thread.To work on main thread define the strict mode permission in activity.

Categories : Android

Facebook Login Permissions
1 set nothing to "scope", you don't need to know your user's like data in this scenario. 2 I guess you do need to have you own facebook app. 3 You can listen to user like event , and then redirect them wherever you want.

Categories : Facebook

EGL Group Permissions Add/Manage
This is actually found in groups.php under the functions addmembergroup and editmembergroup. You will need to add a key that links to the "lang" you have written in admincp/language/english.php like so: if($key=='genrules_manager'){$descr='' . LANG_GRO_PERMISSIONS_DESCR_GENRULES_MANAGER . ''; $site .= group_radio($key, $value, $descr);} It has to be done in both functions in order for you to see when adding and editing. Simply place it inline with the keys under whichever category you'd like...

Categories : PHP

Zend PDF - save permissions
try for save in Zend app directory $pdf->save("test.pdf"); or for save in Downloads $pdf->save("/Users/myname/Downloads/test.pdf");

Categories : PHP

JUnit needs special permissions?
HTTP permission denied has nothing to do with JUnit. You probably need to set your credentials while making the request in the code itself. Show us some code. Also, unit testing is not really meant to access the internet. Its purpose is for testing small, concise parts of your code which shouldn't rely on any external factors. Integration tests should cover that. If you can, try to mock your network requests using EasyMock or PowerMock and make them return a resource you would load from your local resources folder (e.g. test/resources).

Categories : Maven

Failed to set permissions of path: mp
I managed to solve this by changing the hadoop-core jar file little bit. Changed the error causing method in FileUtil.java in hadoop-core.jar file and recompiled and included in my eclipse project. Now the error is gone. I suggest every one of you to do that.

Categories : Hadoop

How to set up user roles and permissions?
Well, that's what MY_Controller is all about - you have to make all the checking there - create functions there and call them in the constructor, according to URL and/or GET/POST/SESSION parameters. And if user has no rights to access it, just add some flag or error text in SESSION. And then in your main controllers check only for that SESSION flag.

Categories : PHP

How to ask for permissions with Google+ Badge API?
1- there isn't a Badges API. 2- You should distinguish between - using Google functionality, like the badges or the +1 button, which requires the user to login to Google+ - using your service's functionality, like the sign-in button, which requires the user to connect their Google+ account to your service In short the user has to sign-in to Google+ (which doesn't require any permissions because Google+ is the identity provider) and connect to your service/site/app which requires them to give you permission.

Categories : Api

Why FB.login doesn't ask me for permissions
It doesn't ask me for any permissions, just publishes in my timelime directly. This simply means that you've already authorized your app once. Once authorized, it doesn't ask for the permissions again unless new permissions are added. Delete the app from your Facebook profile and then try again. It will definitely ask for the permissions then.

Categories : Facebook

Retrieving Facebook name without any permissions
Sure you can't get name without user ID , which needs a little permission also you can check this question Get user name from graph api

Categories : PHP

Google API file permissions
I was never able to set up Google and Ubuntu to allow me to run the Google custom search client from multiple users, so I created a workaround. :) I set up a web page under apache that calls each of the search scripts I wanted to run. Any user must use the web page to run the script. That way all searches run under the www-data user id. I just have to be careful not to try to run the custom search client any other way (from the command line).

Categories : PHP

Directory permissions to a php file
try this <?php chmod("/somedir/somefile", 755); // decimal; probably incorrect chmod("/somedir/somefile", "u+rwx,go+rx"); // string; incorrect chmod("/somedir/somefile", 0755); // octal; correct value of mode ?> here /somedir/somefile is your file path and read this article

Categories : PHP

Insufficient Scope Permissions
The token you're using doesn't have the permission for what you're calling for. Authentication docs

Categories : Json

Amazon AWS Permissions Per User
A couple of things. Firstly, please for the love of God, migrate to AWS SDK for PHP 2. SDK 1.x is on the way out, and hasn't received any updates in a while. Having done that, you can use S3Client::putBucketPolicy() to grant access to a bucket by Canonical User ID (a.k.a., Account ID). That way, you push the responsibility of managing access control back onto the S3 service. When a user tries to access the object, they'll either get a 200 (201, 204, 304, 307), or a 403 if they're not allowed to access it. If you choose to stay on SDK 1.x, the equivalent method is AmazonS3::set_bucket_policy().

Categories : PHP

What permissions mask should be given with O_CREAT?
If you are only creating a simple text file that will be read from and written to by the indenting tool, then just specify 644 - readable and writable by owner, read-only by everyone else, and nobody can execute it.

Categories : Linux

User with no permissions can still SELECT
During my testing, I created a schema called 'test'. Unknown to me, 'test', is actually some sort of reserved database schema name for MySQL. Anonymous users can use it, etc. As a result, the stuff I was creating in there for testing purposes didn't have certain permission restrictions that other databases would have done. I can't really find any information on this beyond this page: http://www.greensql.com/content/mysql-security-best-practices-hardening-mysql-tips That page says that it comes with it, but I'm pretty sure my installation didn't have it by default. Either way, even with deleting it and then recreating it, if it has the name 'test', it will always be accessible to anonymous users, etc. I hope this helps someone, I spent too long puzzling over this!

Categories : Mysql

File permissions are not being preserved while after zip
It looks like you will need to try a different archive format. Perhaps tar --preserve-permissions. The other option would be to save the permissions separately and the reapply them upon decompression. You could add a .saved_permissions file to the archive. There are some examples of scripts that can do this on StackOverflow.

Categories : Java

Changing permissions on a file
The only people that can change the permissions of files are the people that own the files (in your case, jim) and the root user. This is to prevent users from doing something malicious, like changing the permission of someone else's file to r/w and then deleting everything in the file, or something similar.

Categories : Linux

Make all new directories have 777 permissions
Put: os.umask(0000) in the Python script before it creates the directory. If you can't change the Python script, put: umask(0000) in the Perl script before it calls the Python script. When a new file or directory is created, the permissions are determined by taking the permissions specified in the call to creat() or mkdir(), and then masking off the bits that are specified in the umask. Typically, applications specify 0666 or 0777 permissions when they call the function (depending on whether they're creating something that should be executable or not). A common value for umask is 022, which turns off group and world write permissions. If you don't want them turned off, use the above umask value to keep the permissions specified in the call.

Categories : Python

Android status bar permissions
From what I understand, android.persmissions.STATUS_BAR is a System persmission and can't be used. In android terms it falls under signatureOrSystem permission. The meaning is (taken from Android Manifest DOCS)... A permission that the system grants only to applications that are in the Android system image or that are signed with the same certificate as the application that declared the permission. Please avoid using this option, as the signature protection level should be sufficient for most needs and works regardless of exactly where applications are installed. The "signatureOrSystem" permission is used for certain special situations where multiple vendors have applications built into a system image and need to share specific features explicitly because they are being built together.

Categories : Android



© Copyright 2017 w3hello.com Publishing Limited. All rights reserved.