w3hello.com logo
Home PHP C# C++ Android Java Javascript Python IOS SQL HTML videos Categories
How to install newer test version of my installed android app without uninstalling it?
One simple solution is to change the package name, since that's how the OS identifies the .apk. Indeed, the package is unique to the Market: how does an android phone(or market) recognize an app

Categories : Android

What if a native class/method only defined in a newer Java version?
But what will happen if we run NativeClass.somethingMore() on JRE 1.6? A NoSuchMethodError will be thrown. Thrown if an application tries to call a specified method of a class (either static or instance), and that class no longer has a definition of that method. What if a class that doesn't exist? There is no NoSuchClassError See NoClassDefFoundError & ClassNotFoundException. But don't ask me a) why there are two of them. b) why one is used over the other/what the difference is, or c) why methods also have NoSuchMethodException. It seems they should all be an Error rather than an Exception.

Categories : Java

How to debug application on newer iOS version from an older version of xcode?
In order to do this you'll need to have multiple versions of xcode installed. Can I have multiple Xcode versions installed? Xcode shares device and symbol information across all versions of xcode. If you open the newer xcode version that supports the newer version of ios, you can add the device there. Once the device is added, close the newer version of xcode, and open your older version (4.6) that you want to deveop on. If everything went smoothly the device should be available in organizer, and you should be able to run and debug normally on it.

Categories : Iphone

Check jQuery version and load a newer version
Bad idea to do what you are doing. If you really insist on having different jquery versions, you can always write some sort of a script manager. Basically you specify in your page's "config" what jquery versions are required on this page and the manager will load the appropriate one. Something like: // each page content before everything else Manager.reguire("plugin 1", "1.4.7"); Manager.require("plugin 2", "1.4.4"); // Main layout <head section> Manager.LoadRequiredVersions(); And the manager would just request the files for you, but don't forget that you might have to do some clever no-conflict stuff with jQuery if you want more than one on a single page. http://stackoverflow.com/a/1566644/486780 If it's one version per page then a manager would be the easiest option.

Categories : Javascript

How to check if Java 7 version is installed via Cocoa?
Although you may have installed Java 7, you should have installed the Apple's Java Mac OS X 2012-006 update before. Having done that (and then installed java 7 again), java -version should tell you java version "1.7.x..." Determining the Default Version of the JDK

Categories : Java

Get details of installed java version using python
You can store the results into jd by capturing standard error in the result to stdout: jd = subprocess.check_output(["java", "-version"], stderr=subprocess.STDOUT)

Categories : Ubuntu

appcfg.cmd java version; 1.7 installed; 1.6 in path; tells me it needs 1.6 ti yokiad
Thank you for looking at this question. I resolved the problem. It was not related to Google Application Development Server. It was a difficult-to-resolve path problem to the directory where the Java executables were kept.

Categories : Google App Engine

Revert to a newer version with Git
Yes it is possible to revert reverts. Depending on how the revert was performed on of the following options apply: Using git revert <commit/tag>: Simply revert the resulting commit via git revert again. Reverts executed via git revert are normal commits which simply “reverse” the commit, and obviously the reversal of a reversal is the original. Using git checkout <commit/tag> -- file: Simply checkout another commit. All commits are equal and git does not differentiate between older and newer ones.

Categories : GIT

InstallShield LE won't swap .EXE for newer version
See the MSDN Help Topic File Versioning Rules. There are a number of pages off of that one including Both Files Have a Version. InstallShield LE uses Windows Installer.

Categories : Dotnet

JVM 32 bit installed in the Win7 64 bit Os, but it is not recognized
Make sure that the environment variable JAVA_HOME leads to your JDM installation directory and that $JAVA_HOMEin has been added to your PATH env variable This should fix the problem

Categories : Java

Running meteor project on a newer version
Meteor 0.6.x changed variable scoping across multiple files : each source file is encapsulated inside an anonymous function making its local var/function declarations visible only to the concerned file. To enable exporting symbols and reference them in other files, you now have to use this syntax : myVar=value; // instead of var myVar=value; myFunc=function(){...}; // instead of function myFunc(){...} If you did something like function displayName(){...} in model.js, try replacing it with displayName=function(){...}; I'm pretty sure it will do the trick.

Categories : Meteor

is there a way to selfupdate maven without re-downloading the newer version
No, but the Maven install is only a very thin bootstrap anyway..... Maven downloads most of it's functionality as plugins. This normally happens when you run your first build and stores them in a local repository under: $HOME/.m2/repository So the good news is that when you install the new version of Maven, it will re-use the plugins already downloaded (unless newer ones are required). Finally if you have concerns about performance it's an excellent idea to install a Maven repository manager. Software like Nexus can proxy and cache external repositories like Maven Central and will significantly improve your build performance (and enable off-line builds). Nexus is very lightweight, I run it on my laptop.

Categories : Maven

same older dll override existing newer version in bin folder
DotNetNuke manages that for you, as long as you include the version number in the Module install manifest (.dnn file), see here for more information: http://www.dotnetnuke.com/Resources/Wiki/Page/AssemblyComponent.aspx

Categories : C#

Create Panels like newer twitter bootstarp version
You can include the panel section from the new css and everything should be fine. You might have to customize it a little bit. Have a look at this fiddle. <div class="panel panel-success"> <div class="panel-heading"> <h3 class="panel-title">Panel title</h3> </div> <div class="panel-body"> Panel content </div> <div class="panel-footer">Panel footer</div> </div>

Categories : Twitter

VSTO Debug version fine, Installed version doesn't read app.config
You need to add app.Config File to your Setup Project but not from the actual project do it from the ReleaseDebug folder of the ExcelAddIn project. When you build you ExcelAddIn project it will leave App.config File to the ReleaseDebug Folder, piCk the file form there and include it into the dependicies folder of the Setup Project.

Categories : Visual Studio 2010

Parsing user agent to check for newer version of browser
You can use the following PHP class to determine a user's browser and version. https://github.com/ornicar/php-user-agent/blob/master/README.md

Categories : PHP

How to fail maven build if newer version of dependency exists in repository?
This problem can be solved with the maven-enforcer-plugin. You have to create your own custom rule, because non of the standard rules seem to match your needs. The notion of the rule you are going to implement should be enforce dependencies are up to date. To implement the check you could get some inspiration by the versions-maven-plugin you mention.

Categories : Maven

Android: "update version 0 is older than installed version"
As far as I know, no, you can't do that. See this Google Groups discussion, and this Stack Overflow question for some ideas for achieving a similar outcome with ant build scripting. If you look at the Android documentation, it specifically calls out that you can use a resource for the versionName, but says no such thing for the versionCode: android:versionCode An internal version number. This number is used only to determine whether one version is more recent than another, with higher numbers indicating more recent versions. This is not the version number shown to users; that number is set by the versionName attribute. The value must be set as an integer, such as "100". You can define it however you want, as long as each successive version has a higher number. For

Categories : Android

Server-side equivalent of IE setting "Check for newer version of stored page"
You failed to set the proper headers to prevent caching. What exactly did you try, and what were the headers in question (look with Fiddler). In this article, I explain how IE's "Check for new versions" feature works, and as I say there: The most important fact to keep in mind is that these four options impact the behavior when there are no caching headers on the HTTP responses; when caching headers are present, Internet Explorer will always respect them.

Categories : Dotnet

An incompatible version 1.1.22 of the APR based Apache Tomcat Native library is installed, while Tomcat requires version 1.1.24
From the error its clear that your tomcat native is of older version (1.1.22) and service looks for much newer version at least 1.1.24. The latest and stable version of tomcat native is 1.1.27. You can install that. Use the following link to install and fix your current issue.

Categories : Apache

jQuery Toggle not working properly with newer jQuery version
jQuery .toggle() event method was deprecated in jQuery 1.8 and removed in jQuery 1.9. You can use .toggleClass() method instead: $(".trigger").on('click', function() { $(this).toggleClass("active"); });

Categories : Jquery

Get fuse version installed on current OS
At least on my system, fusermount -V gives the current version of Fuse. So something like: with os.popen('fusermount -V') as p: versiontext = p.read() #do something with version text should work.

Categories : Python

Check which version of DirectX is installed
EDIT: Removed registry check method because it works only for Dx <=9 (thx @Telanor) This method is very, very slow, but only one I figured out that is 100% accurate private static int checkdxversion_dxdiag() { Process.Start("dxdiag", "/x dxv.xml"); while (!File.Exists("dxv.xml")) Thread.Sleep(1000); XmlDocument doc = new XmlDocument(); doc.Load("dxv.xml"); XmlNode dxd = doc.SelectSingleNode("//DxDiag"); XmlNode dxv = dxd.SelectSingleNode("//DirectXVersion"); return Convert.ToInt32(dxv.InnerText.Split(' ')[1]); }

Categories : C#

Detect what version of Facebook apk is installed
context.getPackageManager().getPackageInfo(packageName, PackageManager.GET_SIGNATURES).versionCode does indeed return the facebook version code (which is different from the version name). After some digging around, we've found that Facebook version 1.9.8+ works, which is version code version code 40477+. As we are using the deprecated Facebook.java class, we modified validateAppSignatureForPackage(), and it seems to work! private boolean validateAppSignatureForPackage(Context context, String packageName) { PackageInfo packageInfo; try { packageInfo = context.getPackageManager().getPackageInfo(packageName, PackageManager.GET_SIGNATURES); if(packageInfo.versionCode<40477) { Log.i("validateAppSignatureFor

Categories : Android

Sass bleeding edge version installed but 3.2.9 in use
Try doing a clear as well gem uninstall sass compass clean check if sass has gone: sass -v If it has then reinstall it gem install sass gem update then check the version again sass-v or gem list Current version is 3.3.12

Categories : Ruby

How to check version of Ruby dev kit installed in my Windows?
I've never done any kind of ruby development in Windows, but that being said, you should be able to run the ruby command line binary with the --version flag: $ ruby --version ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-darwin12.1.0]

Categories : Ruby On Rails

How to detect installed version of MS Office within javascript?
this method worked for me in chrome, you may have to dumb-down the iteration for older copies of IE: var has2013=([].slice.call(navigator.plugins) .filter(function(a){return a.name.match("Microsoft Office")})[0].name||"") .match(2013)||false; alert(has2013);

Categories : Javascript

PIP command to determine if the latest version is installed?
'pip search' gives you that information. e.g.: $ pip search SOAPpy SOAPpy - SOAP Services for Python INSTALLED: 0.12.0 LATEST: 0.12.5 versus: $ pip search MarkupSafe MarkupSafe - Implements a XML/HTML/XHTML Markup safe string for Python INSTALLED: 0.19 (latest)

Categories : Shell

How to detect installed version of MS Office using javascript from IE?
You can't instantiate ActiveX controls which aren't marked "Safe for Scripting" from the Internet Zone in IE (and the Office apps aren't SFS). What "old mechanism" were you using prior to Office 2013 and what "new mechanism" are you planning to use? (Keep in mind that SharePoint works properly with both old and new Office clients without version detection).

Categories : Javascript

Is there a way to query and find out the version of Vertica installed?
It can be found here: https://my.vertica.com/docs/6.1.x/HTML/index.htm#9158.htm db=> SELECT VERSION(); VERSION ------------------------------------ Vertica Analytic Database v6.1.2-0 (1 row)

Categories : SQL

Zope installed to wrong version (easy_install and pip)
I would suggest installing the Homebrew package manager, and installing python 3 with it. Installing Homebrew: ruby -e "$(curl -fsSL https://raw.github.com/mxcl/homebrew/go)" Installing Python 3 brew install python3 Pip for Python 3 would be installed as pip3 by the above command. easy_install is depretiated with homebrew, and you don't need to use sudo with pip3 or gem Note, easy_install is deprecated. We install pip (or pip3 for python3) along with python/python3. source

Categories : Python

How would i know my latest version of Android app has been updated to all installed users?
At the moment, the only way to tell is by day to day statistics from the google console to know how many have updated to your new version. Go to statistics windows, then underneath the first graph there should be an option to display Active Installs by App Version.

Categories : Android

How do I install Sylius on Bluehost or any other server that has an old version of ICU installed?
I tried this on a clean install of Sylius on my Bluehost server and got it to work. I had previously installed the intl extension on my BlueHost server following https://my.bluehost.com/cgi/help/534 The intl extension is not required. See below. (I was attempting to install it before I realized I didn't need it) After installing the extension, phpinfo() said the version of ICU was 4.2. Note: on BlueHost you have to use php-cli instead of php to run php scripts from the command line To install Sylius I ran: wget http://getcomposer.org/composer.phar php-cli composer.phar create-project sylius/sylius -s dev When running create-project, I recieved the error: Your requirements could not be resolved to an installable set of packages. Problem 1 - Installation request for symfony/icu 1.2

Categories : PHP

Vagrant has detected that you have a version of VirtualBox installed that is not supported
You have an old version of vagrant. Just uninstall the current one, and install the latest one. https://www.vagrantup.com/downloads-archive.html

Categories : Python

How to learn which version of application installed programmatically in android
Yes, like this: String packageToCheck = "com.facebook"; List<PackageInfo> packages = getPackageManager().getInstalledPackages(0); for (int i=0; i<packages.size(); i++) { PackageInfo p = packages.get(i); if (p.packageName.contains(packageToCheck)) { String name = p.applicationInfo.loadLabel(getPackageManager()).toString(); String pname = p.applicationInfo.loadLabel(getPackageManager()).toString(); String packageName = p.packageName; String versionName = p.versionName; int versionCode = p.versionCode; Log.i(TAG, name + ": " + pname + ": " + packageName + ": " + versionName + ": " + versionCode); } }

Categories : Android

How to choose default Subversion (svn) version to use when 2 versions are installed
You can run commands without a prefix when it's in your path: echo $PATH Most likely both executables are in your path. Your shell is using the first hit: # which svn /usr/bin/svn If you like to use both version do: cd /usr/bin mv svn svn16 Now you can use "svn16" for version 1.6.3 and svn for the newer version. If you like to completely remove svn 1.6.3 you can do this with the package manager. yum list | grep subversion Check if this is version 1.6.3, if it is: yum remove subversion

Categories : Linux

How to release android update version of app for regular and pre-installed app
Let's say your pre-release app has versionCode=1. The first version of deployed on Google Play app was also 1. But as you've said, you already have 2 updates on it and google play forced you to increment version number, let's say to 3. In conclusion, if user has pre installed app - his version code will be 1. If he updated from market - most probably he will have latest version number -3. Or at least two. The point is that you can be pretty sure that at that moment of time, when you already published two updates, users, who have version=1 are users with preisntalled app, while users with version>1 are users with app from market. Considering this, you can use the app version number from GA to differentiate these users. Does that make sense?

Categories : Android

Can't deploy rails4 project with capistrano. rbenv: version `2.0.0' is not installed
That's most certainly a PATH problem, capistrano will send commands through ssh without opening a console session and the profile files are not loaded the same way if you open a ssh console session. That may explain why through ssh console you can get a correct rbenv environment but not through capistrano. The following works with debian / ubuntu, and need to be adjusted for other distro I suppose you added some export instruction in one of your profile file. In ~/.profile or ~/.bashrc perhaps. The export instruction I use are the following, but they may be different in your configuration, so if rbenv is properly working when you open a ssh console then you can keep your set of export commands. The trick I'm going to detail is just to place them at the right place. My export instructi

Categories : Ruby On Rails

Cannot debug or run Word AddIn because the required version of Microsoft Office is not installed
Apparently, when the addin project is created, debug information such as the MS Office version and the executable path used for debugging is saved in the .CSPROJ file. So debug is not guaranteed to work on another machine. This information is saved in following XML node of the project file: ProjectExtensions VisualStudio FlavorProperties ProjectProperties In my case, the problem was in the attributes OfficeVersion="14.0" DebugInfoExeName="#SoftwareMicrosoftOffice14.0WordInstallRootPath#WINWORD.EXE" Changing 14.0 to 12.0 (2010 to 2007) in their values solved my problem. Check out these questions for reference: Determine Excel 2007 addin vs excel 2010 addin convert an Excel 2010 addin to a 2007 addin (both VSTO)

Categories : Dotnet

Installed Spark, built against right hadoop version , getting cannot assigned requested address error
Spark tries to resolve your hostname and then bind to resolved IP address. In your setup this IP address is unavailable (wrong DNS/Network Card setup). Try to edit your /etc/hosts (or C:windowssystem32driversetchosts record and add a line: <your ip address> <your hostname>

Categories : Apache



© Copyright 2017 w3hello.com Publishing Limited. All rights reserved.