w3hello.com logo
Home PHP C# C++ Android Java Javascript Python IOS SQL HTML videos Categories
Package failing to pass R CMD check 'package is not installed for arch =i386', any reason why this would happen?
A hunch: You are on Windows (or another OS which by default runs multi-arch like OS X), you are trying to run R CMD check and it fails to check on one of its two sub-architectures for lack of a package you depend upon. Also note that R CMD check --no-multiarch ... is likely to help you here.

Categories : R

JBoss EAP 6.1 support for Netbeans?
Which NetBeans version? For example NB 7.3.1 supports JBoss AS 7 See http://wiki.netbeans.org/NewAndNoteworthyNB731#JBoss_AS_7

Categories : Java

Netbeans (7.3) Adding HTML5 support in PHP
@dev-null-dweller thanks, Download NetBeans 7.4 Beta http://dlc.sun.com.edgesuite.net/netbeans/7.4/beta/bundles/netbeans-7.4beta-php-linux.sh

Categories : PHP

NetBeans new language support with Maven
you probably have found and error in the generation of maven's pom.xml file for the platform's artifacts. While org-netbeans-modules-csl-api jar contains a module dependency on codetemplates module (org.netbeans.modules.editor.codetemplates/1 = 1), it's not present in the list of resolved dependencies. Please file an issue against https://netbeans.org/bugzilla component:apisupport subcomponent: maven. Thanks. PS: The workaround is indeed the path you have tried but didn't finish. Keep on adding missing dependencies until the annotation processor's runtime dependencies are satisfied. The dependencies required (for NetBeans 7.3.1) are: <dependency> <groupId>org.netbeans.api</groupId> <artifactId>org-netbeans-modules-editor-codetemplates</art

Categories : Maven

Can't use a installed package in R
Could in be that you have another R installation for an earlier version 3.0 vs the 3.0.1 showing in your sessionInfo()? Error in FUN(structure(c("write_png", "read_png"), .Names = c("write_png", : no such symbol write_png in package/Library/Frameworks/R.framework/Versions/3.0/Resources/library/png/libs/png.so Error: package or namespace load failed for 'ggmap'

Categories : R

is not a valid installed package in R
something that should be simple: creating a package. Haha. Well, no, creating a package in R isn’t quite simple (compared to module systems in other languages). You’re on the right track but before you can use your package you need to install it (or use devtools to install and load it dynamically). The command package.skeleton actually creates a file Read-and-delete-me in your package directory which contains a short explanation of how to do this. Very briefly, you need to run the following command on the command line, from the parent directory of your package directory: R CMD build packagename R CMD INSTALL packagename This is just a very brief explanation. Be sure to read one of the more detailed explanations, such as Friedrich Leisch’s Creating R Packages: A Tutorial [PDF

Categories : R

How can I tell the source location of a package installed with pip?
pip freeze gave you exactly that. The source location of the SVN repo and the commit revision (1046). You can check the location of the files once imported, to examine where they resides. That will probably point you to path/to/package/checkout: $ python >> import packagename >> packagename.__file__ 'path/to/package/checkout/__init__.py'

Categories : Python

VSIX package gets installed by Wix but not uninstalled
You have a space in the package ID. Escape the package ID like so: <VSExtension:VsixPackage File="MvvmLight.VS2012.vsix" PackageId="&quot;MVVM Light..e8b05c55-a169-42aa-a116-064ef2205f80&quot;" Target="professional" TargetVersion="11.0" Vital="yes" Permanent="no"/>

Categories : Wix

How to properly set installed-size for deb package?
I don't expect that you should change that value manually. Instead, run debuild (part of devscripts package) in the root directory of the package. A binary package will be created in that root's parent directory and will, of course, have the field automatically filled in for you.

Categories : Linux

RPM package to allow different sets of files to be installed
Nope. There should be no user interaction upon RPM installation, ever. You would have to make each its own rpm. You can have an empty rpm that Requires all of them to make a bundle, or you could make them a yum group.

Categories : Linux

Does the PayPal REST API Support Desktop/Installed Apps?
REST simply uses HTTP methods to access APIs, so it shouldn't matter whether you have a desktop app. As long as your app can make REST API calls and parse the JSON response, you should be able to use the PayPal REST API.

Categories : Paypal

How do you uninstall the package manager "pip", if installed from source?
That way you haven't installed pip, you installed just the easy_install i.e. setuptools. First you should remove all the packages you installed with easy_install using (see uninstall): easy_install -m PackageName This includes pip if you installed it using easy_install pip. After this you remove the setuptools following the instructions from here: If setuptools package is found in your global site-packages directory, you may safely remove the following file/directory: setuptools-*.egg If setuptools is installed in some other location such as the user site directory (eg: ~/.local, ~/Library/Python or %APPDATA%), then you may safely remove the following files: pkg_resources.py easy_install.py setuptools/ setuptools-*.egg-info/

Categories : Python

Hackage documentation incosistent with my installed package?
How can I browse documentation and sources for the package I have installed? If you pass --documentation to cabal install, or set Documentation: True in your .cabal/config file, cabal install will generate documentation for every package that you install. You might have to re-install the packages you are interested in to get documentation for them. You will find the documentation, together with a nice index, in ~/.cabal/share/doc/index.html. If you want the documentation to also include highlighted source code, you need to pass --haddock-hyperlink-source to cabal (or, better, that that option in your config file).

Categories : Haskell

Ignoring an error message from yum command [when package is already installed] - bash
Try to redirect output to grep and filter the message: yum -y -q install something 2>&1 | grep -v "already installed and latest version" Or just completely redirect all messages to /dev/null: yum -y -q install something >/dev/null 2>&1

Categories : Linux

Google api console : 3 Client ID for installed applications with same package and different sha1 key
Simply generate a ClientID for your app. Thenk you'll see that under the "Client ID for installed applications" table there is a "Create another client ID..." button. Use it to add another client ID for the same app with different SHA1. The only negative consequence is that you have to provide your package name, icon and project name for every clientID, so if something has to be changed it has to be changed for every clientID

Categories : Android

How to replace a view using android.support package?
The problem appears to be that your SettingsFragment extends PreferenceFragment which is not in the compatibility library. So when it's saying that your method call is "not applicable for the arguments (int, SettingsFragment)" it means that it expects a support.v4.app.Fragment and you're giving it an android.app.Fragment. Unfortunately, to date, there has been no movement on Google to add PreferenceFragment to the compatibility library. A very thorough discussion on the PreferenceFragment and the compatibility library can be found here.

Categories : Android

I'm new to IntelliJ, can't figure out why my android.support package isn't recongnized?
You have not included support package in the project structure: "File->Project Structure == > Modules ==> Dependencies". IDEA uses it's own build scripts and ignores jars from lib directory, unless they included into the project structure.

Categories : Java

package annotations should be in file package-info.java
You are using the file com/rccl/services/v1/commontypes/package-info.java for annotation the package com.rccl.pcp.api.v1.pricetypes Assumming your package-info.java is in the right path, I think you would have to change its content by, @javax.xml.bind.annotation.XmlSchema(namespace = "http://api.pcp.rccl.com/v1/priceTypes", elementFormDefault = javax.xml.bind.annotation.XmlNsForm.QUALIFIED) package com.rccl.services.v1.commontypes;

Categories : Java

Java - Do I have to annotate a package in all classes that are contained by the package?
No you don't have to... If you had to there's no point in having package annotations. (they will be the same as class level annotations) No it's not possible to quote the JLS Annotations may be used on package declarations, with the restriction that at most one annotated package declaration is permitted for a given package. JLS 7.4.1.1

Categories : Java

Chromecast: Gradle: package android.support.v7.media does not exist
The less intensive way to resolve this is to open your Android SDK manager, and select to download/install SDK 4.1, 4.1.1 API level 16. Then restart your IDE (Android Studio or Eclipse I assume).

Categories : Gradle

Anaconda: Where and how to install a non-distribution package to support a flask-wtf conda recipe?
The only way that conda build will see dependencies is if they also exist as conda packages. So you need to build the conda package for wtforms as well. Fortunately, the recipe for this exists in the conda-recipes as well, so you can just clone that repo and do conda build wtforms conda build flask This works because conda is able to find the packages that it has already built. To make sure that they don't get lost if you delete the build directory, it's recommended to upload your packages to Binstar. If you do that and conda install binstar, after you build, it will ask you if you want to upload the package to binstar. If you do that, and also add your Binstar repo to your .condarc, those packages will always be available for you to conda install.

Categories : Python

Program only runs audio from desktop and not audio in a package on netbeans?
You need to invoke a classloader in order to access files in your package. See here for API description. This is how it works: InputStream inaudio = getClass().getResourceAsStream("/audio/retrolevel.wav"); Clip clip = null; try { clip = AudioSystem.getClip(); clip.open(AudioSystem.getAudioInputStream(inaudio)); } catch (IOException | LineUnavailableException | UnsupportedAudioFileException e1) { e1.printStackTrace(); } clip.start();

Categories : Java

How do I upgrade an existing NetBeans Java EE 6 Web project to Java EE 7?
NetBeans won't automatically update the project files when you update the version in project.properties. You'll have to do it by hand. Update the deployment descriptors in your project to use the Java EE 7 namespaces and schemas. Update the code to use the new APIs and features. Add a Java EE 7 server instance to your Servers, like GlassFish 4.0, and set it as the target server in the Run tab in Project Properties. It's also worth noting that the Java EE version in NetBeans projects doesn't actually affect anything, in my experience. You can have the Java EE version set to 6 in your project, but if it uses EE 7 features and is deployed to a Java EE 7 server, it will run correctly.

Categories : Java

Installed python-docx package yet get the ImportError: No module named docx
Try setting your PYTHONPATH environment variable. http://docs.python.org/2/using/cmdline.html#envvar-PYTHONPATH If you need to find where pip is, you could try the locate command if you're on Linux. http://www.computerhope.com/unix/ulocate.htm http://linux.die.net/man/1/locate

Categories : Python

R.java package name is not as the main package name
R.java's package name is dependent on your AndroidManifest.xml's package element. Change that to whatever you want and rebuild your project.

Categories : Android

Java Installed vs Java Enabled in browser
Here is something js window.navigator.plugin

Categories : Java

How to add icon into Java (NetBeans) from Mac Os X?
First of all, check the obvious solutions such as: Have you done window.add(panelone); Is the file in the correct spot/url is correct Secondly, if you hate LayoutManagers like me, but still want to use javax.swing, you might try using drawString and drawImage methods in your panel's paintComponent(Graphics g) class. In detail: You'll need to make your own JPanel: public class MyPanel extends JPanel { as well as override the method: @Override public void paintComponent(Graphics g) { within the method, call this so the window can refresh itself and do other housekeeping things: super.paintComponent(g); then, use drawString and drawImage to draw these images in the place you would like them: g.drawString("Fruit No. 1", x, y); logo.paintIcon(this, g, x, y); Whenever you change o

Categories : Java

WebService in Java using NetBeans
Just sending WSDL will be not enough since that just defines the protocol and operations of the WS. It does not say anything about implementation. What you need to do is generate a web archive package (.war, think of it as a .jar for webapp) and send that to the customer that you are writing it for. They can then deploy it on to their server.

Categories : Java

java coding in netbeans
Try jPasswordField1.getPassword().length getPassword() returns char[]. See docs.

Categories : Java

Best way to deploy java application on AWS using Netbeans?
This is a lot of questions for one question, but I'll see if I can help you out. 1. Simplest Way to deploy to AWS If this application is as simple as you say it is, the most cost effective solution while you're getting used to AWS will be to deploy to a micro instance and take advantage of the free tier. From Amazon: AWS Free Tier includes 750 hours of Linux and Windows Micro Instances each month for one year. To stay within the Free Tier, use only EC2 Micro instances. The simplest way to deploy directly from Netbeans is to use the integrated Elastic Beanstalk support. This saves you from having to configure things yourself. Another option is to launch a Ubuntu AMI and install Tomcat. Create a WAR file from your application and place it where Tomcat can find it. I suggest using th

Categories : Mysql

Netbeans Cannot start Java DB server (MAC)
at com.mysql.jdbc.NonRegisteringDriver.acceptsURL(NonRegisteringDriver.java:248) at java.sql.DriverManager.getDriver(DriverManager.java:273) at org.apache.derby.impl.drda.NetworkServerControlImpl.startNetworkServer(Unknown Source) How did the Derby network server controller code suddenly jump into the mysql driver? Are you using a mysql database url somewhere?

Categories : Jsp

Netbeans IDE 7.3.1 unable to create Java Web
Go to the Tools menu and select Plugins. Click on the "Available Plugins" tab. Check the box for "Java Web Applications". Click the "Install" button. Click through all dialogs until the plugin and its dependencies are installed. Restart the IDE.

Categories : Java

open a web link in java netbeans
Since you use java you need to escape back slashes. This code perfectly works for me: String fileName="test.html"; try { Runtime r = Runtime.getRuntime(); r.exec("C:\Program Files (x86)\Google\Chrome\Application\chrome.exe file:///C:/temp/" + fileName); } catch (Exception e) { e.printStackTrace(); } Note: put the path in a properties file to get more felxibility

Categories : Java

Best way to bind a XML File in Java (NetBeans)
For this small XML (and not only) I would recommend that you take a look at JAXB. The two basic operations are marshalling (converting Java objects to XML data) and unmarshalling (converting XML data to Java objects) but verification and so on is also provided.

Categories : Java

JFrame class convert to a NetBeans Designer support JFrame class
First of all, Eclipse does have a Swing UI Designer Tool indeed. It is call WindowBuilder Pro and you can update your Eclipse to include it easily. The manual is here. WindowBuilder Pro is very stable and runs on any platform Eclipse supports. It may not be as well integrated to Eclipse, as Matisse GUI builder is in Netbeans, but you can do your development without any problems and limitations with both. You can do almost anything with both plug-ins. Both are flexible and expandable if you learn how to work with them. Conversions of Swing applications between Eclipse and Netbeans are not very easy. You have to select one environment and stick to it. GUI builders do not substitute basic Swing knowledge. It is always best for beginners to write their Swing code, using a regular editor

Categories : Java

Java Eclipse Helios 2 Release Java SE 7 Support
No. Helios does not support Java 7 syntax. It is also an over three year old product. Kepler just came out. Last year Juno came out. The year before Indigo came out. Before THAT Helios came out. Why can't you upgrade your Eclipse?

Categories : Java

NetBeans installer Not locating Java properly
You can pass jdk directory with --javahome in command line. $./netbeans.sh --javahome ~/path/to/jdk/ another solution is to define JAVA_HOME enviroment variable like this: $export JAVA_HOME=~/path/to/jdk $export PATH=$JAVA_HOME:$PATH $./netbeans.sh and also you can download netbeans+jdk bundle from oracle site. In your case the error is about JRE. JRE is inside JDK and installer should find it there. what happens if you pass the JRE path with --javahome? Netbeans can be installed with JRE and then link it with JDK later from inside it. Then try defining JAVA_HOME in your system environment variables and append it to your PATH env too. UPDATE: You can get netbeans, JDK and netbeans+jdk bundles for 32 and 64bit architecture from following link: http://uni-smr.ac.ru/archive/dev/jav

Categories : Java

index.jsp default in Java EE project in Netbeans, where?
In Netbeans by default, if you create a project with no added frameworks, no deployment descriptor(web.xml) is provided. To change it, right click on the project and select New>Other>web>Standard Deployment Descriptor(web.xml) Now edit the web.xml and set <welcome-file-list> <welcome-file>newjsp.jsp</welcome-file> </welcome-file-list> In order to change the default to newjsp.jsp UPDATE Explicitly for tomcat.... If no web.xml is provided in the application, the default web.xml($CATALINA_HOME/conf/web.xml) of Tomcat is supplied to the application. This deployment descriptor has the following lines: <!-- --> <!-- If you define welcome files in your own application's web.xml --> <!-- deployment descriptor, that list *replaces* the li

Categories : Java

Problems With encoding Java Web Project - Using Netbeans 7.3
I'm from Mexico, so we use ñ and this char doesn't work in other countries so what we do is use (char)+number something like this: (char)225 = á (char)224 = à (char)227 = ã (char)231 = ç maybe can help you

Categories : Java

Not able to open already created Java ME project in NetBeans
If new projects work, Netbeans probably lost the platform configuration for your project (this happened to me once). To reconfigure it go to Project Properties -> Platform and set the Platform Type and Emulator to your JavaME platform.

Categories : Java



© Copyright 2017 w3hello.com Publishing Limited. All rights reserved.