w3hello.com logo
Home PHP C# C++ Android Java Javascript Python IOS SQL HTML Categories
How to fix TPM in Redhat Linux? RedHat Linux hang on first time to boot after installing
After all my search I found out that in Redhat 6 there is a problem tboot and best way to fix it is to remove tboot package (it is located in System Base>Base>tboot.6) For more info about tboot you can check these links: enter link description here

Categories : Linux

Installing honeyd on linux
Please provide the complete error output. Maybe the honeyd FAQ is a starting point for you http://www.honeyd.org/faq.php#compile_error

Categories : Linux

Installing numpy-1.7.1 with MKL-10.3 using gcc-4.7.2 on linux
Adding the path to libiomp5 to the LD_MODULES_PATH environment. The servers I am currently using use the modules library to manage server-wide applications and libraries. I had previously only used the standalone MKL/10.3 module but substituting that for ifort_icc/13.0 (which also contains MKL) added icc-related paths to the LD_MODULES_PATH. Using the same site.cfg as described above seems to work and numpy runs the test suite. I don't know if this is the most elegant solution but it will do the trick for now.

Categories : Python

Installing RQuantLib on Linux
It might just be that the dynamic loader hasn't realized yet that you've added QuantLib. Try adding the line /usr/local/lib to /etc/ld.so.conf (if it's not already there) and then run sudo ldconfig On your system there should be man pages for both ld.so and ldconfig if you want to understand what you're doing, which is always a good proposition. Never execute commands given by strangers on the internet, especially in sudo mode :) After you do the above, you should be able to load libQuantLib.

Categories : R

Installing Patches in linux
A patch file like this contains the differences between two versions of text files. This one contains changes to these source files: arch/x86_64/vdso/vclock_gettime.c | 4 ++-- arch/x86_64/vdso/vextern.h | 1 + include/asm-x86_64/vsyscall.h | 1 + You can't install it. You can use it to patch the source code (if you have it), compile it and install the results. But I don't think that is what you want. If you want to install bugfixes use your package manager (I guess it's 'yum' for RedHat).

Categories : Linux

Need help in Installing Tide SDK in Linux
I didn't need to 'install' anything. I just downloaded TideSDK SDK and the Developer App (maybe you use 64bit...then choose these). Then you must extract the SDK into your users folder: ~/.tidesdk. After that you have a sdk folder in there. The Developer can be extracted whereever you want. You don't need to execute the installer. Just execute TideSDK Developer. PS: The TiDev Developer app is replaced by the Developer App that you can download from the tidesdk website.

Categories : Misc

Installing Maven 3.0.5 in RedHat Linux
The first thing we need to do is to download the Maven tar file and untar it to a shared location on the workstation wget http://mirrors.gigenet.com/apache/maven/maven-3/3.0.5/binaries/apache-maven-3.0.5-bin.tar.gz su -c "tar -zxvf apache-maven-3.0.5-bin.tar.gz -C /opt/" Setup the Maven Environment Variables in shared profile. The next step is to setup the Maven environment variables in a shared profile so all users on the system will get them import at login time. su -c "vi /etc/profile.d/maven.sh" # Add the following lines to maven.sh export M2_HOME=/opt/apache-maven-3.0.5 export M2=$M2_HOME/bin PATH=$M2:$PATH Now test your install of Maven. Logout of the system and then log back into it. Enter the following command: [jsmith@regan ~]$ mvn -version If you did everything right

Categories : Linux

installing gedit in linux with python 2.7.3
As far as I know gedit is installed by default. Try type gedit in a terminal and see if it opens. alternatively in a terminal type sudo apt-get install gedit This will install Ubuntu's current favorate version of gedit. In either case this wont get you the latest version but unless you are super keen on the latest version for some reason then don't worry about it. If you do want the latest version you need to install python3 first in which case this should help: http://askubuntu.com/questions/244544/how-to-install-python-3-3

Categories : Python

problems in installing libxml2 on linux
You need python headers. Since you're on Ubuntu, you can probably avoid compiling python. Try $ sudo apt-get install python-dev and then compile libxml2. Alternatively, the LFS link that you've posted points to instructions for compiling python.

Categories : Ubuntu

Installing scipy with pip on a linux server
After a lot of trying, I did a clean install of Python in a new virtual environment. And since I was doing a clean install I went with Python 2.7.5. Then activated the virtual environment. Then used pip install to install numpy and scipy, which did not work! (Have no idea why. It would be great to know if someone has a clue). However, tried easy_install and both numpy and scipy worked. Happy that it worked, but am not going to sleep peacefully because have no clue what was the actual problem. Following are the complete codes: 1) Install python wget http://www.python.org/ftp/python/2.7.5/Python-2.7.5.tgz tar -zxvf Python-2.7.5.tgz mkdir ~/Python-2.7 cd Python-2.7.5 make clean ./configure --help #get to know the options in configure ./configure --help | grep -i ucs $get to know the UCS op

Categories : Python

Problems installing R on Linux CentOS 6.3
Hi You can install the missing packages by downloading rpm and install using rpm command libjpeg.so.62 and kernel-headers To install .rpm package use the following steps rpm -iv package.rpm Try yum install R After that. :)

Categories : R

Installing RubyOnRails on a RedHat linux box
Use RVM and it will be a matter of copy pasting a command and you are done. https://rvm.io/rvm/install To install both Ruby and Rails: curl -L https://get.rvm.io | bash -s stable --rails

Categories : Ruby On Rails

Android SDK not installing components on linux (ubuntu)
is there a way to launch the sdk as superuser via command-line? sudo .../tools/android where ... is the path to your Android SDK installation. In your case, from the error message, this would appear to expand to: sudo /opt/android-studio/sdk/tools/android

Categories : Android

Installing GDAL python binding Linux
If you have GDAL installed and libgdal.so exists, it looks like the python module is just not finding the library. You can try setting the LD_LIBRARY_PATH environment variable to point to the directory containing libgdal.so (e.g. /usr/local/lib). If that works, run ldconfig to update your library settings so you won't have to set LD_LIBRARY_PATH every time (which many consider a bad idea).

Categories : Python

MacPorts: Installing arm-none-linux-gnueabi-* fails
Build it with FSF gcc. e.g. port install arm-none-linux-gnueabi-gcc configure.compiler=macports-gcc-4.8 P.S. make sure u have gcc-4.8 installed. This issue is caused by the command: cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_cross_arm-none-linux-gnueabi-gcc/arm-none-linux-gnueabi-gcc/work/build" && /usr/bin/make -j8 -w all AR_FOR_TARGET=arm-none-linux-gnueabi-ar AS_FOR_TARGET=arm-none-linux-gnueabi-as LD_FOR_TARGET=arm-none-linux-gnueabi-ld NM_FOR_TARGET=arm-none-linux-gnueabi-nm RANLIB_FOR_TARGET=arm-none-linux-gnueabi-ranlib issueing this command the output from clang: ... In file included from /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ta

Categories : Misc

Installing subversion under /apps other than /var/www/ is not working. Centos Linux version
In the httpd.conf file your Document Root Section probally says <Directory "/var/www"> Also you can give apache ownership of that directory but only if such is placed in the document root. (If I understand you this may not work for you) chown -R apache.apache /apps Apache can access items outside the root but that is soemthing I am not familiar with and you can look into the apache Alias EDIT As the comment under your OP says SVNADMIN should be able to create the repo and you should be able to hit it. mkdir /app/svn svnadmin create /app/svn/testrepository chown svn:svn -R /app/svn Subversion also is very nice about keeping space low since it only stores revisions to projects instead or brand new versions each time. EDIT Setup Walkthrough - Posted in comments

Categories : Svn

/lib/libc.so.6: version `GLIBC_2.9' not found error while installing Qt5 on Linux
Don't mess with the system libraries -- just upgrade your distribution. Glibc 2.11 has been released in 2009, that's four years ago.

Categories : Linux

Re-installing Linux O.S. and then running bunch of commands in a .sh script , how to stop the script if something fails?
You can check the error code from commands you run #!/bin/bash function test { "$@" status=$? if [ $status -ne 0 ]; then echo "error with $1" exit 255 fi return $status } test ls test ps -ef test not_a_command taken from here for more information Bash Beginner Check Exit Status

Categories : Linux

Installing SQL objects in C# - issue when installing CLR assembly and function scripts
I have now fixed this problem. The issue turned out to be that I was using the same SQLCommand later on to execute a stored procedure (as I have given the command a SQLTransaction so I can rollback if it fails) and had forgotten to remove the parameters that were added when I run the next text command. Therefore it was running the first script file and failing afterwards.

Categories : C#

Installing M2Crypto inside of virtualenv without installing swig to the system
So in the end I got this to work by letting buildout handle downloading and installing swig and M2Crypto and then just moving the built M2Crypto and EGG-INFO directories from where buildout put them to where virtualenv wanted them...this might not be the optimal solution, but hey, it worked.

Categories : Python

Installing setuptools prior to installing python dependencies on Mac
You command attempts to install files into system directories. You must execute the command as root or with sudo: sudo sh setuptools-0.6c11-py2.7.egg You can see this error with the: [Errno 13] Permission denied Edit: If you don't have permissions, you can try installing into your user's Library folder, or look at virtualenv. (See the part about using locally from source.)

Categories : Python

What is the difference between installing an app via homebrew or installing it "normal"?
homebrew (like Macports) is a package manager. It allows you to manage packages (update, delete etc.). Most importantly, homebrew will compile the application on your platform. That's especially important for ports, e.g. from Linux. homebrew will give you greater and more fine grained control over what you install, where, what compilation attributes you want to use etc. But this comes at the cost of a bit more complexity and the need to know your way around the command line. Downloading a binary and putting it in the Applications folder is easier by far and usually works fine. If your not a developer and don't need to manage many different tools then I'd recommend sticking with binary downloads. If you're a developer however, you will most likely not get around a package manager if you n

Categories : Osx

Checking and Installing .net 4.0 before while installing my forms app in SharpSetup WIX
You can check if the .NET framework is installed by linking to the NetFxExtension with light. Just add a PropertyRef to the one you want. You can find a list of those properties here. Say you want to make sure .NET framework 4.0 Full is present before installing your software, you'd add this somewhere in your source code: <PropertyRef Id="NETFRAMEWORK40FULL" /> <Condition Message=".NET Framework 4.0 Full is not installed."> NETFRAMEWORK40FULL </Condition> When running the MSI, the LaunchConditions action will run and check if the NETFRAMEWORK40FULL property is set. If it is, the installation continues, if not, the installation fails. However, if you wanted to install the .NET Framework beforehand, you'll need two WiX projects. One for your basic MSI, and one for

Categories : Dotnet

Rails installing mysql - Error installing mysql2: ERROR: Failed to build gem native extension
I've been so annoyed by the same problem, and finally succeeded in installing mysql2. Kudos to odiszapc@github. It appears any other solution I've found via Google than below doesn't work to me. Copied and pasted from here. So no credit to me. gem uninstall mysql2 Download last MySQL connector from http://cdn.mysql.com/Downloads/Connector-C/mysql- connector-c-noinstall-6.0.2-win32.zip Extract it to C:connector-6.0.2 gem install mysql2 --platform=ruby -- '--with-mysql-lib="C:connector-6.0.2lib" --with-mysql-include="C:connector-6.0.2include" --with-mysql-dir="C:connector-6.0.2"' Additional info on mine. ruby 1.9.3p392 (2013-02-22) [i386-mingw32] Rails 3.2.13 MySQL Server 5.6 mysql2-0.3.13 P.S Even if you successfully installed mysql2, you may still need some work (e.g. mysql2

Categories : Mysql

Linux users', specifically Apache, permissions settings, [Linux noob :]
usually any daemon will need to access a number of ressources. it is therefore good practice to run each daemon under a special user:group, rather than nobody:nogroup. traditionally (e.g. on Debian systems) apache runs as www-data:www-data. finally, user permissions take precedence over group permissions (which in turn take precedence over other permissions). this means that a directory where the user does not have write perms but the user's group can write is effectively r/o for that user (but not for other members of the group)

Categories : Linux

Exec(Linux). How it functions internally? Linux executable attributes(rlimit)
The RLIMIT_CORE is used to place a limit on the amount of info that coredump is allowed to produce, before it is aborted. Once this limit is hit, no more info is logged and the message Aborting Core is logged to the console. From the man page of core : A process can set its soft RLIMIT_CORE resource limit to place an upper limit on the size of the core dump file that will be produced if it receives a "core dump" signal. Use setrlimit() to configure RLIMIT_CORE to a larger value to obtain complete coredumps. The most common format of executables/shared-objects is ELF. On Linux, the dynamic loading and linking of these shared-objects is performed by ld.so ld.so is loaded in the address space of a newly created process (by exec in this case) and executed first. This is possible as

Categories : Android

Purpose of Curly Brace Usage of C Code found in Linux (include/linux/list.h)?
This is a GNU language extension known as a statement expression; it's not standard C.

Categories : C

How to turn a Linux application in C/C++ into a Desktop Enviroment for a Linux distro?
You either want to create a boot loader, or you want to replace the 'shell'. This would be governed by per-user or global xinit and Xsession files.

Categories : C

What's a good way to set up Closure Compiler on Linux? Or, where should Java .jar's live on a Linux?
If you using the java command directly, then you'll have to provide a path to the jar in question. It's probably easier to place the jar in one place and create a shell script that handles the invocation and jar path.

Categories : Java

Write C++ on Windows but use Linux System calls through a Linux emulator
You've already tagged your question with Cygwin. That seems like the best solution for what you want. Cygwin is basically a collection of programs which emulate a GNU/LInux environment through the use of a DLL (cygwin1.dll) which acts as a Linux API layer providing substantial Linux API functionality. Here's the link to the documentation for its API Edit: Most of the Cygwin source code that I've looked at is written in C++ and makes system calls using MS Windows API to do provide the *nix emulation. The source is well written and very readable (even to to a non-C++ programmer such as myself). I think using Cygwin would be a good transition from programming on Windows to a GNU/Linux environment.

Categories : C++

Do i need to install mono on every Linux PC to run .NET application on Linux platform?
"can I run a mono application on a machine that doesn't have mono installed": no; the same as you can't run a java application on a machine that doesn't have java installed. And at the same time (to both): yes. There are tools that attempt to make this work, but they tend to be fiddly and a bit unreliable. However, it should also be noted that several (not all, by any means) distros ship with mono by default.

Categories : Dotnet

fedora linux --- compiling first linux module
As guido said, you have to match your current kernel and the kernel-devel package. To get your kernel version run uname -r I get 3.6.10-4.fc18.x86_64, download that kernel-devel version sudo yum install kernel-devel-3.6.10-4.fc18 Or update your system and boot with the new kernel, I believe those two will automatically match.

Categories : Linux

How to start init.d script on bootup in embedded linux. I dont have update-rc.d. Is there any other way to start init.d script on linux boot?
You can edit the /etc/inittab file. Also, there are 2 other alternatives to update-rc.d: Rcconf - Rcconf allows you to control which services are started when the system boots up or reboots. It displays a menu of all the services which could be started at boot. The ones that are configured to do so are marked and you can toggle individual services on and off.This tool configures system services in connection with system runlevels. It turns on/off services using the scripts in /etc/init.d/. File-rc - Alternative boot mechanism using a single configuration file This package provides an alternative mechanism to boot the system, to shut it down and to change runlevels. The /etc/rc?.d/* links will be converted into one single configuration file /etc/runlevel.conf inste

Categories : Linux

Installing/using SDL for Qt
Compiling with SDL and g++ cannot find -lSDLmain etc Undefined reference to WinMain@16 when using SDL I am sure one of those is also applicable to your question.

Categories : Qt

Installing pip on Mac OS X
You can install it through Homebrew on OS X. Why would you install Python with Homebrew? The version of Python that ships with OS X is great for learning but it’s not good for development. The version shipped with OS X may be out of date from the official current Python release, which is considered the stable production version. (source) Homebrew is something of a package manager for OS X. Find more details on the Homebrew page. Once Homebrew is installed, run the following to install the latest Python, Pip & Setuptools: brew install python

Categories : Python

C++: Help installing FLTK
0) What did you try? 1) Do you have the Cygwin toolset? If not, download it. Extract the files from fltk's tar.gz file using the TAR command. Open a command window in the folder for the extracted files. Run: >> bash configure (I think). When that's done (checking for g++, gcc, and other stuff), run: >> make && make install I think my install took about 20 minutes...

Categories : Windows

Installing MSI vb.net with MsiSetExternalUI
Take a look at Windows Installer XML's (Wix) Deployment Tools Framework (DTF) MSI interop library (Microsoft.Deployment.WindowsInstaller.dll ) It has all the pieces needed to invoke an installation and provide an external UI handler to receive the ProgressBar update messages that you can then route to your VB.Net UI. See the following topic and subtopics for more information: Monitoring an Installation Using MsiSetExternalUI The examples are in C++ using MSI Win32 functions and the DTF interop library encapsulates all of this with classes. The DTF help file tells you which classes and methods map to which Win32 functions.

Categories : Misc

Installing PIP on dreamhost
You will need to install virtualenv. This can install packages into a location that you have permissions and will integrate the virtual environment with the python interpreter from your system. The package can be found at https://pypi.python.org/pypi/virtualenv. I suggest you follow the route install locally (of course if you can't install it global). From the docs $ curl -O https://pypi.python.org/packages/source/v/virtualenv/virtualenv-X.X.tar.gz $ tar xvfz virtualenv-X.X.tar.gz $ cd virtualenv-X.X $ python virtualenv.py myVE

Categories : Python

Installing v8-profiler using npm
According to this comment on GitHub, some APIs were removed from V8, and v8-profiler hasn't been updated. It was V8 problem. v8-profiler uses some V8 API's, but those API's are eliminated from V8 in version 3.11.5. ... In order to use v8-profiler, simplest way is to remove the following methods and SetAccessor call inside constructor from graph_node.cc and rebuild v8-profiler. GraphNode::GetRetainersCount GraphNode::GetRetainedSize GraphNode::GetRetainer GraphNode::GetDominator But of course, if you do this, you can't see anymore dominator and retainer informations.

Categories : Node Js

Installing R on RHEL 6
Try this one rpm -ivh http://mirror.unl.edu/epel/6/x86_64/epel-release-6-7.noarch.rpm The second is: #yum install R Thanks & Regards, Alok

Categories : Linux



© Copyright 2017 w3hello.com Publishing Limited. All rights reserved.