w3hello.com logo
Home PHP C# C++ Android Java Javascript Python IOS SQL HTML videos Categories
Install Java Package
You can use ports. The recommended Java implementation is OpenJDK in /usr/ports/java/openjdk7. You can use the Linux implementation of Sun's (now Oracle) java with /usr/ports/java/linux-sun-jdk17. Note that this has some legal restrictions, see the port Makefile.

Categories : Java

"The gem ... has been deleted. It was installed at" Error. Bundle install doesn't install gems. How to re-install gems?
This solved it for me: "gem install" and "bundle install" do not install gem dependencies after manual gem deletion. How to inform Rubygems that gems were deleted manually? (Delete the .gemspec files for the gems you have removed).

Categories : Misc

How to install java class for Coldfusion 10
The only difference in CF10 is there is an extra directory layer between the {install root} and {web root}. ie coldfusion8wwwroot coldfusion10cfusionwwwroot However, it does not change the rules about class loading. Jars can be placed anywhere, as long as they are accessible to the CF service, and the directory is in CF class path, or the default jvm class path. There are several directories in the default class path that CF checks automatically, such as {cf_webroot}web-inflib. The simplest option is to place them in that directory. Then CF will pick them up automatically, no need to muck with the class path settings. Just drop your jars in that folder, restart the CF service, and you are good to go.

Categories : Java

How to install Java 7 EE SDK download as .sh file for Mac OSX
Run it at the command line. From the install manual: Java Platform, Enterprise Edition 7 SDK - Installation Instructions Solaris, Linux, and Mac OS X systems: If necessary, grant execute permissions to the distribution file: chmod +x ./ distribution-filename At the command prompt, type: sh ./ distribution-filename For future reference a *.sh file is a shell script. You can inspect the shebang (#!) at the first line of the file to see what shell should be used to interpret the script. In the case of the JavaEE 7 installer the shebang is #!/bin/sh which indicates a Bourne compatible shell should be used.

Categories : Java

Eclipse for Java EE can't install and remove plugins
If you are unable uninstall plugin by any then the best way to delete a plugin is delete the plugin folder. You can find folder of specific plugin by: Go to "Help - About Elcipse Platform - Plug-in Details" and search for the Plug-in Id for the plugin you want to delete. After this search in eclipse/plugin/ folder named that Id and delete that folder. Normally plugins can be delete by going to Help > About Eclipse SDK > installation details and then uninstall that plugin. Hope this help you.

Categories : Eclipse

How to install Java file into windows services
Take a look at Java Service Wrapper. It enables a Java Application to be run as a Windows Service or UNIX Daemon. http://wrapper.tanukisoftware.com/doc/english/download.jsp

Categories : Windows

What I need to install for getting java pattern wizard on eclipse?
It used to be included in CodePro, but the current version (CodePro Analytix) doesn't have this feature any more.

Categories : Eclipse

How to install a software and then run java class from batch file
If the Java doesn't work have you tried to launch the batch without "Setup.exe"? @echo off cd ACR122U_MSI_Winx64_1120_P REM Setup.exe java -cp zpay-client-1.5-jar-with-dependencies.jar;. esources com.abc.posgui.LicenseValidator Otherwise, are you sure that the installation has stopped?

Categories : Java

Install commons math library for java in Ubuntu
To install Apache Commons use: sudo apt-get install libcommons-math-java Set the classpath to whichever directory contains the library you are using. Something like: javac -classpath .:/library/directory/path/ MyProgram.java Run man javac for more information.

Categories : Java

Need Easy Way to install & configure Java JDK & Tomcat on Fedora 13/Linux
Installing JDK on Fedora: 1 ) Please visit sun java website to download any java jdk version you like. http://java.sun.com/javase/downloads/index.jsp 2 ) Click download, select Linux platform, language and accept license and continue. 3 ) Select “Linux RPM in self-extracting file” and download jdk_filename-rpm.bin file (jdk-6u6-linux-i586-rpm.bin). 4 ) After downloaded, changed to the directory where you saved the file. 5 ) login to root user or su to root or sudo, and issue ‘chmod +x jdk_filename.-rpm.bin’ to make it executable. chmod +x jdk_filename.bin 6 ) Execute it ./jdk_filename-rpm.bin 7 ) Press space bar , repeat until system prompt to enter yes or no, type y and enter to continue. 8 ) This will output a .rpm file in same directory 9 ) Issue rpm -i jdk_filename

Categories : Java

jar: error while loading shared libraries: libjli.so [How to manually install Java 6]
I'm posting my solution on here in case anyone else runs into a similar problem and stumbles across this. I simply re-installed my OS, ran the steps again, and everything worked perfectly fine this time. I must have caused some sort of error on my machine as I ran the same exact steps too. Here is what I did to manually install Java 6 on a clean machine: Install Java 6(.bin format) from the Oracle website Give it executable permissons and execute it Add a jvm folder to usr/lib/ Move your Java 6 folder to usr/lib/jvm Link java/javaws/javac to usr/bin using the ln -s command Add your Java6 and Java/bin location to your path. For me its: export JAVA_HOME=usr/lib/jvm/jdk1.6.0_45 export PATH=/usr/bin:$JAVA_HOME/bin

Categories : Java

How to Install Matplotlib Basemap Module on Windows 7 with WinPython (or any Python stack install)?
I use windows. And my installation failed with official guidance, too. Finally I installed Basemap using the following method. Although I am not sure if it will go right for you, I just offer mine. First of all, you must have pip in your computer. (It is much easier to install, compared with Basemap and other things. And it can be used to install many useful packages.) Then go this great link: http://www.lfd.uci.edu/~gohlke/pythonlibs/ And download the file named "basemap‑1.0.8‑cp27‑none‑win_amd64.whl". Remove the .whl file to directory "C:Python27". (Maybe you installed your python in different disk, then change it accordingly.) Open terminal. (Use cmd or Git Bash or something else.) Use command: pip install basemap‑1.0.8‑cp27‑none‑win_amd64.whl

Categories : Python

Pip install python package into a specific directory other than the default install location
System: Ubuntu 12.04, Enthought Python Distribution (this is where I wanted to install a new python module) So the prefix_path environment variable didn't work for me and pip still kept installing it in the default location. But I used change default directory for pip install question as a guide. And one of the answers helped me achieve what I needed. pip install -d <path_to_my_directory> For the path I used: path_to_epd_directory/lib/python2.7/site-packages This puts the tar.gz file into the site-packages Then extract it using: tar -zxvf pymodule.tar.gz a directory named pymodule is created, cd into that module and type: python setup.py install and that should do the job.

Categories : Python

Error "invalid switch in RUBYOPT: -F (RuntimeError)" is shown while install gems by gem install mechanize
I found the reason. Just because there is a space in the installation path of Ruby RUBY EXECUTABLE: "C:/Program Files/Ruby200-x64/bin/ruby.exe" Re-install the Ruby to the path which doesn't contain space, this error will be fixed. And, of course, AutoRun should be removed from HKCUSoftwareMicrosoftCommand Processor and HKLMSoftwareMicrosoftCommand Processor. That's important!

Categories : Ruby

C# Install - Change a custom folder location using install dialog
So PATHPROPERTY returns the custom folder location user has selected, If thats the case you have to set that property to "Property" attribute. Also make sure in the User Interface Editor you are getting the user input before installation starts. (You can move up and down the UI to required position)

Categories : C#

How install ruby with rbenv install 1.9.3-p448 ubuntu 12.04 vagrant box?
Download the ruby using your browser from ftp://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.3-p448.tar.bz2 and place it in ~/.rbenv/caches/ruby-1.9.3-p448.tar.bz2, then run rbenv install 1.9.3-p448 Explanation here

Categories : Ruby On Rails

Component install error: JInstaller: :Install: File does not exist
check if you have added this code to your XML: <languages> <language tag="en-GB" client="site">language/en-GB/en-GB.com_helloworld.ini</language> <language tag="en-GB" client="site">language/en-GB/en-GB.com_helloworldt.sys.ini</language> </languages> and: <administration> ... <languages> <language tag="en-GB" client="site">language/en-GB/en-GB.com_helloworld.ini</language> <language tag="en-GB" client="site">language/en-GB/en-GB.com_helloworld.sys.ini</language> </languages> ... </administration> and check if the files are included in your installation ZIP - in right folder, e.g.: language/en-GB/ ... Be aware, the path to the file can be different for

Categories : PHP

When exporting .Apk in the android manifest its does not install on other phones, when getting from Bin folder it does install?
There is most likely a problem with the certificate. Try making a new certificate, keystore, and alias, then generate the .apk again. Make sure that no previous instance of the app is on the phone when you try to install this new version or the mismatch of signatures will cause the installation to fail. Also, was there a previous version of the app installed on their phones already? The signature mismatch may occur due to the use of both signed and unsigned(in reality the .apk is singed, but it is done automatically by the system) .apks

Categories : Android

Why "bundle install" try to install outdated version of gems?
bundle install or in short bundle does not install the latest gem unless you have left out the version in your Gemfile. e.g. gem 'rails' But usually this is not the case, we specify versions to prevent application from "crashing" when some gems are updated and we unknowingly run bundle update, or for that matter move application to say test or production servers. Usually when adding a gem to Gemfile, we do: gem 'rails', '~> 3.2.7' Note the leading ~> in the version number. This says: use rails gem between versions 3.2.7 and less than 3.3.0. In order for your bundle command to grab rails 4.0, you need to change that line to read either one of the following: gem 'rails', '>= 3.2.7' or gem 'rails', '4.0.0' If you use gem 'rails', '>= 3.2.7' then your rails appl

Categories : Ruby On Rails

rails heroku - how to install javascript dependences that needs 'npm install ...'
If you are deploying a Node app, declare it in your package.json, otherwise, specific it in your gemfile. https://devcenter.heroku.com/articles/getting-started-with-nodejs#declare-dependencies-with-npm

Categories : Ruby On Rails

Bundle install gets permission issues with global RVM install
This error doesn't necessarily need to be solved. Your bundle is installing properly, but it's not able to remove cached gems. It's a pretty harmless error unless you're running way short on hard drive space. I actually get this same error too. The problem is that my home directory is remotely mounted, so local root doesn't have permission to modify items there. Local root only has global write permissions on local directories. I imagine, based on what you describe, that you have the same issue. You could remove the files manually, or you could instruct rvm to install gems in a directory on the local machine.

Categories : Ruby On Rails

Install multiple packages on linux (like pip install -r requirements.txt)
Put the list of packages in a text file(say test.txt) with package names separated by spaces, like this - python ruby foo bar then you can just install with apt-get like this - sudo apt-get install $(cat test.txt)

Categories : Linux

Go install always fails no install directory outside GOPATH
You are using go install on a directory outside the GOPATH folder. Set your GOBIN env variable, or move src folder inside GOPATH. GOPATH/ bin/ src/ go-statsd-client/ More info: GO BUILD Source code, line 296

Categories : Osx

Can't Install gem install mysql2 Ruby WINx64
I've downloaded the connector from http://dev.mysql.com/downloads/mirror.php?id=412857 and typed in the command prompt gem install mysql --platform=ruby -- --with-mysql-include=C:mysql-connector-c-6.1.0-winx64include --with-mysql-lib=C:mysql-connector-c-6.1.0-winx64lib

Categories : Mysql

Rails : gem install vs. gemfile&bnudle install
RubyGems is akin to a package manager for Ruby. It's a means by which you can install self-contained libraries to use in your applications. When you use gem install gemname you're installing that gem to the current machine that you're developing on. Bundler is a tool for managing the gems that your application depends on. When you create a Gemfile, you list the various gems and their versions that your application requires. This allows you to easily ensure that your application has the gems it needs when you deploy it to a new location - for example, when you push to Heroku, your Gemfile is used to determine all the dependencies of your application. Running bundle install will take the list of required gems in your gemfile and install them if they aren't installed already, just like

Categories : Ruby On Rails

Trying to install a Scitools Python pkg via 'pip install' but getting error
I had the same error but resolved it by manually installing all the Anaconda packages. NumPy SciPy Pandas PyTables h5py Matplotlib IPython Spyder Qt/PySide VTK Numexpr Astropy Cython LLVM LLVMpy Numba Scikit-learn Scikit-image NLTK NetworkX MayaVi

Categories : Python

How to install/configure new software in newly created amazon instances using Amazon SDK in java?
The Amazon API primarily controls infrastructure. It does not have any control as to what happens inside the instance. There are a couple of ways you can bootstrap your instance and install software. You can use user-data to pass a script that will run on first launch. You could use a provisioning system like chef or puppet. You could roll your own if it works better for you.

Categories : Amazon

How can I install Leiningen self-install from behind a firewall?
This should help: https://github.com/technomancy/leiningen/wiki/HTTP-Proxies You should work on your googling skills ;)

Categories : Misc

how to install php 5.4 install on ubuntu desktop 12.04?
Maybe this tutorial will help http://www.barryodonovan.com/index.php/2012/05/22/ubuntu-12-04-precise-pangolin-and-php-5-4-again

Categories : PHP

Steps to Install Git from source, install Post-Git from source, and then load up Posh in PowerShell?
Check out https://github.com/msysgit/msysgit for building Git for Windows. (For what it's worth, I've never built Git on Windows and don't consider myself to have missed out.) Once you have Git built (or installed): Add the location of git.exe to your %PATH% Clone posh-git to a directory of your choosing Run posh-git's install.ps1 to install the default prompt in your $PROFILE

Categories : Windows

Rake db:migrate error Please install the sqlite3 adapter: `gem install activerecord-sqlite3-adapter`
It looks like you might be using sqlite in development. Can you try this in your gemfile instead of what you have? group :development, :test do gem 'sqlite3' gem "unicorn", "~> 4.6.2" end Then usual bundle install and run migration again.

Categories : Ruby On Rails

Python GDAL: pip install --no-install GDAL fails
A workaround to that problem is to Download GDAL Complete from this site Install GDAL Complete.pkg Go to /Library/Frameworks/GDAL.framework/Versions/1.10/ and copy all files in there Go to your virtual environment's sites-packages /venv/lib/python2.7/site-packages and paste the copied files in there

Categories : Python

Permission error when try to install psycopg2 on Mac with "pip install psycopg2"
For a variety of packages that require c compilation (gevent, zeromq, etc.) it seems that pip is adding extra spaces to the command, causing it to fail: go into Xcode and explicitly download the Command Line Tools (under Preferences > Downloads). From: http://www.pressingquestion.com/5111217/Pip-Installation-Adds-Extra-Spaces-To-Command-On-Os-X-108

Categories : Misc

What's the pros and cons to install HBase + Hadoop together vs. install HBase and Hadoop seperately?
Option 1: An integrated cluster. Pros: MapReduce which reads or writes HBase will more efficient as the data locality. Cons: The HBase region server will reduce the performance of the machine (Datanode and TaskTracker) as it need to hold some CPU and memory. The HBase latency may be seconds if there are many MapReduce jobs. So if you want to make HBase response in time, you need more work (For example, using memcache to improve the read performance). Option 2: 2 clusters. Prons: The HBase region server will not impact the performance of the HDFS Datenode and the TaskTracker. Cons: MapReduce needs to read and write the data remotely if it wants to access HBase. The option also needs more machines.

Categories : Hadoop

Please install the postgresql adapter: `gem install activerecord-postgresql-adapter`
First of all best practice is to use same DB for all environments. Could you please run RAILS_ENV=production bundle exec gem install pg on server? The problem seems to be in absence of pg gem in assets group when running RAILS_ENV=production RAILS_GROUPS=assets bundle exec rake assets:precompile

Categories : Ruby On Rails

How to add (read) java.io.FilePermission to my /usr/share/java/mysql-connector-java.jar for a java applet using MySQL on Ubuntu?
java.security.AccessControlException: access denied (java.io.FilePermission /usr/share/java/mysql-connector-java.jar read That means that you need to either: Add an AllPermission covering that file or directory to the .policy file that is active when the applet executes. Add an explicit java.io.FilePermission read ditto. And it doesn't mean anything else. Most of your post is therefore irrelevant: specifically, your points 1, 2, 5, 6, and 7. Sign the JAR file. This is by far the best solution. It solves that problem and many others. The fact that your 'applet is not a runnable jar file' has nothing to do with whether you should sign it.

Categories : Java

Java: Unable to fix unchecked conversion required java.util.Collection
If oldV is declared as a Vector<String> just use the parameterized version of 'LinkedHashSet': Vector<String> newV = new Vector<String>( new LinkedHashSet<String>(oldV) ) you can also use the annotation @SuppressWarnings if you just want to get rid of the warnings: @SuppressWarnings("unchecked") Vector<String> newV = new Vector<String>( new LinkedHashSet(oldV) );

Categories : Java

Java "ajp-9009-AsyncTimeout" java.lang.OutOfMemoryError: Java heap space Errors
Without specifics, it's difficult to identify your issues. I would look at tools like YourKit to profile your app (you can get a free 30 day trial, ISTR) and VisualVM to dig down into your JVM. But, if your webservice takes your 100,000 records, renders them into XML/JSON and sends them out in one request/response, then that's a lot of data to pull from the db, marshall and transmit. I would investigate that design and see if that's the fundamental issue.

Categories : Java

How to use Maven to build a Java EE project with Java class references to several dependent Java projects?
You are getting this error because you are trying to join everything with maven pom file where packaging node is set to war: war/ +--- project 1 - jar/ | +--- project 2 - jar/ instead you have to reorganize your project and join everything in project with packaging type set to "pom" pom/ +--- war/ | +--- project 1 - jar/ | +--- project 2 - jar/ Maven requires parent pom to be of type "pom".

Categories : Java

Getting error A message body writer for Java class java.util.ArrayList/List was not found
You should add at least a getter in your StringWrapper. Without public attributes, there is nothing to serialize. So the output is correct. If you do not want a tag around the list of your strings, you can mark a single getter with @XmlValue. @XmlRootElement public class StringWrapper { public StringWrapper (){} List<String> list=new ArrayList<String>(); public void add(String s) { list.add(s); } @XmlValue public List<String> getData() { return list; } }

Categories : Java



© Copyright 2017 w3hello.com Publishing Limited. All rights reserved.