w3hello.com logo
Home PHP C# C++ Android Java Javascript Python IOS SQL HTML videos Categories
Ansible after 'vagrant provision' gives this error "Could not import python modules: apt, apt_pkg. Please install python-apt package."

I see you're using a specific python interpreter for python2.6, and that you're using an Ubuntu Precise 64 image. I believe the Precise 64 package for apt-get is for python 2.7 (per apt-cache show python-apt). Assuming you used apt & default sources to install python-apt, I don't think the apt packages will be available to the 2.6 interpreter.





© Copyright 2018 w3hello.com Publishing Limited. All rights reserved.