w3hello.com logo
Home PHP C# C++ Android Java Javascript Python IOS SQL HTML videos Categories
How to use root context as wsdl end point in CXF Web service
I had the workaround, Since I use tomcat6 plugin to deploy the war file. When I give the ipaddress of target server(if its localhost, then 127.0.0.1) in url. Then IPAddress of the server is displayed in endpoint. Endpoint address: http://127.0.0.1:8080/xxxxx/services/YYYYY WSDL : {http://kp.com/aaaa/webservices/YYYY/}bbbb Target namespace: http://kp.com/aaaa/webservices/YYYY/ Hence when you click on WSDL in points to corresponding server. However I could not find, how to do it when we deploy it from tomcat manager url

Categories : Java

Get user root directory from windows service
I found this under Win7 registry. XP looks to have the same registry keys, but the values have "All Users" profile within it. [HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersionExplorerShell Folders] "Common Desktop"="C:\Users\Public\Desktop" "Common Start Menu"="C:\ProgramData\Microsoft\Windows\Start Menu" "CommonVideo"="C:\Users\Public\Videos" "CommonPictures"="C:\Users\Public\Pictures" "Common Programs"="C:\ProgramData\Microsoft\Windows\Start Menu\Programs" "CommonMusic"="C:\Users\Public\Music" "Common Administrative Tools"="C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative Tools" "Common Startup"="C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup" "Common Documents"="C:\Users\Public\Documents" "OEM Links"="C:\ProgramData\OEM Links" "Common Template

Categories : C#

dynamically remapping the root of static file service in a CherryPy app
I think that your method needs to be like this: @cherrypy.expose @cherrypy.config(**{'tools.staticdir.root' : full_path('superior')}) def superior(self, s="supreme", cmpg=None, banner=None): return self.render(Superior(s))

Categories : Misc

Servlet.service() for servlet [Faces Servlet] in context with path threw exception [null] with root cause
The error is well detailed, above the exception you mention com.sun.faces.application.view.FaceletViewHandlingStrategy handleRenderException SEVERE: Error Rendering View[/cECI/domainReport.xhtml] java.lang.NullPointerException You should give a look into that xhtml so it can be rendered correctly Also, you can create a custo lo4j.properties at /src folder, to obtain extra information from ICEFaces core (in the example is set to WARN, try with INFO, or DEBUG, until you find more information on your problem) log4j.rootLogger=INFO log4j.appender.stdout=org.apache.log4j.ConsoleAppender log4j.appender.stdout.layout=org.apache.log4j.PatternLayout log4j.appender.stdout.layout.ConversionPattern=[%d{dd MMM yyyy HH:mm:ss}] %-5p [%F:%L -- %M] - %m%n log4j.logger.com.icesoft.faces.application.D

Categories : Java

Linux skip /root/.gvfs when executing df command with non-root user
I got the solution for my own question :) In df command you can pass the file system types which you would like to exclude, in this case it is 'fuse.gvfs-fuse-daemon'. So when I execute the below the command I no more get this message "df: `/root/.gvfs': Permission denied" df -x fuse.gvfs-fuse-daemon For more details one can look into df --help option.

Categories : Linux

Root immediate child nodes icons not visible when hiding root
JTree#setShowsRootHandles(boolean newValue) controls the state of the handles for root elements. Normally, this is false. Try changing to true

Categories : Java

Is sudo-ing tomcat's startup with a non-root user the same as running it as root?
Do be aware that the recommended solution to run tomcat on port 80 is to use mod-jk with the Apache web server, not to have tomcat listen on port 80 directly.

Categories : Unix

Reset MAMP Pro username and password to root/root
Assuming you still know the password, you can change the password back to root using /Applications/MAMP/Library/bin/mysqladmin -u root -p password root It'll prompt you to enter a password again, after which it'll be reset to root

Categories : Mysql

Read and Write root folder wihout root
You can use run-as on some devices to execute commands as a particular package. Google have fixed this on Jelly Bean so it no longer works: adb shell run-as app.package.name cp /data/data/package.name/file.txt /sdcard/ exit adb pull /sdcard/file.txt ~/ Here is a good article explaining file access in Android without root permissions, including a one-liner for the above script. It details how to use the new backup command: backup -f ~/data.ab -noapk app.package.name And how to extract the contents of the resulting .ab file: dd if=data.ab bs=1 skip=24 | openssl zlib -d | tar -xvf - You will most likely need the android.permission.BACKUP permission.

Categories : Android

SVN (svnserve) virtual root --root= not recognized
svn+ssh handles the whole transaction including writing and reading the files so it ignores the --root parameter in svnserve. Here is how to fix it over at serverfault -- Basically you just make svnserve into a script that calls svnserve with the proper variables.

Categories : Svn

Document root element "hibernate-configuration", must match DOCTYPE root "hibernate-mapping"
DOCTYPE for <hibernate-configuration> should be: <!DOCTYPE hibernate-configuration PUBLIC "-//Hibernate/Hibernate Configuration DTD//EN" "http://hibernate.sourceforge.net/hibernate-configuration-3.0.dtd">

Categories : Hibernate

is there any method to draw a tree with a root , the root's previous nodes and successor nodes?
Couple of ideas you might find useful: You can use the tree layout to place the nodes in the canvas, create link objects pointing back and forth, then bind the link objects to a diagonal. http://www.durablejs.org/examples/flowchart/1/admin.html You can also use place the nodes using a pack layout, create the link objects pointing back and forth, and bind the links to a Bezier curve. http://www.durablejs.org/examples/statechart/1/admin.html You can find the code for the graphs above: https://github.com/jruizgit/durable/tree/master/lib/durabjevisual.js

Categories : D3 Js

Including from child theme root or else include from parent theme root
To answer your question directly based on your sample, i would not check to see if the file has been placed in the child theme. If a child-theme developer has customized the file, they can simply declare the function and include their own file (wherever they place it). There is no risk of code duplication because your sample function is simple enough. Even if you simplified your code for the purposes of placing it here....you can always keep includes wrapped in a very simple function that can be declared by a child theme. This will keep PHP running efficient and not having to check for files all the time.

Categories : Wordpress

How can I remove the root node and make the first child the new root node with XSLT?
Add a rule to the identity transform that adds nothing to the result tree for your document element other than the processing of its children: <?xml version="1.0" encoding="US-ASCII"?> <xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1.0"> <xsl:template match="/*"> <xsl:apply-templates select="*[1]"/> </xsl:template> <xsl:template match="@*|node()"><!--identity for all other nodes--> <xsl:copy> <xsl:apply-templates select="@*|node()"/> </xsl:copy> </xsl:template> </xsl:stylesheet> (edited to be agnostic to the name of the document element) (edited again to only preserve the first child element of the document element)

Categories : Xml

Defining root of HTML in a folder within the site root folder
You need to set the base tag. If you add the tag in your page <head> like this: <base href="http://yoursite.tld/folder/"> it should display images and with sources relative to this base path.

Categories : HTML

I want to set authenticated users' root to a nested resource, their dashboard, instead of the home#index page non-authenticated users use as root
Option 1: In your dashboards controller, change to: @user = current_user @dashboard = current_user.dashboard This will also prevent users from seeing other user's dashboards. Option 2: Now, if users can see other user's dashboard fine, then change your route: root :to => "dashboards#find", as: :authenticated_root and in your dashboards controller: def find redirect_to user_dashboard_path(current_user, current_user.dashboard) end

Categories : Ruby On Rails

Reference another Aggregate Root inside another Aggregate root?
By the sounds of it you have an Installation AR. When requiring an AR in another you should model the contained AR as a only the ID in the container or a VO if required. You need to have hard edges around your ARs. Back to the Order / OrderLine example :) An OrderLine seems to 'require' a Product but you shouldn't ever give a Product instance tot eh OrderLine. Instead only model, say, the ProductName and ProductId as a VO in the OrderLine. Now you have a distinct edge to your Order AR. Hope that helps somewhat.

Categories : Entity Framework

wrong child root name in rabl and can't set child root name
I've encountered the same exact bug, the problem seems to be setting the object_root to false. Following the comment of Bigxiang I have experimented a bit and found that this works fantastically: child( {:rsvp => :rsvp}, {:object_root => false} ) do extends "users/index" end Note both the round parentheses "()" and braces "{}".

Categories : Ruby On Rails

Is it webapp-root/META-INF or webapp-root/WEB-INF/classes/META-INF (Tomcat 7)
I guess it is all right. They both might have slightly different purposes. webapp-root/META-INF is directory for metadata of the web application, which you can access via servletContext.getResource("/META-INF/foo"). webapp-root/WEB-INF/classes/META-INF is directory for metadata of java classes, which you can read via getContextClassLoader().getResource("/META-INF/foo").

Categories : Spring

Adding service reference for WF4 workflow service doesn't create client (ClientBase)
For anyone caught in this one, here's the issue. I had generated the web references for a console service app. By default, these are implemented as workflow activities, not as part of a client wrapper. Once I realized my misunderstanding, instantiating was simple.

Categories : Visual Studio 2012

Symfony2 service container: Inject array of services parameter as an argument to another service using XML
So, you inject array of parameters no array of services. You can inject service by service via: <services> <service id="notifications_decorator" class="NotificationsDecorator"> <argument type="service" id="decorator1"/> <argument type="service" id="decorator2"/> <argument type="service" id="decorator3"/> </service> </services> Or (in my opinion better way) tag decorators services and inject them to notifications_decorator during compilation passes. UPDATE: Working with Tagged Services In your case you have to modify your services like this: <services> <service id="decorator1" class="FirstDecorator"> <tag name="acme_decorator" /> </service> <service id="decorator2"

Categories : Symfony2

MvvmCross syntax to consume a service defined in a plugin and the lifetime of that service within the application
1. The syntax you are using for CreatableTypes looks OK to me. When not using it inside App then the documented syntax is: " And you can also, of course, use the same type of registration logic on assemblies other than Core - e.g.: typeof(Reusable.Helpers.MyHelper).Assembly.CreatableTypes() .EndingWith("Helper") .AsInterfaces() .RegisterAsDynamic(); " from https://github.com/slodge/MvvmCross/wiki/Service-Location-and-Inversion-of-Control#bulk-registration-by-convention CreateableTypes(), EndingWith(), etc are all just fairly short extension methods acting on System.Type - you can see them in IoC/MvxTypeExtensions.cs - e.g. public static IEnumerable<Type> CreatableTypes(this Assembly assembly) { return assembly .ExceptionS

Categories : C#

Get user appdata path from windows service by running service under local profile
I have also encountered in that problem and looked at your question but i at first sight didnot find an answer in it. This is the Mohit shah Answer "I found out that is not possible to get user appdata path from windows service by running service under profile "LocalSystem". So I used Environment.SpecialFolder.CommomAppData which gives me app data path C:ProgramData when run on windows 7 and when used same thing in windows service, it also gived the same path and i also ran the service under profile "LocalSystem" so it did not prompt me for credentials. So this solved my problem." @Mohit Shah Please mark this is as answer so that other can take help from that.

Categories : C#

Unable to authorize access to a Service Bus Namespace for service running as LocalSystem or NetworkService?
suggest to use shared access key. To get the connection string with shared access key, run PowerShell cmd: $authRule = Get-SBAuthorizationRule -NamespaceName ServiceBusDefaultNamespace $authRule[0].ConnectionString

Categories : Misc

Tanuki service-wrapper application works in console, fails as service with 1053
I found out what I did wrong. I created the service through the sc create command, rather than using the build in options of the java service wrapper executables. This resulted in the service wrapper executable not being able to start correctly, because of missing command-line parameters.

Categories : Java

symfony2 service tagged as doctrine.event_subscriber not receiving events when using service with arguments
You have circular references. To create EntityManager, all event listeners must be created first. Now as your listener has dependency on a service, which has dependency on entity manager, you get circular reference. Best way to fix it would be avoid creating these references - you can get entity manager to listener by event arguments, passed to it. Another way would be to inject service container into listener and get the service only when it's needed.

Categories : PHP

Adding manually defined service operations inside initService for odata service
Thanks @robesz - there were some subtleties in creating parameterized odata actions in .net and this is what has been plaguing me (I have tried actions before just couldn't get it to work), but this time I got it: [Queryable] [HttpPost] public IQueryable<Airport> GetAirportsWithinRadius([FromBody] ODataActionParameters parameters) { if (!ModelState.IsValid) { throw new HttpResponseException(HttpStatusCode.BadRequest); } var radius = (int)parameters["radius"]; var airportId = (int)parameters["airportId"]; var resultAirports = GetAirportsWithinRadius2(airportId, radius); return resultAirports; } ActionConfiguration getAirportsWithinRadius

Categories : Misc

android:how to ensure only one process(of a remote-service) running even all APPs integrated this service in the apk
You could write some resource locking mechanism. If you're already handling a call from app A, and app B wants the same call, return an error code that isn't fatal, rather tells the app to try back at another time. Or you could create a queue with a callback to app B that fires when app A is done.

Categories : Android

Is there any way to automatically generate proxy class for android in eclipse for web service if I have web service url?
When you say "for android" you mean for use in an android app? I haven't used it in some time, but I think you can use SoapUI. That article is a few years old, but should still be possible. There are also tools (wsdl2java) that come with Apache axis, and cxf that you can use.

Categories : Java

ScriptManager service reference generates JS code that forgets about the service host name
From Exposing Web Services to Client Script: The ServiceReference object can reference a Web service only in the same domain as the page. The Web service path can be relative, application relative, domain relative, or absolute. For absolute paths, you must make sure that the path is in the same domain. So you can't call your web service method which is in another domain. What you can do is create another service in your asp.net project to call the original web service. then you can call newly created web service method from script manager

Categories : Asp Net

What guarantees does the service control manager (SCM) make about the method calls on the service?
Michael Taylor provided a good answer to this question on the MSDN forums referencing the Win32 API which documents what the SCM will do in response to invalid control codes (reject them in various ways). State change methods are called only when the SCM believes the service is in the appropriate state and assuming that the service says it can handle the state (pause/continue). OnStart will be called if the service is stopped. OnPause is called if the service is running. OnContinue if the service is paused. A paused service can only be resumed or stopped. A running service can only be paused or stopped. SCM serializes commands to a service so only a single command will be running at a time. Refer to the Win32 documentation on how services work fo

Categories : C#

Changing binding of WCF service hosted in Web role in azure cloud service
You're probably using basicHttpBinding now - that's what WCF defaults to for HTTP. The reason you don't see a reference to your service in web.config is because of the simplified configuration that was introduced in .NET Framework 4.0. You can still explicitly configure the service in web.config like you had to in earlier versions if you want, but it's not necessary. To do what you're asking, here's what you need to do: Change the protocolMapping to use webHttpBinding instead of basicHttpBinding. Add a webHttp endpoint behavior and set the DefaultOutgoingResponseFormat to "Json". Change your .svc markup file to include the Factory attribute and specify the WebServiceHostFactory. For example: Factory="System.ServiceModel.Activation.WebServiceHostFactory" Finally, add the [WebGet

Categories : Wcf

Custom Linux service status message using Java Service Wrapper
I got a half-solution. Inspecting the wrapper script code, as suggested by @Naytzyrhc, I found that the wrapper lib reads 3 files to create the status message: bin/my-app.pid to print the PID of the running process; bin/my-app.status to print the status of the wrapper itself; bin/my-app.java.status to print the status of the wrapped application. So, in the application code, to override the status message, just write the message in the my-app.java.status file. There's only one gotcha: if the status message contains line breaks, the service my-app status doesn't print them, because it uses the echo command (as stated in this question Capturing multiple line output to a bash variable). To solve this problem, just change the line from: eval echo `gettext '$APP_LONG_NAME is running: PID:$

Categories : Java

WCF service Process.Start under network service account impersonating as a different user
I had to add a reference to AsproLock.dll and associated code in order to permit the user account to have access to the running resource. //The following security adjustments are necessary to give the new //process sufficient permission to run in the service's window station //and desktop. This uses classes from the AsproLock library also from //Asprosys. IntPtr hWinSta = NativeMethods.GetProcessWindowStation(); WindowStationSecurity ws = new WindowStationSecurity(hWinSta, System.Security.AccessControl.AccessControlSections.Access); ws.AddAccessRule(new WindowStationAccessRule(userPassDto.Usuario, WindowStationRights.AllAccess, System.Security.AccessControl.AccessControlType

Categories : C#

Create C# client consumes SOAP service without using built-in 'Add Service Reference...'
You can do it by creating SOAP message and sending web request Like in this SOAP client web request

Categories : C#

Unable to create requested service [org.hibernate.service.jta.platform.spi.JtaPlatform]
I can try to answer your problem, but your question should include more information: You should include a full stacktrace. There is not enough information in the error you put in your question. The full stacktrace will add some necessary information to help us figure out what's going on. You post one configuration file, but it refers to other files, like hibernate.properties. You should include these files so that we can check the correct configuration of your application. Without this information, I can just suggest the following: You are using Atomikos as transaction manager. You must include a Maven dependency to Atomikos (you say in your post that you are using Maven). In the declared bean usermanagementSessionFactory, you should have properties in relation with Atomikos, as it i

Categories : Spring

Android activity accessing service's static reference before the service is ready
So how should I make my activity wait till the TTSService is ready to be used? You don't. Most likely, you get rid of the service entirely, as it does not appear to be necessary. Have the activity use TextToSpeech directly. If you have a demonstrable reason why your app needs this to be in a service: Step #1: Delete public static TTSService sInstance and the sayHello() method. Step #2: Get rid of your existing startService() call. Step #3: Replace TTSService.sInstance.sayHello(Float.valueOf(distance).toString()); with a startService() call, to send a command to the service, where the message to be said is added as a String extra. Step #4: In onStartCommand() of your service, if the TTS initialization is complete, call speak() to speak the requested string (pulled from the extra).

Categories : Java

Materializing a 'WCF Data Service' service operation that calls a Stored Procedure
I had a problem very similar to this. The solution was to create a property within the DataContext which returned the type in question. To make that a little clearer, I had a method on the service like this: [WebGet()] public IQueryable<VolumeSlaReportSummary> GetVolumeSlaSummary(...) { ... return this.CurrentDataSource.GetVolumeSlaSummary(...); } When I called that method I got XML in the form <GetVolumeSlaSummary...., instead of the expected <feed... So, in the DataContext, I created a property like this: public IQueryable<VolumeSlaReportSummary> VolSlaSummary { get { return this.GetVolumeSlaSummary(...); } } Calling the method now returns the expected <feed... style XML.

Categories : Dotnet

Resource based routing module used in a Node.js REST API service, or other useful modules for this type of service
RESTfull API get and post data through HTTP protocol. A more progressive approach is to use WebSocket [Wikipedia] npm link. Try to play with Sails.js framework build on Express.js that use Socket.IO for flash data transfering

Categories : Javascript

Ruby: gem win32-service: Create a service with Admin privileges
The underlying CreateService Windows API function requires an account domain on the lpServiceStartName field, so you probably need to set the :service_start_name field to 'domainAdministrator', where the account domain is usually the computer name.

Categories : Ruby



© Copyright 2017 w3hello.com Publishing Limited. All rights reserved.