w3hello.com logo
Home PHP C# C++ Android Java Javascript Python IOS SQL HTML Categories
QT-creator 2.8 wont deploy to android, ant clean debug failed
This is caused from a missing or invalid OpenJDK location setting. To fix it, go to the Tools -> Options dialog. Select the Android filter from the left-hand side of the dialog. Then in the OpenJDK location entry field, ensure you have a complete path to an installed OpenJDK. If you don't have the OpenJDK installed, then Ant will fail. My path that I set in that field is /usr/lib/jvm/java-6-openjdk-amd64.

Categories : Android

"Failed to load platform plugin "xcb" " while launching qt5 app on linux without qt installed
Since version 5, Qt uses a platform abstraction system (QPA) to abstract from the underlying platform. The implementation for each platform is provided by plugins. For X11 it is the XCB plugin. See Qt for X11 requirements for more information about the dependencies.

Categories : Linux

How to run an app after running an xcode clean and clean build folder where the app now crashes
First, certain files get cached even with 'Clean Build Folder', especially for simulator. Files (especially derived nibs and images) can be left that have been deleted in the project. Command-Option-Shift-K to clean out the build folder. Quit Xcode and clean out ~/Library/Developer/Xcode/DerivedData manually. In the simulator, choose iOS Simulator > Reset Content and Settings. Now if it fails, it is because your code was only working because of over-cached build files. If this is the case, check where your rootViewController is pointing.

Categories : Iphone

How to clean project cache in Intellij idea like Eclipse's clean?
Try this: Go into Settings (File > Settings or ctrl+alt+S). Under Project Settings, select the "Compiler" node. On the left, uncheck "Clear output directory on rebuild". Note that this is a per project setting. If desired, change it in the project template settigs (Settings > Other Settings > Template Settings).

Categories : Java

difference between clean and clean working directory in Eclipse WTP with Tomcat
Clean: Purges all webapps and redeploys them (don't do this while the Tomcat instance is running) Clean working dir: Cleans out Tomcat's work dir, e.g. where compiled JSPs go. See here.

Categories : Java

DBD-mysql installed ,but still error "install_driver(mysql) failed: Can't locate DBD/mysql.pm in @INC"
Perhaps the DBD::mysql perl module hasn't been fully installed ...so install it. cpan DBD::mysql Or since you don't have internet access, perl Makefile.PL make make test make install You'll need MySQL's development header files installed first, as per INSTALL

Categories : Perl

git clean -d -f removes directories containing files which are ignored. Can I keep the ignored files and still run git clean -d
I've observed the same behavior and cannot find it listed in a bug. It's certainly still the behavior in git 2.0.4. The work-around i've found it to add a dummy file in the empty directory that is contains the ignored file, so that it is no longer considered by -d, e.g. /dir /dir2 /file1 /.marker Being a .dotfile it's ignored from directory listing, so it's fairly unobtrusive and it does keep the directory put.

Categories : GIT

How to check for specific application installed in machine or can we get list of installed application in gwt ?
Browser and OS detected via Window.Navigator are not fail proof. They only observe pattern in the way a browser does stuff and classify into OS and Browser groups. Browser run Javascript ( i.e GWT Code ) do not have privilege to query OS regarding installed software or hardware details!!!!! There is no possible solution in GWT/Javascript for this.

Categories : Gwt

How to add clean task - Task 'clean' not found
The clean task is introduced by the 'base' plugin. So you need to apply this plugin to get the clean task and the clean task rules for cleaning up specific task outputs: apply plugin:'base'

Categories : Gradle

Chromecast app starting from sample TicTacToe - failed to start application: request failed
In file README_ECLIPSE.txt it says: In GameActivity at line 91, the code makes a call to the app name "TicTacToe". This is a whitelisted app name at which the TicTacToe receiver is located, so you can simply build and run the app without worrying about whitelisting your own receiver. So please do not change anything in the sample code (to replace with your AppId), just build and run to see if it works for you. If you can't make that work, please check the answer here: Unable to debug Whitelisted device / ApplicationSession failing to start

Categories : Android

Failed to load resource: the server responded with a status of 412 (Precondition Failed)
Probably you're browser is handling this POST the same as Safari is... see: http://avnwx.blogspot.co.at/2011/10/debuggers-lie.html in my case this problem was solved by adding a timestamp to the URL of the linked file to stop my browser from pulling up the cached version.

Categories : Javascript

activeCollab: Failed to connect. Reason: Failed to load class 'Swift_1_SimpleCharacterReaderFactory'
That is not a known issue, so we recommend that you upgrade to the latest stable release (3.3.18 at the moment). You can find the upgrade instructions here. Upgrade should resolve the potential problem that you did not upload all the files properly, plus activeCollab 3.3 has auto-upgrade feature which will make similar error less likely to happen in the future.

Categories : Misc

PERCPU: allocation failed, size=256 align=256, failed to allocate new chunk
The largest chunk available from a module from the per-cpu pool depends upon the current usage by other modules that are already loaded in the Linux kernel. The size of the percpu pool depends upon whether the following configs are defined in the kernel config. CONFIG_HAVE_SETUP_PER_CPU_AREA CONFIG_SMP A typical initial size of the per-cpu pool at boot-up is 32KB per cpu. It can vary if the architecture specific setup_per_cpu_area() function is defined. The exact amount of memory reserved for the percpu pool is logged to the console during the Linux kernel boot. For example, Linux kernel 3.2 on my Intel Core 2 Duo P8700 machine, logs the following : PERCPU: Embedded 13 pages/cpu @f77d1000 s31616 r0 d21632 u53248 The percpu pool is 13 pages i.e. 52KB for each cpu, 104KB total. The

Categories : Linux

C9.IO - Debugging Failed - Failed to open socket on port 15400, waiting 1000 ms before retrying
Looks like an older process is already running . You have to kill the older process yourself. See the solution posted here : https://github.com/ajaxorg/cloud9/issues/2170.

Categories : Node Js

Mountain Lion, failed to install ruby on rails [ERROR: Failed to build gem native extension.]
Either download and install 'command line tools' from apples developer download page: https://developer.apple.com/downloads/ or just install xcode through App Store.. and try again. And as mentioned by someone else in the comments, rbenv is a much better and easier way to manage your rubies on Mac OS X, so consider making the switch. to remove rvm from your system do: rvm implode and then restart your shell to make sure you are installing rbenv in a clean environment. for detailed instructions on how to install a decent rails dev environment on mac take a look at the instructions i put together in a blog post here: http://blog.parsalabs.com/blog/2013/08/27/setting-up-a-ruby-on-rails-4-development-environment-on-a-clean-mac-os-x-installation/ they worked for me, hope you will find the

Categories : Ruby On Rails

MVC local dev The underlying provider failed on open - Login failed for user 'NT AUTHORITYANONYMOUS LOGON' in Firefox only
While most solutions to this indicated that you needed to set or add Integrated Security=True; to the connection string among other possible solutions. I first found that if I set impersonate to true and passed in my own domain username and password that it fixed it but this was a bad solution as it required me to store my details. The actual solution which solved this particular problem with least possible issues was to set impersonate to false and bam no further issues.

Categories : Sql Server

Re-Run testng failed xml file to excute failed test cases
Just run an .xml file you need using IDE(with plugin) or add it to pom.xml if you use Maven. All documentation about testng.xml you can find here

Categories : Selenium

curl_easy_perform() failed: failed FTP upload (the STOR command) error
Set curl_easy_setopt(curl, CURLOPT_ERRORBUFFER, char* allocatedMemoryForErrorBuffer); The character pointer will have a bit more detail about the error that is occurring. Typically, this works for HTTP requests but my understanding is that it should work for FTP as well.

Categories : C++

Gradle Build Failed: "occurred evaluating root project...failed to create a task or type gettype"
For anyone else having the same issue, as Greg mentioned above, switching to the official Google Android Gradle plugin should work: http://tools.android.com/tech-docs/new-build-system/user-guide There are a number of other questions that I believe were using the unofficial version in this question since it comes up high on search results when searching for the Android Gradle plugin.

Categories : Android

Git: git svn rebase failed. RA layer request failed
Answering your questions in reverse order. Index mismatch: 4c97d1eea751f79ddf4e58f48f41e89dc8d254bd != 35962f4b5051693558a975b48ff903f061908235 rereading a2530aabd7ce119d35f63954e075b1c86067809d This basically means that it has not been able to successfully, or completely, read the named revision, and so it is starting to fetch from svn again from that revision. In your case it is r58087 of your repository that is causing you problems. Based on this blogpost, it seems most likely that this revision is too large, and the server is timing out while you are trying to retrieve it. Based on the collective wisdom of the internet, you have a couple of choices: You can try to upgrade the server, assuming that you have that capability to a later/latest svn version. You can upgrade your svn c

Categories : GIT

Oozie failed to take stdout for failed actions
Can you provide sample workflow.xml you are referring to? If a node fails then you can use error to="errorHandlingNode"/> and try to access the stdout in error handling node. If not atleast you could get the name of failed node as ${wf:lastErrorNode()}.

Categories : Hadoop

Error: Gradle: Execution failed "Running /Applications/Android Studio.app/sdk/build-tools/android-4.2.2/aapt failed"
This is because one or more of your asset names have unsupported characters present. Replace all capitals with lowercase letters. Replace all spaces and dashes with an under-bar/underscore. AND to be safe, remove all numbers too. Another suggestion I've seen going around is to make sure your SDK is up to date, but from my own experience it has always been the names of imported assets.

Categories : Gradle

SSH -L connection successful, but localhost port forwarding not working "channel 3: open failed: connect failed: Connection refused"
ssh -v -L 8783:localhost:8783 myacct@server.com ... channel 3: open failed: connect failed: Connection refused When you connect to port 8783 on your local system, that connection is tunneled through your ssh link to the ssh server on server.com. From there, the ssh server makes TCP connection to localhost port 8783 and relays data between the tunneled connection and the connection to target of the tunnel. The "connection refused" error is coming from the ssh server on server.com when it tries to make the TCP connection to the target of the tunnel. "Connection refused" means that a connection attempt was rejected. The simplest explanation for the rejection is that, on server.com, there's nothing listening for connections on localhost port 8783. In other words, the server software that yo

Categories : Osx

Client.Error.MessageSend - Channel.Connect.Failed error NetConnection.Call.Failed: HTTP: Status 404: url:
HTTP: Status 404 clearly means the server is not able to find the page you're looking for. The URL you're using is invalid. http://localhost:8080/demo/spring/messagebroker/amf Maybe you are missing a trailing slash or something. For the list of HTTP error codes: http://en.wikipedia.org/wiki/List_of_HTTP_status_codes#4xx_Client_Error

Categories : Java

WordPress Site Error failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found
To make the path request local and not over the network I had to use the WordPress template tag get_template_directory() instead of get_bloginfo('stylesheet_directory') .

Categories : Wordpress

YouTube Data API failed to open stream: HTTP request failed! HTTP/1.0 403 Forbidden
is file_get_contents supported on your web server? many web servers dont support this function due to security risks. have you looked into using curl instead? maybe something like this: $option = array( 'part' => 'snippet', 'q' => 'search_query', 'type' => 'video', 'key' => 'your_key' ); $url = "https://www.googleapis.com/youtube/v3/search?".http_build_query($option, 'a', '&'); $curl = curl_init($url); curl_setopt($curl, CURLOPT_HTTPAUTH, CURLAUTH_ANY); curl_setopt($curl, CURLOPT_SSL_VERIFYPEER, true); curl_setopt($curl, CURLOPT_RETURNTRANSFER, 1); curl_setopt($curl, CURLOPT_HTTPHEADER, false); $json_response = curl_exec($curl); curl_close($curl); $responseObj = json_decode($json_response);

Categories : PHP

No build tools installed in the SDK (sdk tools already installed)
From version 22 forward the build tools is a separate package. Open then Android SDK Manager and check Android SDK Build-tools and click install. The package will download and you'll be able to export/build.

Categories : Android

Viewstate verification failed. Reason: The viewstate supplied failed integrity check.
You can check if the problem is into the machine authentication code(MAC). Set enableViewStateMac="false". If you no longer get view state errors, the problem is related to the MAC feature. Also you can generate a new machineKey and copy it into the web.config of your app on each server. Here are some links that might help... explanation of machineKey http://msdn2.microsoft.com/en-us/library/w8h3skw9.aspx machineKey generator http://www.codeproject.com/aspnet/machineKey.asp

Categories : Asp Net

Github windows: Commit failed: Failed to create a new commit... continued issues
If you have a process blocking (keeping an handle) on a git resource, you can track it using process explorer. Search for any process referencing ".gitindex" and you will be able to kill it.

Categories : GIT

R: failed installation Slidify - Error: Command failed (1) not recognized as a i/e command
try this method, Install slidifyLibraries from Windows command prompt http://thiagosilva.wordpress.com/2013/02/17/installing-slidify-on-a-windows-machine/

Categories : R

Jenkins job failed due to tests failed. Source code for tests include AWT GUI tests, how to use Xvfb plugin
A Putty session and a jenkins job will probably have 2 slightly different run environments. Because of the way it was configured, Putty wants to use your remote X server, while jenkins is probably headless and requires xfvb or similar environment. For your tentative trough Putty to work, you might want to add "ForwardX11Trusted yes" in /etc/ssh/sshd_config on your server, or use xauth. But this will make your GUI appear on your Windows client. Probably not what you really want: you don't want to have to export your display to a remote server to run your automated build. To fix jenkins, I am not 100% sure yet. The Xfvb plugin fails because you already have a server running on the port it tries to use. You may want to check with netstat -ln and search for ports (potentially around 6000+).

Categories : Linux

Clean up a CSV file
Don't really know, what you need. Please explain more, if this doesn'w work for you: for /f "delims=" %%a in (old.csv) do ( set "line=%%a" setlocal enabledelayedexpansion set "line=!line: =!" set "line=!line:-=0!" >> new.csv echo(!line! endlocal )

Categories : Batch File

Clean URL htaccess
Try: RewriteEngine On RewriteCond %{THE_REQUEST} ^[A-Z]{3,9} /index.php?a=page&b=([^& ]+) RewriteRule ^ /%1? [L,R=301] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule ^(.*)$ /index.php?a=page&b=$1 [L]

Categories : PHP

regex to clean up url
This will do exactly what you are asking: <?php $string = 'http://somesite.com/directory//sites/9/my_forms/3-895a3e/somefilename.jpg|:||:||:||:|19845'; preg_match('/^([^|]+)/', $string, $m); // get everything up to and NOT including the first pipe (|) $string = $m[1]; $string = preg_replace('/(?<!:)///', '/' ,$string); // replace all occurrences of // as long as they are not preceded by : echo $string; // outputs: http://somesite.com/directory/sites/9/my_forms/3-895a3e/somefilename.jpg exit; ?> EDIT: (?<!X) in regular expressions is the syntax for what is called a lookbehind. The X is replaced with the character(s) we are testing for. The following expression would match every instance of double slashes (/): // But we need to make sure that the match we are loo

Categories : PHP

How do you clean up jfloat when using jni
You only have to clean up in cases where the JNI interface may have allocated memory or other resources. Basic types, like jfloat , are typedef's for basic C++ *types* (usually, float), and are passed around by copy; when you declare a jfloat, it's just a floating point type on the stack, and disappears when you leave its scope.

Categories : C++

How to clean csv by another csv while in a 'for' loop?
If I understand you correctly, assuming a recent 'nix, grep should do most of the trick for you. The command, grep -vf filterfile input.csv will output the lines in input.csv that do NOT match any regular expression found in filterfile. A couple of other comments ... uniq needs the input sorted in order to remove dups, so you might want the sort before it in the pipe (unless your input data is sorted). Or if the input is sorted to start with, grep -u will omit duplicates. Small suggestion -- you might add a #!/bin/bash as the first line in order to ensure that the script is run by bash rather than the user's login shell (it might not be bash). HTH. b

Categories : Linux

How to keep clean url after redirection
You can't "keep the clean url" for a url that exists on a different server. One of the only ways to have a "clean url" is to use an iframe like this: /cap.html <iframe frameBorder="0" src="https://docs.google.com/a/l5lab.com/forms/d/1gTVPzkBSyKAiLNv26MhVlfGfYf78AgNY0OWA0PQm3lY/viewform" style="width: 100%; height: 2210px;"></iframe>

Categories : PHP

How to clean up my git repositories
You need to specify --squash for git merge. See this and this answer for more info.

Categories : GIT

What does "setup.py clean" exactly do?
As far as I know, it just removes the the build subdirectory, where Python puts all the files to be installed, including extensions that need to be compiled. There shouldn't be any *.pyc files elsewhere, unless you ran Python on some scripts in the source directory (which may happen if you run tests), or imported modules directly from the source directory. *~ files are emacs backup files, and thus wouldn't be cleaned up by setup.py anyway. (If you've seen this behaviour from make clean, than that's simply because someone coded that into the Makefile.) You probably could override the clean command in a way to (recursively) remove *.pyc files, but I doubt if there's a need. In general, Python is smart enough to recompile *.py files into *.pyc files if the former have changed, and otherwise

Categories : Python

Do I need a 301 Redirect after clean URL's
Yes you do need 301 redirects from old URLs to new ones in order to avoid duplicate content. Enable mod_rewrite and .htaccess through httpd.conf and then put this code in your .htaccess under DOCUMENT_ROOT directory: Options +FollowSymLinks -MultiViews # Turn mod_rewrite on RewriteEngine On RewriteBase / RewriteCond %{THE_REQUEST} ^[A-Z]{3,}s/+(photos)/index.php?([^s]+) [NC] RewriteRule ^ /%1/%2? [R=301,L] RewriteCond %{QUERY_STRING} ^$ RewriteRule ^(photos)/(.+?)/?$ /$1/index.php?$2 [NC,QSA,L]

Categories : Regex



© Copyright 2017 w3hello.com Publishing Limited. All rights reserved.