w3hello.com logo
Home PHP C# C++ Android Java Javascript Python IOS SQL HTML videos Categories
iOS Project with CocoaPods in SVN Failed when doing pod install/update
Try doing a fresh svn checkout of the project, then when that completes successfully, do an svn update on it immediately. You shouldn't get anything new (unless someone has committed to the project while you were checking it out). After that, run your pod install.

Categories : Svn

Xcode 5 - "iOS Simulator failed to install application" every time I switch simulators
Looks like this is a known issue. From the Xcode 5 release notes: After switching the minimum deployment target of an application from iOS 7.0 to a release prior to iOS 7.0, building and running the application may fail with the message “iOS Simulator failed to install the application.” Go to the iOS home screen, click and hold the application icon, then tap the hovering “X” button to delete the application. 13917023 Another release note: iOS Simulator If an iOS app is detached, relaunching the same app from Xcode will result in a black screen in the Simulator even though the new app is launched. Terminate the app in the Simulator or relaunch it for the second time. 14648784

Categories : Xcode

Mountain Lion, failed to install ruby on rails [ERROR: Failed to build gem native extension.]
Either download and install 'command line tools' from apples developer download page: https://developer.apple.com/downloads/ or just install xcode through App Store.. and try again. And as mentioned by someone else in the comments, rbenv is a much better and easier way to manage your rubies on Mac OS X, so consider making the switch. to remove rvm from your system do: rvm implode and then restart your shell to make sure you are installing rbenv in a clean environment. for detailed instructions on how to install a decent rails dev environment on mac take a look at the instructions i put together in a blog post here: http://blog.parsalabs.com/blog/2013/08/27/setting-up-a-ruby-on-rails-4-development-environment-on-a-clean-mac-os-x-installation/ they worked for me, hope you will find the

Categories : Ruby On Rails

Eclipse Plugin : build failed java.lang.NullPointerException error for an update site project
Eclipse will generate a p2 repository (aka an update site) when exporting from your feature.xml if you select the "Generate metadata repository option". http://help.eclipse.org/galileo/index.jsp?topic=/org.eclipse.platform.doc.isv/guide/p2_publisher.html http://help.eclipse.org/galileo/topic/org.eclipse.pde.doc.user/guide/tools/export_wizards/export_features.htm

Categories : Java

Npm install failed with "cannot run in wd"
The documentation says (also here): If npm was invoked with root privileges, then it will change the uid to the user account or uid specified by the user config, which defaults to nobody. Set the unsafe-perm flag to run scripts with root privileges. Your options are: Run npm install with the --unsafe-perm flag: [sudo] npm install --unsafe-perm Add the unsafe-perm flag to your package.json: "config": { "unsafe-perm":true } Don't use the preinstall script to install global modules, install them separately and then run the regular npm install without root privileges: sudo npm install -g coffee-script node-gyp npm install Related: package.json for global module installation

Categories : Node Js

iOS App Failed to Install
Yeah sounds like a provisioning problem. Make sure the UDID of all devices you are targeting are in each listed provisioning profile (Note: You will need to add any additional UDID's added to the developer portal again to any provisioning profile). Although I strongly recommend using Testflight for your circumstance, makes sending an .ipa extremely easy. https://testflightapp.com/

Categories : IOS

Install Rails Failed on OSX 10.8.4
Finally, I got the solution! Run rvm implode,and use rm to delete /etc/rvmrc and ~/.rmvrc, restart your mac, and you can use gem install rails to install rails successfully.

Categories : Ruby On Rails

yum install failed and corrupted the original yum
if you want to uninstall you can do rpm -e yum then Install it using: rpm -ivh yum-(version).rpm If yum is working fine for local installations, but it's not able to access Red Hat Network, verify if the following packages are installed. If not, install them: rhnsd yum-rhn-plugin yum-security rhn-check rhn-setup rhn-setup-gnome yum-downloadonly rhn-client-tools rhn-virtualization-common rhn-virtualization-host pirut yum-updatesd

Categories : Linux

iFunbox App Install Failed (-402620395)
For an AdHoc distribution -- that's a provisioning error. Go to Apple developer center and verify that the iPhone 5 is a added to the AdHoc provisioning profile. https://developer.apple.com/library/ios/documentation/IDEs/Conceptual/AppDistributionGuide/TestingYouriOSApp/TestingYouriOSApp.html

Categories : Iphone

Failed to install ssh-0.2.12 (haskell package )
This is because ssh just depends on cryptohash without an uppper version bound. It was probably written against cryptohash 0.9.1, in which the MD5 constructor existed and where it is marked as deprecated, but now cryptohash 0.10.0 is out which doesn't contain it anymore. Your cabal will install the latest versions of dependencies if there are no restrictions on them. The right thing to do is to file a bug against the ssh package so that it gets updated. You can find a bugtracker URL on its hackage page. Note: It is controversial whether upper version bounds are good or bad.

Categories : Haskell

"brew install osm2pgsql" failed
I don't know anything about brew but according to the error message you are missing the zlib library. Try to install it first. And you should keep to osm2pgsql because it is the standard tool to import OSM data into a PostgreSQL database.

Categories : Osx

`bundle install` failed due to permission denied
bundle install does not use the gemrc settings. (Although possibly that has changed in a recent update, but the update appears to load ~/.gemrc only, not /etc/gemrc) You can do what you want with bundle install --path ~/.gem However, I would highly recommend getting rbenv or RVM working. You said that you had the "same result" with rbenv. If your gems were trying to install into /var/lib/gems when you had rbenv installed, then it wasn't an rbenv-installed Ruby that was running that command. Either rbenv was still using the system Ruby (which it will until you pick an rbenv installed Ruby to become the default), or you did not have rbenv running correctly.

Categories : Ruby

Unable to install Rails extconf.rb failed
I guess it's a same problem with this question. Try sudo ln -s /usr/bin/{llvm-,}gcc-4.2 and gem install rails again. By the way, you're in your own home directory, you don't have to use sudo.

Categories : Ruby On Rails

Failed to install mysql2 while creating rails new app
Unfortunately mysql2 gem has issues,you'll have to install mysql gem for now,to do that do a bundle install after modifying to mysql from mysql2/sqlite in your config/database.yml and gemfile,hope thats clear.

Categories : Mysql

Heroku failed to install production dependencies with NPM
The build is failing because node-waf isn't in your path. You can check if you have the path configured properly by running which node-waf. node-waf has actually been superseded by node-gyp, but you can still install it. It goes under the name nodejs-dev on some package managers. You might also already have the package on your system. I suggest looking in /usr/local/bin. If the binary is there, then you can add a system shortcut for access.

Categories : Node Js

Tried reinstalling Ruby but RubyGem failed to install
See this answer: RVM ruby on rails issue OpenSSL . Uninstall rvm, install openssl, install rvm Instructions from: http://www.dinduks.com/rails-cannot-load-such-file-openssl/ : This error means that your Ruby isn’t compiled with openssl. Assuming that you use RVM, these are the steps to follow to fix this issue. Install the openssl package rvm pkg install openssl Remove the Ruby installation you’re using rvm remove 1.9.3 And finally recompile Ruby with openssl rvm install 1.9.3 --with-openssl-dir=$HOME/.rvm/usr Everything should be working now. Don’t forget to: rvm use 1.9.3 --default Side note: I recommend installing rbenv instead of rvm.

Categories : Ruby On Rails

Failed to install myapp.apk on device timeout
You need to increase the timeout on your eclipse Go to window-> Preferences--> Android --> DDMS --> ADB Connection time out(ms) an put the time (milliseconds) you need. For example,for the old Galaxy S 1 10000

Categories : Java

Failed to install darcsden-1.1 (haskel package)
FYI, best practice is usually not to run cabal as root - no sudo required. Also, add any error messages to your question, where they will be more easily seen. You wrote: I tried to install drcsden-1.1 on ubuntu 13.04 with GHC 7.6.3 with sudo cabal install darcsden-1.1 cabal install hsx-0.10.4 -v3 , returns a fail message , below a part of the debug message. src/HSX/Transform.hs:1484:13: Constructor `PTuple' should have 2 arguments, but has been given 1 In the pattern: PTuple ps In a case alternative: PTuple ps -> concatMap gatherPVars ps I did't see this problem when installing hsx-0.10.4 with ghc 7.6.3. So I looked at the source in question. I couldn't see where PTuple comes from, so I searched for it at Hayoo (not Hoogle, because I didn't know what package

Categories : Haskell

Postgres failed to install, 'unexpected character ";"'
You're... trying to install postgres? Either one of these commands should get you on your way: sudo apt-get install postgresql-9.1 sudo apt-get install postgresql-9.2 Here's the download page If those commands returned an error, the error response would be helpful information to include in your question. I'm afraid I've never tried manually creating the clusters before, so I'm probably not of much help.

Categories : Postgresql

How can we upload log files from a failed .msi install (Using WiX to create)
If you set the MsiLogging property to something like "voicewarmupx", you can later use the property MsiLogFileLocation to get the log file location. This supported in Windows Installer 4.0 and higher. If a batch file or PowerShell script isn't giving you the programmability you need, you can create a custom action that retrieves the log file and sends it to you.

Categories : Powershell

Cannot install PySpotify module for python due to gcc failed
src/module.c:3:28: error: libspotify/api.h: No such file or directory is the source of your problems. Just having the DLL is not enough, the header needs to be available as well. https://github.com/mopidy/pyspotify/issues/63 covers a similar issue and might provide some hints on how to fix this for Windows.

Categories : Python

Python, install .pyd file: ImportError: DLL load failed
There's only dlls built for Python-2.6 in the site. You cannot use dll built for Python2.6 in Python 2.7. Find the dll built for your system (platform, python version should match). Or build it yourself.

Categories : Python

PhoneGap Mac CLI local install failed because of Node version
In fact my bash_profile was missing the path to the n module as I found here: cannot install npm? problems generating application Edit your ~/.bash_profile. Add this export somewhere. export PATH=/usr/local/bin:$PATH:/usr/local/share/npm/bin

Categories : Osx

gem install: ERROR: Failed to build gem native extension
To build native extensions you need the c++-compiler and tools. This is said clearly: sh: make: command not found Except of make utility you obviously need the compiler itself (e. g. gcc) and company. Thus, sudo apt-get install gcc will do the trick. BTW, the properly suggested above RVM-way will definitely require build-tools as well.

Categories : Ruby On Rails

Drupal 7.21 install error -- failed to open stream
Drupal needs permissions to write to the sites/default/settings.php file during install...make sure your web server has the correct permissions on that file and you should be good to go. Also, try it with 7.22 (not 7.21), there's no good reason to install 7.21 and upgrade. I've installed loads of 7.22 sites on loads of different servers and never once had a problem

Categories : Drupal

Install Nginx Passenger Rails on Ubuntu Failed
Try following the advice in Debugging application startup problems on the Phusion Passenger wiki.

Categories : Ruby On Rails

*** extconf.rb failed *** error when install muby mud client
The error message is quite clear: checking for ncurses.h... no ... ... ...: ncurses hearder file not found You just have to install the ncurses development package: apt-get install libncurses5-dev Update That's a bug in the ncurses gem that is not updated to work with Ruby 1.9+, switch to Ruby 1.8.7, if you can, and it will build with no errors. Unfortunately this gem seems to be no longer manteainded. You can quite easily install Ruby 1.8.7 using rvm or rbenv, I suggest the latter.

Categories : Ruby

IOS Mobile device management failed to install profile
Most likely, it's exactly the problem which it mentions: "The server certificate for is invalid.". May be, it's not root certificate (I am not sure how iOS will like that) or may be you are using something unusual in this cert which is supported by your desktop, but it's not support by iOS device. Try to access to your server from Safari on your iOS device and see what it will say. Also, I assume that you created a configuration profile with server certificate which you installed beforehand. Go to Preferences and look at this configuration profile. This certificate should say something like "Trusted".

Categories : IOS

Install Devkit: Failed to build gem native extension
on window 7 64 bit system 1) if you want to work with ruby version lesst then ruby 2.0 2) you need to install DevKit 32 bit from http://rubyinstaller.org/downloads/ on window 7 x64 bit if you want to install ruby 2 or greater version on window 7 so you need to install DevKit 64 bit with ruby 2 with 64 bit with DevKit 64 bit on window 7 64 bit system ruby 32 bit will not work but window 7 64 bit system with Devkit 32 bit and ruby 32 bit will work this issue will not come

Categories : Ruby

Trying to install jekyll, getting the following error: Failed to build gem native extension
Try installing Jekyll from Ruby or Ruby and Rails command prompt instead of any other command prompt I am not an expert at all, so my suggested solution is just a 'guess' based on my experience below. I am using Windows 7. Although you're using Ubuntu and not Windows 7, this solution might work for pretty much anyone with the same problem. First, I installed Ruby from RailsInstaller. Then, I wanted to install Jekyll. I tried installing Jekyll from Cygwin. However, I received the following error (although it is not identical to the questioner's error, I think it is sufficiently similar): $ gem install jekyll Building native extensions. This could take a while... ERROR: Error installing jekyll: ERROR: Failed to build gem native extension. /usr/bin/ruby.exe extconf.rb

Categories : Ruby

python 2.7.5 failed to build module when install the gentoo prefix
Try this: mv $EPREFIX/tmp/usr/lib/libpython2.7.a $EPREFIX/tmp/usr/lib/_libpython2.7.a as mentioned from the following link: http://forums.gentoo.org/viewtopic-t-890016-start-0.html Also look at this post for resolving some of the modules if the above doesn't work: http://www.kelvinwong.ca/tag/python-2-7/

Categories : Linux

datastax opscenter installation failed with 'no such option: --post-install' error
This is most likely an issue with the following from the opscenter-free package: # cause any deferred python module compilation (like for telephus) to be done # now, before the initscript starts if which update-python-modules >/dev/null 2>&1; then update-python-modules --post-install fi update-python-modules comes with the python-support package. It looks like the binary is available, but whatever version the install process is finding doesn't recognize the --post-install option. If which update-python-modules points to an older (<= 2.5) or newer (3.0+) version of the script, you can try removing whatever package is including that, or updating the python-support package.

Categories : Python

MongoDB,using java to update three fields of document at the same time,sometimes only two fields is updated
I've written a unit test to show how the code behaves. This unit test proves that: you should be able to update more than one field at once (i.e. multiple fields can be updated with the $set keyword) updateMulti will update all matching documents (Note, like all Java MongoDB tests this uses TestNG not JUnit, but it's pretty similar in this case) @Test public void shouldUpdateAllMatchingFieldsUsingMultiUpdate() throws UnknownHostException { MongoClient mongoClient = new MongoClient(); DB db = mongoClient.getDB("myDatabase"); DBCollection coll = db.getCollection("coll"); coll.drop(); //Put some test data in the database for (int i = 0; i < 5; i++) { DBObject value = new BasicDBObject(); value.put("fieldToQuery", "a"); value.put("ishi

Categories : Java

emacs package install error: "autoloading failed to function define-globalized-minor-mode"
Do you happen to have an easy-mmode.el of your own installed somewhere that would shadow the builtin one? If not, try to activate Options => Enter Debugger on Error in the menu before reproducing the error and show us the backtrace.

Categories : Emacs

Will mongodb take time to update the index when I update an unrelated field?
If you change the value of a or b during the update then the index will be updated. If you don't change either of the values, the index will only be updated if the document had to be relocated on disk during the update process. The way to tell for sure is to profile your updates - they are logged in mongod log if they take longer than 100ms but you can start mongod with a lower threshold (using --slowms switch) or you can turn on profiling for the DB in question with level 2 and then all operations will be logged into the system.profile collection. Read more about it here: http://docs.mongodb.org/manual/reference/command/profile/

Categories : Mongodb

How do I know if a live tile update "failed"?
As far as I can tell there isn't a way to check whether an update failed. You can protect yourself to some extent by using a library (PushSharp maybe) or sanitizing the data you retrieve from your webservices before you pass it on to the Notification service.

Categories : C#

Cakephp query failed to update
try to update record by this $this->Invoice->save($this->request->data,false); if record updated successfully then its mean there is some validation rule failed regarding your posted data. if this issue don't solve by this way then check PK of invoice table exist in your POST data if not then set it & re-run your code

Categories : PHP

How to install/update rvm on a remote EC2 machine
use rvm-capistrano => https://github.com/wayneeseguin/rvm-capistrano#readme it has quite good description how to setup everything, I maintain example project to make sure it all works as expected: https://github.com/mpapis/ad - you can check it's capistrano config for details

Categories : Ruby On Rails

Composer install/update failing
I'm having the same problem, while earlier this week I created a new package and everything went fine. I found this old post about it: https://github.com/composer/composer/issues/1090, but unfortunately it doesn't give a solution. some package with a massive amount of replaces/suggest/requires triggered a memory issue in the package dumper (and indexer and everything else really) EDIT: problem seems fixed now.

Categories : PHP

How to dynamically update updateURL in install.rdf?
You can update your add-ons manifest but you cannot pass your own URL as update URL. This part is just an FYI: if you look into omni.jamodulesXPIProvider.jsm, function loadManifest (line 4601) , you can see that it reads update URL from your add-on's manifest. After loading the manifest, it will use its updateURL to send request and check for an update(UpdateChecker).

Categories : Javascript



© Copyright 2017 w3hello.com Publishing Limited. All rights reserved.