w3hello.com logo
Home PHP C# C++ Android Java Javascript Python IOS SQL HTML videos Categories
stunnel is not accepting incoming request from other machine
127.0.0.1 is the local machine. You have restricted connections which can be accepted to the local machine only. You can run stunnel in inetd mode (inetd starts stunnel up when a connection attempt arrives), or the preferred daemon mode. Refer to the stunnel HOWTO for more details. Here's what you do for daemon mode. First add the following line to /etc/services: myconn 3500/tcp # name the service Stunnel configuration file needs at least the section name and accept option. For example: [myconn service] accept = myconn ...

Categories : Ssl

Did I install pip correctly?
To add an answer to this question (it was provided in the comments by Joran Beasley), the issue here was that pip installs to the python/Scipts directory, but that was not in the path by default on Windows. Adding C:Python27Scripts to the path fixed the issue. This answer describes adding a directory to the path on Windows 7.

Categories : Python

I can't install rails correctly on mac
I've found the best way is with Homebrew and RVM. There's an excellent Railscast on this: http://railscasts.com/episodes/310-getting-started-with-rails

Categories : Ruby On Rails

How can I correctly install the DateTables plugin?
Its because of using collspan in some td. U should not merge two columns. See my HTML coding. Its working if u do like this. <div> <table id="internalActivities" cellpadding="0" cellspacing="0" border="1" class="display" width="100%"> <thead> <tr> <th> Internal Activities </th> <th> </th> <th> </th> </tr> </thead> <tbody> <tr> <td style="text-align: left;"> <a href="display-call.php?account_id=9&amp;call_id=1128">&

Categories : Jquery

How do I correctly install pyinstaller? (what am I doing wrong?)
As the error message says pyinstaller does not "install" - just download it, unpack and run using the path to where you put it or add it to your path. Please RTFM it can be found here.

Categories : Python

"The gem ... has been deleted. It was installed at" Error. Bundle install doesn't install gems. How to re-install gems?
This solved it for me: "gem install" and "bundle install" do not install gem dependencies after manual gem deletion. How to inform Rubygems that gems were deleted manually? (Delete the .gemspec files for the gems you have removed).

Categories : Misc

How to Install Matplotlib Basemap Module on Windows 7 with WinPython (or any Python stack install)?
I use windows. And my installation failed with official guidance, too. Finally I installed Basemap using the following method. Although I am not sure if it will go right for you, I just offer mine. First of all, you must have pip in your computer. (It is much easier to install, compared with Basemap and other things. And it can be used to install many useful packages.) Then go this great link: http://www.lfd.uci.edu/~gohlke/pythonlibs/ And download the file named "basemap‑1.0.8‑cp27‑none‑win_amd64.whl". Remove the .whl file to directory "C:Python27". (Maybe you installed your python in different disk, then change it accordingly.) Open terminal. (Use cmd or Git Bash or something else.) Use command: pip install basemap‑1.0.8‑cp27‑none‑win_amd64.whl

Categories : Python

Pip install python package into a specific directory other than the default install location
System: Ubuntu 12.04, Enthought Python Distribution (this is where I wanted to install a new python module) So the prefix_path environment variable didn't work for me and pip still kept installing it in the default location. But I used change default directory for pip install question as a guide. And one of the answers helped me achieve what I needed. pip install -d <path_to_my_directory> For the path I used: path_to_epd_directory/lib/python2.7/site-packages This puts the tar.gz file into the site-packages Then extract it using: tar -zxvf pymodule.tar.gz a directory named pymodule is created, cd into that module and type: python setup.py install and that should do the job.

Categories : Python

Reading in a file, loading correctly but not formatting correctly
Try to use this line: Navi_Endo_RefHomCell = textscan(Navi_HomMat_File_ID, '%f %f %f %f'); You will end up with a cell Navi_Endo_RefHomCell but you can use cell2mat to solve this.

Categories : Matlab

Error "invalid switch in RUBYOPT: -F (RuntimeError)" is shown while install gems by gem install mechanize
I found the reason. Just because there is a space in the installation path of Ruby RUBY EXECUTABLE: "C:/Program Files/Ruby200-x64/bin/ruby.exe" Re-install the Ruby to the path which doesn't contain space, this error will be fixed. And, of course, AutoRun should be removed from HKCUSoftwareMicrosoftCommand Processor and HKLMSoftwareMicrosoftCommand Processor. That's important!

Categories : Ruby

When exporting .Apk in the android manifest its does not install on other phones, when getting from Bin folder it does install?
There is most likely a problem with the certificate. Try making a new certificate, keystore, and alias, then generate the .apk again. Make sure that no previous instance of the app is on the phone when you try to install this new version or the mismatch of signatures will cause the installation to fail. Also, was there a previous version of the app installed on their phones already? The signature mismatch may occur due to the use of both signed and unsigned(in reality the .apk is singed, but it is done automatically by the system) .apks

Categories : Android

How install ruby with rbenv install 1.9.3-p448 ubuntu 12.04 vagrant box?
Download the ruby using your browser from ftp://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.3-p448.tar.bz2 and place it in ~/.rbenv/caches/ruby-1.9.3-p448.tar.bz2, then run rbenv install 1.9.3-p448 Explanation here

Categories : Ruby On Rails

C# Install - Change a custom folder location using install dialog
So PATHPROPERTY returns the custom folder location user has selected, If thats the case you have to set that property to "Property" attribute. Also make sure in the User Interface Editor you are getting the user input before installation starts. (You can move up and down the UI to required position)

Categories : C#

Component install error: JInstaller: :Install: File does not exist
check if you have added this code to your XML: <languages> <language tag="en-GB" client="site">language/en-GB/en-GB.com_helloworld.ini</language> <language tag="en-GB" client="site">language/en-GB/en-GB.com_helloworldt.sys.ini</language> </languages> and: <administration> ... <languages> <language tag="en-GB" client="site">language/en-GB/en-GB.com_helloworld.ini</language> <language tag="en-GB" client="site">language/en-GB/en-GB.com_helloworld.sys.ini</language> </languages> ... </administration> and check if the files are included in your installation ZIP - in right folder, e.g.: language/en-GB/ ... Be aware, the path to the file can be different for

Categories : PHP

rails heroku - how to install javascript dependences that needs 'npm install ...'
If you are deploying a Node app, declare it in your package.json, otherwise, specific it in your gemfile. https://devcenter.heroku.com/articles/getting-started-with-nodejs#declare-dependencies-with-npm

Categories : Ruby On Rails

Why "bundle install" try to install outdated version of gems?
bundle install or in short bundle does not install the latest gem unless you have left out the version in your Gemfile. e.g. gem 'rails' But usually this is not the case, we specify versions to prevent application from "crashing" when some gems are updated and we unknowingly run bundle update, or for that matter move application to say test or production servers. Usually when adding a gem to Gemfile, we do: gem 'rails', '~> 3.2.7' Note the leading ~> in the version number. This says: use rails gem between versions 3.2.7 and less than 3.3.0. In order for your bundle command to grab rails 4.0, you need to change that line to read either one of the following: gem 'rails', '>= 3.2.7' or gem 'rails', '4.0.0' If you use gem 'rails', '>= 3.2.7' then your rails appl

Categories : Ruby On Rails

Bundle install gets permission issues with global RVM install
This error doesn't necessarily need to be solved. Your bundle is installing properly, but it's not able to remove cached gems. It's a pretty harmless error unless you're running way short on hard drive space. I actually get this same error too. The problem is that my home directory is remotely mounted, so local root doesn't have permission to modify items there. Local root only has global write permissions on local directories. I imagine, based on what you describe, that you have the same issue. You could remove the files manually, or you could instruct rvm to install gems in a directory on the local machine.

Categories : Ruby On Rails

Install multiple packages on linux (like pip install -r requirements.txt)
Put the list of packages in a text file(say test.txt) with package names separated by spaces, like this - python ruby foo bar then you can just install with apt-get like this - sudo apt-get install $(cat test.txt)

Categories : Linux

Go install always fails no install directory outside GOPATH
You are using go install on a directory outside the GOPATH folder. Set your GOBIN env variable, or move src folder inside GOPATH. GOPATH/ bin/ src/ go-statsd-client/ More info: GO BUILD Source code, line 296

Categories : Osx

Rails : gem install vs. gemfile&bnudle install
RubyGems is akin to a package manager for Ruby. It's a means by which you can install self-contained libraries to use in your applications. When you use gem install gemname you're installing that gem to the current machine that you're developing on. Bundler is a tool for managing the gems that your application depends on. When you create a Gemfile, you list the various gems and their versions that your application requires. This allows you to easily ensure that your application has the gems it needs when you deploy it to a new location - for example, when you push to Heroku, your Gemfile is used to determine all the dependencies of your application. Running bundle install will take the list of required gems in your gemfile and install them if they aren't installed already, just like

Categories : Ruby On Rails

Trying to install a Scitools Python pkg via 'pip install' but getting error
I had the same error but resolved it by manually installing all the Anaconda packages. NumPy SciPy Pandas PyTables h5py Matplotlib IPython Spyder Qt/PySide VTK Numexpr Astropy Cython LLVM LLVMpy Numba Scikit-learn Scikit-image NLTK NetworkX MayaVi

Categories : Python

Can't Install gem install mysql2 Ruby WINx64
I've downloaded the connector from http://dev.mysql.com/downloads/mirror.php?id=412857 and typed in the command prompt gem install mysql --platform=ruby -- --with-mysql-include=C:mysql-connector-c-6.1.0-winx64include --with-mysql-lib=C:mysql-connector-c-6.1.0-winx64lib

Categories : Mysql

how to install php 5.4 install on ubuntu desktop 12.04?
Maybe this tutorial will help http://www.barryodonovan.com/index.php/2012/05/22/ubuntu-12-04-precise-pangolin-and-php-5-4-again

Categories : PHP

How can I install Leiningen self-install from behind a firewall?
This should help: https://github.com/technomancy/leiningen/wiki/HTTP-Proxies You should work on your googling skills ;)

Categories : Misc

Computing a correctly rounded / an almost correctly rounded floating-point cubic root
Given that there are lots of easily computable rational points on the curve x = y^3, I’m tempted to reduce about s^3 ~ x, with s rational and just a few bits wide. Then you have: cbrt(x) = s * cbrt(1 + (x - s^3)/s) Obvious thing then is to evaluate the correction term using your favorite series approximation, and compute a residual via head-tail FMA arithmetic to bump the result up or down by an ulp if needed (you won’t need the full computation most of the time, obviously). This isn’t totally in the spirit of the question, but can definitely be made to work, and it’s very easy to prove the necessary bounds this way. Hopefully someone else can suggest something more clever (I used up my cleverness for the month already).

Categories : Algorithm

Steps to Install Git from source, install Post-Git from source, and then load up Posh in PowerShell?
Check out https://github.com/msysgit/msysgit for building Git for Windows. (For what it's worth, I've never built Git on Windows and don't consider myself to have missed out.) Once you have Git built (or installed): Add the location of git.exe to your %PATH% Clone posh-git to a directory of your choosing Run posh-git's install.ps1 to install the default prompt in your $PROFILE

Categories : Windows

Running file from ssh connection doesn't work correctly. File got executed correctly only with direct connection
When you ssh to the server the first thing shell does is read all the environment files (.profile, .bashrc, .kshrc, etc...). When executing remote command, however, this will not happen. Try sourcing required env file before executing, for example: ssh host ". ./.profile; node week2/part1.js" Might also need to use . ./.profile; . ./.bashrc; or . ./.profile; . ./.kshrc;, depending on what shell you use and if those files have env (mostly PATH) settings too.

Categories : Linux

Rake db:migrate error Please install the sqlite3 adapter: `gem install activerecord-sqlite3-adapter`
It looks like you might be using sqlite in development. Can you try this in your gemfile instead of what you have? group :development, :test do gem 'sqlite3' gem "unicorn", "~> 4.6.2" end Then usual bundle install and run migration again.

Categories : Ruby On Rails

Python GDAL: pip install --no-install GDAL fails
A workaround to that problem is to Download GDAL Complete from this site Install GDAL Complete.pkg Go to /Library/Frameworks/GDAL.framework/Versions/1.10/ and copy all files in there Go to your virtual environment's sites-packages /venv/lib/python2.7/site-packages and paste the copied files in there

Categories : Python

Permission error when try to install psycopg2 on Mac with "pip install psycopg2"
For a variety of packages that require c compilation (gevent, zeromq, etc.) it seems that pip is adding extra spaces to the command, causing it to fail: go into Xcode and explicitly download the Command Line Tools (under Preferences > Downloads). From: http://www.pressingquestion.com/5111217/Pip-Installation-Adds-Extra-Spaces-To-Command-On-Os-X-108

Categories : Misc

What's the pros and cons to install HBase + Hadoop together vs. install HBase and Hadoop seperately?
Option 1: An integrated cluster. Pros: MapReduce which reads or writes HBase will more efficient as the data locality. Cons: The HBase region server will reduce the performance of the machine (Datanode and TaskTracker) as it need to hold some CPU and memory. The HBase latency may be seconds if there are many MapReduce jobs. So if you want to make HBase response in time, you need more work (For example, using memcache to improve the read performance). Option 2: 2 clusters. Prons: The HBase region server will not impact the performance of the HDFS Datenode and the TaskTracker. Cons: MapReduce needs to read and write the data remotely if it wants to access HBase. The option also needs more machines.

Categories : Hadoop

Please install the postgresql adapter: `gem install activerecord-postgresql-adapter`
First of all best practice is to use same DB for all environments. Could you please run RAILS_ENV=production bundle exec gem install pg on server? The problem seems to be in absence of pg gem in assets group when running RAILS_ENV=production RAILS_GROUPS=assets bundle exec rake assets:precompile

Categories : Ruby On Rails

How Can I Do GIT SVN Correctly?
To clone your repo including all trunk/branches/tags with the standard layout (as you mention you have): git svn clone -s http://www.example.com/code new-repo-directory NOTE: Using git is not a silver bullet. You will still have merge/rebase conflicts that you will need to resolve. You will probably have much less of them, but they will not go away entirely. The failure was probably accurate and indicates that you need to resolve the conflicts then finish your rebase with git rebase --continue. I'm sure Tortoise is a great help for many things. But I've been told many times over that you will get much more out of git if you learn to use the command line (and I believe I agree) and only use GUI helpers as tools once you understand what it is they are doing behind the scenes. PS -- git

Categories : GIT

Are we doing DMZ correctly?
So with a system where you have a DMZ, there is also a firewall involved. So your system should look like this I think: SQL-server hosting internal data Other servers needed for the company ---- firewall ---- SQL-server hosting data for web solution AD-server (if needed) Web-server FTP-server (could be on the web server also) With this setup you don't expose company-sensitive database to the outside world and you also don't open up a port in the firewall making it possible for attackers to (maybe) get access to the internal database which has company sensitive data... Just my suggestion based on the information provided.

Categories : Sql Server

How to correctly watch for changes
The code you posted in the question isn't relevant to the problem you're facing, the problem is in your validator, you're calling preventDefault(). The default behavior of the input element is cancelled, and you aren't calling $digest manually, so there is nothing to trigger the digest loop. Two solutions: Remove the e.preventDefault(); Call scope.$digest() in your keydown handler http://plnkr.co/edit/HtjnNmored70rAPOOMg6

Categories : Javascript

Writing a DLL correctly
The #define statements in MSDN's .h file are the correct ones. You define UPLOAD_EXPORTS when building the DLL, so all UPLOAD_API functions will be declared as dllexport. You don't define it anywhere else, so all clients will see them as dllimport. PS: You may want to declare your functions WINAPI as well (it means __stdcall) if you wish to use them from languages other than C and C++. Note however that using dllexport instead of a .def file exports the function names with call-convention-specific decorations (leading underscore, etc.)

Categories : C++

Using GenericForeignKeys Correctly
Using the name of the GenericForeignKey in the form doesn't work as it's not actually a real field but more of a convenience. There's no widget to display the relationship; you usually display the content_type and object_id. If you want to see the relationship in the admin interface then I'd recommend looking at Grappelli. You also need content_type and object_id fields for each GenericForeignKey. author_content_type = models.ForeignKey(ContentType) author_object_id = models.PositiveIntegerField() recipient_content_type = models.ForeignKey(ContentType) recipient_object_id = models.PositiveIntegerField() author = generic.GenericForeignKey('author_content_type', 'author_object_id') recipient = generic.GenericForeignKey('recipient_content_type', 'recipient_object_id') I've not much expe

Categories : Django

My Cookie is not set correctly
You need to define what username contains. Otherwise it will be NULL $username = $get_array['username'] Assuming $userdata is not empty, because otherwise the sql query will never be executed UPDATE It is a really bad idea to call md5($username) as a session id, because this id will be the same every time you login and you can impersonate another account if you know the username

Categories : PHP

How to use count correctly in sql?
Please try this: SELECT forum.match_static_id, count(matches.id), matches.* from forum INNER JOIN matches ON forum.match_static_id = matches.static_i WHERE forum.comments_yes_or_no = 1 GROUP BY forum.id

Categories : SQL

Correctly getting process ID
$$ should give you the script pid $PPID should give you the caller (parent) pid Answer of comment sleep 100 & sleeppid=$! echo "PID=$sleeppid"

Categories : Bash



© Copyright 2017 w3hello.com Publishing Limited. All rights reserved.