w3hello.com logo
Home PHP C# C++ Android Java Javascript Python IOS SQL HTML videos Categories
update parent version to next release version
I got the same problem as you, but finally understood it was only accepting a range as input, not a single value, so in your case you should put: mvn versions:update-parent -DparentVersion=[1.0,1.1] This should select 1.1 if it exists in your repository. Got the clue reading tickets in plugin bug tracker

Categories : Maven

How to release an iOS app as worldwide which was release with Italian as the language in the first version?
The third Question answers my query. https://vpp.itunes.apple.com/faq 3. Can I distribute redemption codes to employees who are not located in my country? No. Apps can only be distributed to employees with Apple IDs located in the same country where the apps were purchased. To distribute redemption codes in other countries, you must enroll your business in the Volume Purchase Program for every eligible country in which you wish to purchase and distribute apps.

Categories : IOS

Which Linux platfrom required for Installation of ingres database version 9.2 and openROAD version 4.0
If you want answers don't use Stackoverflow as its ridiculous policies prevent me supplying the four links that would have been helpful to you. Google for the Actian community, which you will find far more helpful with fewer egos struggling to rule the world.

Categories : Misc

Why isn't maven replacing the environment variable for the maven-release-plugin release version?
you will have to use the arguments attribute: http://maven.apache.org/maven-release/maven-release-plugin/prepare-mojo.html#arguments So in your context your cmd line will look like this (Note the double quotes as well): mvn release:clean --batch-mode release:prepare "-Darguments=-Dtag=${env.tag} -Dproject.rel.com.mycompany.project:project-root=${env.project.rel.com.mycompany.project:project-root} -Dproject.dev.com.mycompany.project:project-root=${env.project.dev.com.mycompany.project:project-root}" Furthermore, if i remember right the uses of the tokens ${env.X} requires the usage of the property name in upper case (to be verified)

Categories : Java

How can I get version of release before updating application?
You can use PackageManager for this purpose. I have successfully used this code in my app: PackageInfo info = context.getPackageManager().getPackageArchiveInfo(apkPath, PackageManager.GET_META_DATA); if(info != null) { ApplicationInfo appInfo = info.applicationInfo; if(Build.VERSION.SDK_INT >= 8) { appInfo.sourceDir = apkPath; appInfo.publicSourceDir = apkPath; } String version = info.versionName; int vcode = info.versionCode; }

Categories : Android

Double changing value on release version?
You ignored the "variable amountComplete is used uninitialized" warnings. Change the declarations to double amountComplete = 0; double possibleTotal = 0; (In debug mode, entirely by accident, these variables' storage locations happen to contain floating-point zeroes on entry to the loop. Remember, undefined behavior includes the possibility of everything appearing to work just fine.)

Categories : Iphone

Which version of patch-release to build?
if you don't find particular version, that means product is released with older version of jars.. In your case, you might need to build 4.0.2.. Anyway if you do online build, if jars are available in the repo, they will be downloaded..You don't need to build older versions.. If not, you have to..

Categories : Wso2

In MVC 4, release mode is not generating .min version
I found another message (Running the ASP mvc 4 app in release mode does not bundle and minifiy the js files) that had a workaround that makes it work. Basically, I add the following to the Application_Start in Global.asax.cs: #if !DEBUG BundleTable.EnableOptimizations = true; #endif This fixes it (or at least, makes it behave the way I expected it to behave). Thanks, -D

Categories : Asp Net Mvc

Make a release from an already released version with CVS
You can do it as follow : Suppose that the your tag is 1.0 1 - create a new branch (named for example 1.0-hotfix) from the tag of release (1.0 ) 2 - checkout the new branch in another local directory 3 - Make changes to your source, commit and release ! 4 - finally merge the branch into HEAD

Categories : Maven

In-App-Purchase invalid product id only on release version
It turns out in app purchases are magic. At around 8 pm we noticed that things started working normally. We had previously filed a request for help from Apple but never received a response so I'm not sure if that's what kicked off the fix or if it was just one of those things we needed to wait on.

Categories : IOS

Set the release version for NetBeans RCP application Windows installer
I got the same problem today, and after I changed these lines product.version on {nbdir}harness bistubextinfrauildproductshelloworlduild.properties version attribute on create-bundle > component on {nbdir}harness bistubuild.xml with the same value (your new version), I can use my new installer to install the newer app side-by-side with older app. Hope it helps.

Categories : Misc

How to release android update version of app for regular and pre-installed app
Let's say your pre-release app has versionCode=1. The first version of deployed on Google Play app was also 1. But as you've said, you already have 2 updates on it and google play forced you to increment version number, let's say to 3. In conclusion, if user has pre installed app - his version code will be 1. If he updated from market - most probably he will have latest version number -3. Or at least two. The point is that you can be pretty sure that at that moment of time, when you already published two updates, users, who have version=1 are users with preisntalled app, while users with version>1 are users with app from market. Considering this, you can use the app version number from GA to differentiate these users. Does that make sense?

Categories : Android

using the release version of boost libs in debug mode
Short answer: You don't. Boost uses parts of the C++ runtime which work differently in Debug and Release so stuff is likely to break eventually. However, if you absolutely want to shoot yourself in the foot: You can prevent automatic linking by setting the BOOST_ALL_NO_LIB preprocessor flag and then manually link to the release binary instead.

Categories : C++

Is there any way to find out the ruby version used by a past heroku release?
It's somewhat crude, but you could roll back to the previous release and do $ heroku run bash $ ruby --version

Categories : Ruby

Automatically change map key based on debug or release version
The best thing you can do it not to have to change it at all. First of all, you can check in the API_KEY into your repository even if it is public. Nobody can use the key without having your debug or release keystore (and passwords). Secondly, you can assign a single API key multiple SHA-1;package pairs in the Google APIs Console.

Categories : Android

Qt Creator. Why do I get an error about glut when compiling release version, but not debug?
For static single executables you will first need a commercial license for QT. This being said you can change the mkspecs in $QTDIRmkspecs$COMPILERVERSIONqmake.conf to use static linking. For example win32-msvc2008 (2008 Visual Studio Compiler) set CFLAGS and CXXFLAGS from QMAKE_CFLAGS_RELEASE = -O2 -MD to QMAKE_CFLAGS_RELEASE = -O2 -MT (MD => MT, MDd => MTd). Furthormore you will static libs of QT and GLUT. These typically end in .lib (not .dll). You probably will need to compile QT from Source for getting static-compatible libraries. When compiling QT remember to compile with opengl support. There is a good documentation at http://qt-project.org/wiki/Build_Static_Qt_For_Windows_With_Gcc_German for gcc, and you can also find examples for MSVC. After these prerequisites are me

Categories : C++

No version prompt when running maven-release-plugin inside Eclipse
This is normal. The Eclipse plugin for Release will automatically release the version set in your POM, and set the next development version to +0.0.1 of that. I'm used to using the release plugin from inside Eclipse, and when I used it from command prompt I was surprised when I was prompted for version :p

Categories : Eclipse

Visual C++ Release build - is string getting corrupted when passed across DLL because compiled with different runtime version?
If you pass non-POD (plain old datatypes) between DLL/EXE boundaries (like STL string or CRT FILE pointers) you must use the same shared CRT. In your case, you must recompile all DLLs/LIBs with the same compiler! See also: I can pass std::string for a Dll and what i can do with DLL´s?

Categories : Visual C++

Local version works but the production version does not
The problem appears to be an open comment (*/) in one of my CSS files. This came to my attention when I attempted to compile the assets with the command: RAILS_ENV=production bundle exec rake assets:precompile and got the error... rake aborted! Invalid CSS after "*/": expected identifier, was "/* Sections" I deleted the extraneous "*/", forced a push to Heroku (git push -f heroku master), deleted index.html and voila the right page was served. Thank you to all for the help and recommendations!

Categories : Ruby On Rails

Is a library ,created in .net version 4.0, access with in the lower version from its version
Create a library in .Net 2.0 Framework so there will be no issue with higher versions, you can set the version from project properties (right click the project and select properties in visual studio) Select Application tab from properties window and select Target Framework combobox select .Net Framework 2.0

Categories : C#

How to fix TPM in Redhat Linux? RedHat Linux hang on first time to boot after installing
After all my search I found out that in Redhat 6 there is a problem tboot and best way to fix it is to remove tboot package (it is located in System Base>Base>tboot.6) For more info about tboot you can check these links: enter link description here

Categories : Linux

Why /lib/ld-linux.so.2 soname version bumps are so rare?
Whenever a library is changed in a way that old programs do not work with the new version of the library this number is chaned. If old programs will still work with the newer library (and programs needing the new version will not cause a crash with the old library) there is no need to change the number because you can simply install the latest version of the library. As far as I understand the "2" (it was "1" ten years ago) should not change any longer. The reason is simple: The first version of "ld-linux.so.2" was written in a way that any version of "ld-linux.so.2" should work with any program using this file - maybe printing an error message when an older version of "ld-linux.so.2" is used. This means: It is never necessary to install two different "ld-linux.so.2" files but it is eno

Categories : Linux

Python Smtp SSL wrong version on linux
I bet the problem is on the other side of the wire. Hello, Microsoft! I've tried logging in a number of times, and you won't believe me, but some servers will let me in, while others won't. Try doing smtp.ehlo() in order to find the server's hostname (by the way, you must issue EHLO at the beginning of your session, and immediately after STARTTLS). All their servers have names BLU0-SMTP<somenumber>phx.gbl. Believe me or not, but servers with two digits in their name are OK, but those with three digits are not. In [52]: s = smtplib.SMTP('smtp.live.com', port=587) In [53]: s.ehlo() Out[53]: (250, 'BLU0-SMTP17.phx.gbl Hello [188.134.8.114] TURN SIZE 41943040 ETRN PIPELINING DSN ENHANCEDSTATUSCODES 8bitmime BINARYMIME CHUNKING VRFY TLS STARTTLS OK') In [54]: s.starttls() Out[54]: (

Categories : Python

Meaning of version info in .mod.c file in Linux kernel
The __versions section contained in all the individual *.mod.c files CRC Symbol { 0xa6d8dcb5, "module_layout" }, { 0x16c2b958, "register_netdevice" }, ... ... is a list of symbols and their corresponding CRCs. This has 2 main uses : Global list of all exported symbols. Module versioning check when loading ko modules. Rationale behind Module versioning Module versioning is enabled by the CONFIG_MODVERSIONS tag, and is used as a simple ABI consistency check. A CRC value of the full prototype for an exported symbol is created. When a module is loaded/used, the CRC values contained in the kernel are compared with similar values in the module; if they are not equal, the kernel refuses to load the module as it indicates that the module is built with

Categories : C

Libgdx Version Nightly Build or Release Build? Action Package Different
The Libgdx nightly builds have a lot of API changes accumulated in them (its been a while since the 0.9.8 release). Mario & Co. try to document any such API changes in blog posts, so if you're following the nightly builds, you'll definitely want to keep up with the blog. The "CHANGES" file in the nightly distribution also has notes on what has changed (but I think this may not have some early changes in it). Its hard to know what version a 3rd party blog or article is talking about if they don't explicitly list the version. You can sometimes go by the date on the article, though. Anyway, I think its safe to use either the "stable" build or the nightlies. There are non-trivial API changes when switching between the two versions, so you'll want to stick with one for a while, but th

Categories : Misc

How to compile ixgbe network drivers on other linux kernel version
Install the kernel-devel rpm for 2.6.39.4 and compile against the new kernel. In Makefile use the Kernel directory as 2.6.39.4. Usually located in /usr/src/kernels/

Categories : Linux

/lib/libc.so.6: version `GLIBC_2.9' not found error while installing Qt5 on Linux
Don't mess with the system libraries -- just upgrade your distribution. Glibc 2.11 has been released in 2009, that's four years ago.

Categories : Linux

Installing subversion under /apps other than /var/www/ is not working. Centos Linux version
In the httpd.conf file your Document Root Section probally says <Directory "/var/www"> Also you can give apache ownership of that directory but only if such is placed in the document root. (If I understand you this may not work for you) chown -R apache.apache /apps Apache can access items outside the root but that is soemthing I am not familiar with and you can look into the apache Alias EDIT As the comment under your OP says SVNADMIN should be able to create the repo and you should be able to hit it. mkdir /app/svn svnadmin create /app/svn/testrepository chown svn:svn -R /app/svn Subversion also is very nice about keeping space low since it only stores revisions to projects instead or brand new versions each time. EDIT Setup Walkthrough - Posted in comments

Categories : Svn

TimePicker works fine on version 4 android, but in version 2.3 crash bug. (Android)
You have infinite recursion. Your onTimeChanged() calls updateTime() on the time picker which in turn leads to another call to onTimeChanged(). One way to fix it is to add a boolean flag in your class to prevent recursive calls to updateTime(). Something like: boolean mIsOnTimeChanged; @Override public void onTimeChanged(TimePicker view, int hourOfDay, int minute) { if (!mIsOnTimeChanged) { mIsOnTimeChanged = true; // your regular onTimeChanged() here mIsOnTimeChanged = false; } }

Categories : Android

on Linux, how can I resolve WARNING: Nokogiri was built against LibXML version 2.8.0, but has dynamically loaded 2.9.0 ?
The implicit question here seems to be "why am I getting this warning, and what can I do about it?" You are getting the warning because Nokogiri was built (it is a largely native-extension gem, requiring compilation) against LibXML version 2.8.0, and your system has since upgraded LibXML to version 2.9.0. This is a warning, not at error -- in many cases, Nokogiri will continue to work fine with a newer version of LibXML than it was built against. If you run into problems or just want to be on the safe side, rebuilding Nokogiri will solve the issue -- it will be built against the version of LibXML currently installed.

Categories : Ruby On Rails

How can I ensure a Perl script works with an older version?
perlver, Perl::MinimumVersion::Fast

Categories : Perl

How do I substitute special characters with escaped version in a Bash script
I think this is the proper form for that: _INFO=${_INFO// / } _INFO=${_INFO// /\ } _INFO=${_INFO//" "/" "} _INFO=${_INFO//" "/"\ "} _INFO=${_INFO//' '/' '} _INFO=${_INFO//' '/'\ '} When using parameter substitution form ${parameter/pattern/string}, you shouldn't add $ before your parameter inside {}. See more about parameter expansion here: http://www.gnu.org/software/bash/manual/html_node/Shell-Parameter-Expansion.html

Categories : Linux

Detect version of tomcat when WAR file starts (possibly stop it if it is not on the recommended version)
Straight from Tomcat FAQ: How to I get Tomcat's version number? javax.servlet.ServletContext.getServerInfo(); Starting with Tomcat 5.0.28 - there is now a version.sh (or version.bat) program in the bin directory. It will print the version number of Tomcat to Standard output.

Categories : Tomcat

Calling https version of TYPO3: content (css, js, ..) is blocked because link to http version
I used config { baseURL = https://domain.com } and adapted all links which had a http in the beginning (otherwise the slider stopped working because Chrome didn't load the other ressources ...). Seems to work now.

Categories : Http

VSTO Debug version fine, Installed version doesn't read app.config
You need to add app.Config File to your Setup Project but not from the actual project do it from the ReleaseDebug folder of the ExcelAddIn project. When you build you ExcelAddIn project it will leave App.config File to the ReleaseDebug Folder, piCk the file form there and include it into the dependicies folder of the Setup Project.

Categories : Visual Studio 2010

Debug mode on my RubyMine version 4.0.1 stopped working after upgrade ruby version to 2.0.0
Please update to RubyMine 5.4.2, it will install the correct debug gem version. RubyMine versions before 5.x do not support Ruby 2.0 debugging. 5.x versions install the following gem for Ruby 2.0: ruby-debug-ide (0.4.17) Note that linecache and ruby-debug-base gems are not needed and are not installed by RubyMine 5 when using Ruby 2.0. If ruby-debug-ide gem doesn't install from RubyMine for some reason, please try installing it from the terminal: gem install ruby-debug-ide

Categories : Ubuntu

Attempt to update step execution id=1 with wrong version (2), where current version is 1
I had this same exception. org.springframework.dao.OptimisticLockingFailureException: Attempt to update step execution id=0 with wrong version (2), where current version is 3 In my case, it was caused by a failure the process step, which was being swallowed. Spring Batch activated the writer, even though the processor had failed. Look through your logs to make sure that your process step is completing and returning something.

Categories : Misc

Grails adding version to command object causes id and version from params not to be bound
Seems this is by design per Jeff Brown jira The data binding explicitly avoids binding id or version [if] they both exist and does this by design. This is a shield against potential security problems relevant to data binding as it relates to domain classes. A simple work around for command objects would be to name the properties with something like "idValue" and "versionValue" or anything other than "id" and "version".

Categories : Grails

'dependencies.dependency.version' is missing error, but version is managed in parent
In theory, maven does not allow to use a property to set a parent version. In your case, maven can simply not figure out that the 0.0.1-SNAPSHOT version of your parent pom is the one that is currently in your project, and so it tries to find it in your local repo. It probably finds one since it is a snapshot, but it is an old version that probably not contains your Dependency Management section. There is a workaround though : Simply change the parent section in the child pom with this : <parent> <groupId>com.sw.system4</groupId> <artifactId>system4-parent</artifactId> <version>${system4.version}</version> <relativePath>../pom.xml</relativePath> <!-- this must match your parent pom location --> </parent>

Categories : Java

The database cannot be opened because it is version 706. This server supports version 655 and earlier. A downgrade path is not supported
Version 706 is a database file from Sql Server 2012 Version 665 is a database file from Sql Server 2008R2 (post SP1 ?) http://conceptdev.blogspot.com/2009/04/mdf-cannot-be-opened-because-it-is.html

Categories : C#



© Copyright 2017 w3hello.com Publishing Limited. All rights reserved.